aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/cwm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-01-05 05:32:07 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-01-05 05:32:07 +0000
commiteee96d8fe8ff133c30720f5032d52a223484f943 (patch)
tree4ec85aa888ebbe8aa2220e0a04a85153e4a5865b /x11-wm/cwm
parentb9608053c7b17d0e1d2661a1b639c28ede13201e (diff)
downloadports-eee96d8fe8ff133c30720f5032d52a223484f943.tar.gz
ports-eee96d8fe8ff133c30720f5032d52a223484f943.zip
x11-wm/cwm: Update to 6.6
- After >2 years stop installing the config migration script - Drop conditional post-patch. DragonFly has reallocarray in its libc too nowadays. We can just have one static patch now. Changes: https://github.com/leahneukirchen/cwm/blob/v6.6/README
Notes
Notes: svn path=/head/; revision=522109
Diffstat (limited to 'x11-wm/cwm')
-rw-r--r--x11-wm/cwm/Makefile27
-rw-r--r--x11-wm/cwm/distinfo6
-rw-r--r--x11-wm/cwm/files/patch-Makefile14
3 files changed, 24 insertions, 23 deletions
diff --git a/x11-wm/cwm/Makefile b/x11-wm/cwm/Makefile
index 4ded020dc119..d662889d8b9e 100644
--- a/x11-wm/cwm/Makefile
+++ b/x11-wm/cwm/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cwm
-DISTVERSION= 6.3
+DISTVERSION= 6.6
CATEGORIES= x11-wm
MASTER_SITES= https://leahneukirchen.org/releases/
@@ -13,30 +13,17 @@ LICENSE= ISCL
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= pkgconfig shebangfix xorg
-USE_XORG= x11 xft xinerama xrandr
-
+USES= pkgconfig xorg
+USE_XORG= x11 xft xrandr
+MAKE_ARGS= MANPREFIX="${MANPREFIX}/man"
PLIST_FILES= bin/cwm \
- bin/cwm-migrate-config.pl \
man/man1/cwm.1.gz \
man/man5/cwmrc.5.gz
-SHEBANG_FILES= migrate-config.pl
-
-.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} 's@/usr/X11R6@${LOCALBASE}@' ${WRKSRC}/cwmrc.5
- @${REINPLACE_CMD} -e 's@strlcpy.o strlcat.o@@' \
- -e 's@strtonum.o@@' ${WRKSRC}/Makefile
-.if ${OPSYS} == FreeBSD
- @${REINPLACE_CMD} 's@reallocarray.o@@' ${WRKSRC}/Makefile
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cwm ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/migrate-config.pl \
- ${STAGEDIR}${PREFIX}/bin/cwm-migrate-config.pl
- ${INSTALL_MAN} ${WRKSRC}/cwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/cwmrc.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cwm
.include <bsd.port.mk>
diff --git a/x11-wm/cwm/distinfo b/x11-wm/cwm/distinfo
index b2600f62b5d7..04ea03c37b0c 100644
--- a/x11-wm/cwm/distinfo
+++ b/x11-wm/cwm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526324643
-SHA256 (cwm-6.3.tar.gz) = 4cd57ffac72841c128cccaea8ba210679d8913cd841690861d56c0e758baed9e
-SIZE (cwm-6.3.tar.gz) = 52419
+TIMESTAMP = 1578172523
+SHA256 (cwm-6.6.tar.gz) = 223d086dbebfb2f35f05af0c72c3d1b04fdd341123121c65105524ebd605655c
+SIZE (cwm-6.6.tar.gz) = 53062
diff --git a/x11-wm/cwm/files/patch-Makefile b/x11-wm/cwm/files/patch-Makefile
new file mode 100644
index 000000000000..486ccc37eafe
--- /dev/null
+++ b/x11-wm/cwm/files/patch-Makefile
@@ -0,0 +1,14 @@
+Prefer libc version over custom strlcpy, strlcat, reallocarray, strtonum
+
+--- Makefile.orig 2020-01-04 21:20:03 UTC
++++ Makefile
+@@ -11,8 +11,7 @@ SRCS= calmwm.c screen.c xmalloc.c client.c menu.c \
+
+ OBJS= calmwm.o screen.o xmalloc.o client.o menu.o \
+ search.o util.o xutil.o conf.o xevents.o group.o \
+- kbfunc.o strlcpy.o strlcat.o y.tab.o \
+- strtonum.o reallocarray.o
++ kbfunc.o y.tab.o
+
+ CPPFLAGS+= `pkg-config --cflags x11 xft xrandr`
+