aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e-module-mem
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2014-11-25 03:07:22 +0000
commit273c6e6d76de909e0b97d381d45340af8e91a37e (patch)
treea3ede366da71e5f2c9d8a5565a987a08de3b99d0 /x11-wm/e-module-mem
parente688f6929aa312916047cec14f32a26ac695505a (diff)
downloadports-273c6e6d76de909e0b97d381d45340af8e91a37e.tar.gz
ports-273c6e6d76de909e0b97d381d45340af8e91a37e.zip
- Merge EFL libraries into devel/efl and update to 1.12.0
- Update x11-toolkits/elementary to 1.12.0 - Update x11-wm/enlightenment to 0.19.1 - Update graphics/evas_generic_loaders-* to 1.12.0 - Update devel/e_dbus to 1.7.10 - Update benchmarks/expedite to 1.7.10 - Move some of x11-wm/e17-module-* to x11-wm/e-module-* and update to recent snapshots - Add multimedia/emotion_generic_players-vlc - Add multimedia/rage Reviewed by: crees, antoine
Notes
Notes: svn path=/head/; revision=373393
Diffstat (limited to 'x11-wm/e-module-mem')
-rw-r--r--x11-wm/e-module-mem/Makefile36
-rw-r--r--x11-wm/e-module-mem/distinfo2
-rw-r--r--x11-wm/e-module-mem/files/patch-src-e_mod_main.c17
-rw-r--r--x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c51
-rw-r--r--x11-wm/e-module-mem/pkg-descr6
-rw-r--r--x11-wm/e-module-mem/pkg-plist35
6 files changed, 147 insertions, 0 deletions
diff --git a/x11-wm/e-module-mem/Makefile b/x11-wm/e-module-mem/Makefile
new file mode 100644
index 000000000000..9cbb9c790dba
--- /dev/null
+++ b/x11-wm/e-module-mem/Makefile
@@ -0,0 +1,36 @@
+# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
+# $FreeBSD$
+
+PORTNAME= e-module-mem
+PORTVERSION= 20140705
+PORTEPOCH= 1
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= LOCAL/gblach/enlightenment/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Enlightenment memory monitoring module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= enlightenment
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig tar:xz
+INSTALL_TARGET= install-strip
+
+.include "../enlightenment/Makefile.plist"
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e-module-mem/distinfo b/x11-wm/e-module-mem/distinfo
new file mode 100644
index 000000000000..a2d3dd829ca8
--- /dev/null
+++ b/x11-wm/e-module-mem/distinfo
@@ -0,0 +1,2 @@
+SHA256 (enlightenment/e-module-mem-20140705.tar.xz) = f80f30fde81797bc7350b8d0ef235510997d150528ff6899217b2969b3f13dbd
+SIZE (enlightenment/e-module-mem-20140705.tar.xz) = 310620
diff --git a/x11-wm/e-module-mem/files/patch-src-e_mod_main.c b/x11-wm/e-module-mem/files/patch-src-e_mod_main.c
new file mode 100644
index 000000000000..277054f8ed5c
--- /dev/null
+++ b/x11-wm/e-module-mem/files/patch-src-e_mod_main.c
@@ -0,0 +1,17 @@
+diff -ur src.old/e_mod_main.c src/e_mod_main.c
+--- src.old/e_mod_main.c 2010-11-13 17:56:21.000000000 +0200
++++ src/e_mod_main.c 2012-02-21 23:43:46.548797357 +0200
+@@ -424,11 +424,9 @@
+
+ if (!inst->ci->show_percent)
+ {
+- snprintf (real_str, sizeof (real_str), "Real: %d/%d MB", (real / 1024),
+- (total_real / 1024));
++ snprintf (real_str, sizeof (real_str), "Real: %d/%d MB", real, total_real);
+ if ( total_swap )
+- snprintf (swap_str, sizeof (swap_str), "Swap: %d/%d MB", (swap / 1024),
+- (total_swap / 1024));
++ snprintf (swap_str, sizeof (swap_str), "Swap: %d/%d MB", swap, total_swap);
+ }
+ else
+ {
diff --git a/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c b/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c
new file mode 100644
index 000000000000..5b14b15912c9
--- /dev/null
+++ b/x11-wm/e-module-mem/files/patch-src-machdep_freebsd.c
@@ -0,0 +1,51 @@
+diff -ur src.old/machdep_freebsd.c src/machdep_freebsd.c
+--- src.old/machdep_freebsd.c 2010-11-13 17:56:21.000000000 +0200
++++ src/machdep_freebsd.c 2012-02-21 23:18:00.000000000 +0200
+@@ -12,6 +12,8 @@
+
+ #define GETSYSCTL(name, var) getsysctl(name, &(var), sizeof (var))
+
++#define PAGES_PER_MEG ((1024 * 1024) / getpagesize())
++
+ static int
+ getsysctl (char *name, void *ptr, size_t len)
+ {
+@@ -32,7 +34,6 @@
+ static int
+ swapinfo (int *total, int *used)
+ {
+- int pagesize = getpagesize ();
+ size_t mibsize, size;
+ struct xswdev xsw;
+ int mib[16], n;
+@@ -61,8 +62,8 @@
+ return 1;
+ }
+
+- tmp_total = (long long) xsw.xsw_nblks * pagesize;
+- tmp_used = (long long) xsw.xsw_used * pagesize;
++ tmp_total = xsw.xsw_nblks / PAGES_PER_MEG;
++ tmp_used = xsw.xsw_used / PAGES_PER_MEG;
+ *total += tmp_total;
+ *used += tmp_used;
+ }
+@@ -82,8 +83,6 @@
+ {
+ int total_pages, inactive_pages, free_pages;
+
+- int pagesize = getpagesize ();
+-
+ if (GETSYSCTL ("vm.stats.vm.v_page_count", total_pages))
+ {
+ warnx ("can't read sysctl \"vm.stats.vm.v_page_count\"");
+@@ -102,8 +101,8 @@
+ return;
+ }
+
+- *phys_total = (total_pages * pagesize) >> 10;
+- *phys_used = ((total_pages - free_pages - inactive_pages) * pagesize) >> 10;
++ *phys_total = total_pages / PAGES_PER_MEG;
++ *phys_used = (total_pages - free_pages - inactive_pages) / PAGES_PER_MEG;
+
+ if ((swapinfo (sw_total, sw_used)) != 0)
+ {
diff --git a/x11-wm/e-module-mem/pkg-descr b/x11-wm/e-module-mem/pkg-descr
new file mode 100644
index 000000000000..a68c0ab3c5b7
--- /dev/null
+++ b/x11-wm/e-module-mem/pkg-descr
@@ -0,0 +1,6 @@
+An E17 module which monitors the RAM usage. It features the following:
+- display text and/or graph
+- display text in percentage or absolute
+
+Author: Matthew Mullins
+WWW: http://www.enlightenment.org
diff --git a/x11-wm/e-module-mem/pkg-plist b/x11-wm/e-module-mem/pkg-plist
new file mode 100644
index 000000000000..d0479b549993
--- /dev/null
+++ b/x11-wm/e-module-mem/pkg-plist
@@ -0,0 +1,35 @@
+lib/enlightenment/modules/mem/e-module-mem.edj
+lib/enlightenment/modules/mem/module.desktop
+lib/enlightenment/modules/mem/mem.edj
+lib/enlightenment/modules/mem/%%ENLIGHTENMENT_ARCH%%/module.a
+lib/enlightenment/modules/mem/%%ENLIGHTENMENT_ARCH%%/module.so
+%%NLS%%lib/enlightenment/modules/mem/locale/sk/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/tr/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/it/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/eo/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/fi/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/sv/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/zh_CN/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/ru/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/de/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/ja/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/uk/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/el/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/fr/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/nl/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/cs/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/ar/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/he/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/lt/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/pl/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/es/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/hu/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/pt/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/pt_BR/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/nb/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/hr/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/bg/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/sl/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/ca/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/gl/LC_MESSAGES/mem.mo
+%%NLS%%lib/enlightenment/modules/mem/locale/sr/LC_MESSAGES/mem.mo