aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fluxbox/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-19 01:27:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-19 01:27:20 +0000
commitf301086144127ef7c88166ddb0bc955b0852ccc2 (patch)
tree24717299246ce01abc704a29cc25ca91d69ecc58 /x11-wm/fluxbox/Makefile
parent840ccd20d14a96aa97cd26e1531f1c5116f3ce96 (diff)
downloadports-f301086144127ef7c88166ddb0bc955b0852ccc2.tar.gz
ports-f301086144127ef7c88166ddb0bc955b0852ccc2.zip
- Stage support
Notes
Notes: svn path=/head/; revision=344981
Diffstat (limited to 'x11-wm/fluxbox/Makefile')
-rw-r--r--x11-wm/fluxbox/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index ad9ffb851fa9..2acd52eefce0 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -21,10 +21,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-MAN1= fbrun.1 fbsetbg.1 fbsetroot.1 fluxbox.1 \
- startfluxbox.1 fluxbox-remote.1
-MAN5= fluxbox-apps.5 fluxbox-keys.5 fluxbox-menu.5 \
- fluxbox-style.5
+
DOCSVERSION= 20060629
OPTIONS_DEFINE= DOCS DOCHTML PDFDOCS DEBUG GNOME IMLIB2 XINERAMA \
@@ -38,7 +35,6 @@ SYSTRAY_DESC= Enable systray feature
TOOLBAR_DESC= Enable toolbar feature
XRENDER_DESC= Enable xrender support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
@@ -140,21 +136,19 @@ post-patch:
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.if ${PORT_OPTIONS:MPDFDOCS}
- @${MKDIR} ${DOCSDIR}/pdf
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/pdf
${INSTALL_DATA} ${DISTDIR}/fluxbook-${DOCSVERSION}.pdf \
- ${DOCSDIR}/pdf/
+ ${STAGEDIR}${DOCSDIR}/pdf/
.endif
.if ${PORT_OPTIONS:MDOCHTML}
- @${MKDIR} ${DOCSDIR}/html
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
. for h in *.css *.html
- (cd ${WRKDIR}/html && ${INSTALL_DATA} ${h} ${DOCSDIR}/html)
+ (cd ${WRKDIR}/html && ${INSTALL_DATA} ${h} ${STAGEDIR}${DOCSDIR}/html)
. endfor
.endif