aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/jewel/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-11-20 17:32:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-11-20 17:32:19 +0000
commit34ddc09eb226061fda6dba25cf85dcd143b207ef (patch)
treebde7a38cd7e188fde035d62f96324cf25a1e4777 /x11-wm/jewel/Makefile
parent3ea99a55c14aa5a119e89ffebb0a7b5101c47c85 (diff)
downloadports-34ddc09eb226061fda6dba25cf85dcd143b207ef.tar.gz
ports-34ddc09eb226061fda6dba25cf85dcd143b207ef.zip
- Cosmetic fixes, simplify docs handling and don't install license as documentation
Notes
Notes: svn path=/head/; revision=485441
Diffstat (limited to 'x11-wm/jewel/Makefile')
-rw-r--r--x11-wm/jewel/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-wm/jewel/Makefile b/x11-wm/jewel/Makefile
index 83a9e527780b..a6613116887c 100644
--- a/x11-wm/jewel/Makefile
+++ b/x11-wm/jewel/Makefile
@@ -13,11 +13,10 @@ COMMENT= Window manager based on aewm++
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
-ALL_TARGET= all
-DOCS= Changelog Changelog.DLR Changelog.jewel INSTALL LICENSE README
-PORTDOCS= *
USES= compiler gmake
USE_XORG= x11 xext xpm
+ALL_TARGET= all
+PORTDOCS= Changelog Changelog.DLR Changelog.jewel INSTALL README
MAKE_ARGS= CFLAGS="${CXXFLAGS}"
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
@@ -27,7 +26,7 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
- ${REINPLACE_CMD} -i '' -e 's|g++|${CXX}|g; s|gcc|${CC}|g'
+ ${REINPLACE_CMD} -i '' -e 's|g++|${CXX}|g; s|gcc|${CC}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jewel ${STAGEDIR}${PREFIX}/bin/jewel
@@ -39,7 +38,7 @@ do-install:
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for ii in ${DOCS}
+.for ii in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${ii} ${STAGEDIR}${DOCSDIR}
.endfor