aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/lxqt-panel
diff options
context:
space:
mode:
authorJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-08-03 13:19:06 +0000
committerJesper Schmitz Mouridsen <jsm@FreeBSD.org>2018-08-03 13:19:06 +0000
commitb426ced11366f49a078e9bf7827cc418eda40b46 (patch)
treec120da314d592d149badcf808366e24d2724d8de /x11-wm/lxqt-panel
parent5a6d3d997aabbf5690188ab1acfa33e9300c5407 (diff)
downloadports-b426ced11366f49a078e9bf7827cc418eda40b46.tar.gz
ports-b426ced11366f49a078e9bf7827cc418eda40b46.zip
New port x11-wm/lxqt-panel
PR: 229297 Approved by: miwi (mentor) Differential Revision: https://reviews.freebsd.org/D16542
Notes
Notes: svn path=/head/; revision=476292
Diffstat (limited to 'x11-wm/lxqt-panel')
-rw-r--r--x11-wm/lxqt-panel/Makefile60
-rw-r--r--x11-wm/lxqt-panel/distinfo3
-rw-r--r--x11-wm/lxqt-panel/files/patch-panel_resources_panel.conf11
-rw-r--r--x11-wm/lxqt-panel/files/patch-plugin-kbindicator_src_x11_kbdlayout.cpp15
-rw-r--r--x11-wm/lxqt-panel/pkg-descr4
-rw-r--r--x11-wm/lxqt-panel/pkg-plist35
6 files changed, 128 insertions, 0 deletions
diff --git a/x11-wm/lxqt-panel/Makefile b/x11-wm/lxqt-panel/Makefile
new file mode 100644
index 000000000000..50c4becba432
--- /dev/null
+++ b/x11-wm/lxqt-panel/Makefile
@@ -0,0 +1,60 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= lxqt-panel
+PORTVERSION= 0.13.0
+CATEGORIES= x11-wm
+MASTER_SITES= LXQT
+
+MAINTAINER= jsm@FreeBSD.org
+COMMENT= Panel for the LXQt desktop
+
+LICENSE= LGPL21+
+
+LIB_DEPENDS= libdbusmenu-qt5.so:devel/libdbusmenu-qt@qt5 \
+ libxkbcommon.so:x11/libxkbcommon \
+ libxcb-util.so:x11/xcb-util \
+ libsysstat-qt5.so:sysutils/libsysstat
+RUN_DEPENDS= lxmenu-data>=0.1.2:x11/lxmenu-data
+
+USES= cmake:outsource compiler:c++11-lib gettext-runtime kde:5 qt:5 \
+ localbase:ldflags lxqt pkgconfig tar:xz
+USE_QT= buildtools_build qmake_build core dbus gui svg widgets \
+ x11extras xml
+USE_KDE= windowsystem
+USE_LXQT= buildtools lxqt globalkeys qtxdg
+USE_XORG= ice sm x11 xcb xcomposite xdamage xext xfixes xrender
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+OPTIONS_RADIO= SOUND
+OPTIONS_RADIO_SOUND= ALSA PULSEAUDIO
+OPTIONS_DEFINE= CPULOAD MOUNT
+OPTIONS_DEFAULT= PULSEAUDIO
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ALSA_CMAKE_ON= -DVOLUME_USE_PULSEAUDIO:BOOL=OFF
+CPULOAD_LIB_DEPENDS= libstatgrab.so:devel/libstatgrab
+CPULOAD_CMAKE_OFF= -DCPULOAD_PLUGIN:BOOL=OFF
+CPULOAD_DESC= CPU stat plugin
+PULSEAUDIO_CMAKE_ON= -DVOLUME_USE_ALSA:BOOL=OFF
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+MOUNT_USE= kde=solid
+MOUNT_CMAKE_OFF= -DMOUNT_PLUGIN:BOOL=OFF
+MOUNT_DESC= Mount removable devices support
+OPTIONS_SUB= yes
+
+LDFLAGS+= -Xlinker --export-dynamic
+
+CMAKE_ARGS+= -DSENSORS_PLUGIN:BOOL=OFF \
+ -DNETWORKMONITOR_PLUGIN:BOOL=OFF \
+ -DWITH_SCREENSAVER_FALLBACK:BOOL=OFF
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MALSA} && ! ${PORT_OPTIONS:MPULSEAUDIO}
+CMAKE_ARGS+= -DVOLUME_PLUGIN:BOOL=OFF
+PLIST_SUB+= SOUND="@comment "
+.elif ${PORT_OPTIONS:MALSA} || ${PORT_OPTIONS:MPULSEAUDIO}
+PLIST_SUB+= SOUND=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/lxqt-panel/distinfo b/x11-wm/lxqt-panel/distinfo
new file mode 100644
index 000000000000..f00e8d52ae91
--- /dev/null
+++ b/x11-wm/lxqt-panel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527328541
+SHA256 (lxqt/lxqt-panel-0.13.0.tar.xz) = a139dc43d19adf6b7674e7ad518772aebf033aefcb1767b05085d983ff8b2ae3
+SIZE (lxqt/lxqt-panel-0.13.0.tar.xz) = 273924
diff --git a/x11-wm/lxqt-panel/files/patch-panel_resources_panel.conf b/x11-wm/lxqt-panel/files/patch-panel_resources_panel.conf
new file mode 100644
index 000000000000..1094b2391c41
--- /dev/null
+++ b/x11-wm/lxqt-panel/files/patch-panel_resources_panel.conf
@@ -0,0 +1,11 @@
+--- panel/resources/panel.conf.orig 2018-05-26 09:42:02 UTC
++++ panel/resources/panel.conf
+@@ -1,7 +1,7 @@
+ panels=panel1
+
+ [panel1]
+-plugins=mainmenu,desktopswitch,quicklaunch,taskbar,tray,statusnotifier,mount,volume,worldclock,showdesktop
++plugins=mainmenu,desktopswitch,quicklaunch,taskbar,tray,statusnotifier,volume,worldclock,showdesktop
+ position=Bottom
+ desktop=0
+
diff --git a/x11-wm/lxqt-panel/files/patch-plugin-kbindicator_src_x11_kbdlayout.cpp b/x11-wm/lxqt-panel/files/patch-plugin-kbindicator_src_x11_kbdlayout.cpp
new file mode 100644
index 000000000000..339508ce43b5
--- /dev/null
+++ b/x11-wm/lxqt-panel/files/patch-plugin-kbindicator_src_x11_kbdlayout.cpp
@@ -0,0 +1,15 @@
+--- plugin-kbindicator/src/x11/kbdlayout.cpp.orig 2018-08-01 13:39:24 UTC
++++ plugin-kbindicator/src/x11/kbdlayout.cpp
+@@ -245,10 +245,10 @@ private:
+ static LangInfo def{"Unknown", "??", "None"};
+ static QHash<QString, LangInfo> names;
+ if (names.empty()){
+- if(QFile::exists("/usr/share/X11/xkb/rules/evdev.xml")){
++ if(QFile::exists("/usr/local/share/X11/xkb/rules/evdev.xml")){
+ QDomDocument doc;
+
+- QFile file("/usr/share/X11/xkb/rules/evdev.xml");
++ QFile file("/usr/local/share/X11/xkb/rules/evdev.xml");
+ if (file.open(QIODevice::ReadOnly)){
+ if (doc.setContent(&file)) {
+ QDomElement docElem = doc.documentElement();
diff --git a/x11-wm/lxqt-panel/pkg-descr b/x11-wm/lxqt-panel/pkg-descr
new file mode 100644
index 000000000000..3af825e335c5
--- /dev/null
+++ b/x11-wm/lxqt-panel/pkg-descr
@@ -0,0 +1,4 @@
+LXQt desktop panel and plugins.
+lxqt-panel is part of the LXQt desktop.
+
+WWW: http://lxqt.org/
diff --git a/x11-wm/lxqt-panel/pkg-plist b/x11-wm/lxqt-panel/pkg-plist
new file mode 100644
index 000000000000..a7d58ba7ced2
--- /dev/null
+++ b/x11-wm/lxqt-panel/pkg-plist
@@ -0,0 +1,35 @@
+bin/lxqt-panel
+etc/xdg/autostart/lxqt-panel.desktop
+etc/xdg/menus/lxqt-applications.menu
+%%LXQT_INCLUDEDIR%%/ilxqtpanel.h
+%%LXQT_INCLUDEDIR%%/ilxqtpanelplugin.h
+%%LXQT_INCLUDEDIR%%/lxqtpanelglobals.h
+%%LXQT_INCLUDEDIR%%/pluginsettings.h
+lib/lxqt-panel/libcolorpicker.so
+%%CPULOAD%%lib/lxqt-panel/libcpuload.so
+lib/lxqt-panel/libdirectorymenu.so
+lib/lxqt-panel/libkbindicator.so
+%%MOUNT%%lib/lxqt-panel/libmount.so
+lib/lxqt-panel/libsysstat.so
+%%SOUND%%lib/lxqt-panel/libvolume.so
+man/man1/lxqt-panel.1.gz
+share/desktop-directories/lxqt-leave.directory
+share/desktop-directories/lxqt-settings.directory
+%%LXQT_SHAREDIR%%/lxqt-panel/clock.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/colorpicker.desktop
+%%CPULOAD%%%%LXQT_SHAREDIR%%/lxqt-panel/cpuload.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/desktopswitch.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/directorymenu.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/kbindicator.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/mainmenu.desktop
+%%MOUNT%%%%LXQT_SHAREDIR%%/lxqt-panel/mount.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/quicklaunch.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/showdesktop.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/spacer.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/statusnotifier.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/sysstat.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/taskbar.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/tray.desktop
+%%SOUND%%%%LXQT_SHAREDIR%%/lxqt-panel/volume.desktop
+%%LXQT_SHAREDIR%%/lxqt-panel/worldclock.desktop
+%%LXQT_SHAREDIR%%/panel.conf