aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/marco/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-10 13:11:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-10 13:11:28 +0000
commitbcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc (patch)
treee98877eaeb5e2a44f00691183c3f6564168e2955 /x11-wm/marco/Makefile
parentf9f9a731b4169a1148866d9821539fe3f5dd5aa6 (diff)
downloadports-bcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc.tar.gz
ports-bcf3a830a4f4c1c5453ee72607fea3aa99a4b5cc.zip
Welcome Mate Desktop 1.8
The porting work as been done by gnome@ (kwm) and Eric Turgeon (ericturgeon@ghostbsd.org)
Notes
Notes: svn path=/head/; revision=367830
Diffstat (limited to 'x11-wm/marco/Makefile')
-rw-r--r--x11-wm/marco/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/marco/Makefile b/x11-wm/marco/Makefile
new file mode 100644
index 000000000000..4a8b531c754d
--- /dev/null
+++ b/x11-wm/marco/Makefile
@@ -0,0 +1,32 @@
+# Created by: Garrett Rooney <rooneg@electricjellyfish.net>
+# $FreeBSD$
+
+PORTNAME= marco
+PORTVERSION= 1.8.0
+CATEGORIES= x11-wm mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Window manager for the adult in you
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_MATE= dialogs
+USE_XORG= x11 xcomposite xcursor xdamage xrandr
+USE_GNOME= gdkpixbuf2 glib20 gnomehier gtk20 intlhack pango
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.mate.marco.gschema.xml
+
+.include <bsd.port.mk>