aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pawm
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-04-14 16:06:04 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-04-14 16:06:04 +0000
commit11de210aa42beef424092e6226c4a3af3381c184 (patch)
tree6993f353b4e6247c74b006cb6bfd3d9308ea8296 /x11-wm/pawm
parent1917c86eb924ffbc072c683ba1ea61847b86ce61 (diff)
downloadports-11de210aa42beef424092e6226c4a3af3381c184.tar.gz
ports-11de210aa42beef424092e6226c4a3af3381c184.zip
fix for 4-STABLE
Submitted by: vs
Notes
Notes: svn path=/head/; revision=107024
Diffstat (limited to 'x11-wm/pawm')
-rw-r--r--x11-wm/pawm/Makefile8
-rw-r--r--x11-wm/pawm/files/patch-src_wm.c17
2 files changed, 18 insertions, 7 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index 9c722fc4f800..daeb96bded7d 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -21,12 +21,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on 4.x"
-.endif
-
do-configure:
cd ${WRKSRC} && \
bash ./0 --prefix=${PREFIX} --datadir=${PREFIX}/share/pawm
@@ -60,4 +54,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/pawm/files/patch-src_wm.c b/x11-wm/pawm/files/patch-src_wm.c
new file mode 100644
index 000000000000..7e06a1888977
--- /dev/null
+++ b/x11-wm/pawm/files/patch-src_wm.c
@@ -0,0 +1,17 @@
+$FreeBSD$
+
+Make ANSI C89/C90-compliant to compile with GCC 2.X.
+author: Volker Stolz
+
+--- src/wm.c.orig Wed Apr 14 16:32:24 2004
++++ src/wm.c Wed Apr 14 16:32:44 2004
+@@ -311,8 +311,8 @@
+
+ char *tmpvalue;
+
+- SAY ("Initializing window manager...");
+ int (*olderrorhandler) (Display *, XErrorEvent *);
++ SAY ("Initializing window manager...");
+
+ if (reference_count++) return !0;
+