aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pawm
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-08-22 10:47:57 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-08-22 10:47:57 +0000
commit255370206552e5425b4bba4f2c7af8ac82f15eb0 (patch)
tree4edb27ff276e2763700d1cc50139633de77a4610 /x11-wm/pawm
parente261441e1ee702fa19844a076a3924402c9afd01 (diff)
downloadports-255370206552e5425b4bba4f2c7af8ac82f15eb0.tar.gz
ports-255370206552e5425b4bba4f2c7af8ac82f15eb0.zip
new port of pawm, the Puto Amo Window Manager
(leopard hat, platform shoes and gold Cadillac not included)
Notes
Notes: svn path=/head/; revision=87492
Diffstat (limited to 'x11-wm/pawm')
-rw-r--r--x11-wm/pawm/Makefile57
-rw-r--r--x11-wm/pawm/distinfo2
-rw-r--r--x11-wm/pawm/files/patch-015
-rw-r--r--x11-wm/pawm/files/patch-signals.c12
-rw-r--r--x11-wm/pawm/pkg-descr8
5 files changed, 94 insertions, 0 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
new file mode 100644
index 000000000000..eec99c8ec1e9
--- /dev/null
+++ b/x11-wm/pawm/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: pawm
+# Date created: 2002-08-22
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= pawm
+PORTVERSION= 1.9.3
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.pleyades.net/pawm/files/
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= The Puto Amo Window Manager
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+DOCS= AUTHORS Changelog GPL INSTALL README THANKS
+PLIST= ${WRKDIR}/pkg-plist
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+do-configure:
+ cd ${WRKSRC} && \
+ bash ./0 --prefix=${PREFIX} --datadir=${PREFIX}/share/pawm
+
+pre-install:
+ ${ECHO_CMD} bin/pawm > ${PLIST}
+ ${ECHO_CMD} etc/pawm.conf >> ${PLIST}
+ for ii in `${LS} ${WRKSRC}/data/icons`; do \
+ ${ECHO_CMD} share/pawm/icons/$$ii >> ${PLIST}; \
+ done
+ ${ECHO_CMD} @dirrm share/pawm/icons >> ${PLIST}
+ ${ECHO_CMD} @dirrm share/pawm >> ${PLIST}
+.if !defined(NOPORTDOCS)
+ ${ECHO_CMD} @dirrm share/doc/pawm >> ${PLIST}
+.for ii in ${DOCS}
+ ${ECHO_CMD} share/doc/pawm/${ii} >> ${PLIST}
+.endfor
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/pawm ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/conf/pawm.conf ${PREFIX}/etc/
+ ${MKDIR} ${PREFIX}/share/pawm/icons
+ for ii in `${LS} ${WRKSRC}/data/icons/*`; do \
+ ${INSTALL_DATA} $$ii ${PREFIX}/share/pawm/icons ; \
+ done
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/pawm/distinfo b/x11-wm/pawm/distinfo
new file mode 100644
index 000000000000..fbccaa7270f9
--- /dev/null
+++ b/x11-wm/pawm/distinfo
@@ -0,0 +1,2 @@
+$FreeBSD$
+MD5 (pawm-1.9.3.tar.bz2) = a7d49d77451976d63a3ef1d491829968
diff --git a/x11-wm/pawm/files/patch-0 b/x11-wm/pawm/files/patch-0
new file mode 100644
index 000000000000..4edc3321b846
--- /dev/null
+++ b/x11-wm/pawm/files/patch-0
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- 0.orig Tue Aug 19 21:13:14 2003
++++ 0 Fri Aug 22 04:49:07 2003
+@@ -31,8 +31,8 @@
+ # LDIRS: A *space separated* list of additional library or .o search dirs.
+ # LIBES: A *space separated* list of additional library names to link,
+ ########################################
+-IDIRS="/usr/include/X11 /usr/X11R6/include/X11"
+-LDIRS="/usr/X11R6/lib /usr/lib/X11R6"
++IDIRS="/usr/X11R6/include/"
++LDIRS="/usr/X11R6/lib"
+ LIBES="libX11 libXext libXpm libm"
+
+ ########################################
diff --git a/x11-wm/pawm/files/patch-signals.c b/x11-wm/pawm/files/patch-signals.c
new file mode 100644
index 000000000000..56a32d497f51
--- /dev/null
+++ b/x11-wm/pawm/files/patch-signals.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- src/signals.c.orig Sun Jul 6 22:45:30 2003
++++ src/signals.c Fri Aug 22 04:54:29 2003
+@@ -22,6 +22,7 @@
+ */
+
+
++#include <sys/types.h>
+ #include "signals.h"
+
+ /* Non-ignored signals. This array marks its end with '0',
diff --git a/x11-wm/pawm/pkg-descr b/x11-wm/pawm/pkg-descr
new file mode 100644
index 000000000000..4b93846b2b32
--- /dev/null
+++ b/x11-wm/pawm/pkg-descr
@@ -0,0 +1,8 @@
+from the home page:
+
+ With Pawm you can minimize windows, that are placed on a
+ small auto-hide bar at the bottom, for a better access to
+ all apps. It also includes a small clock on the bar, that
+ can be easily disabled.
+
+WWW: http://www.pleyades.net/pawm/