aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pawm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-16 10:32:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-16 10:32:54 +0000
commit64156f45847fbe982d70b4b1fb592f4cb499cf96 (patch)
tree6e16ab68cf7c0ac06defa538f48cec508ad7efa4 /x11-wm/pawm
parent00cd57b7a9931e3a191d1bd9261a193a589e0434 (diff)
downloadports-64156f45847fbe982d70b4b1fb592f4cb499cf96.tar.gz
ports-64156f45847fbe982d70b4b1fb592f4cb499cf96.zip
- Update to 2.2.0
PR: ports/94507 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=157395
Diffstat (limited to 'x11-wm/pawm')
-rw-r--r--x11-wm/pawm/Makefile81
-rw-r--r--x11-wm/pawm/distinfo6
-rw-r--r--x11-wm/pawm/files/patch-src__pashut.c10
-rw-r--r--x11-wm/pawm/files/patch-src__pawindow.cc32
-rw-r--r--x11-wm/pawm/files/patch-src__wm.c20
-rw-r--r--x11-wm/pawm/files/patch-src_cfgpool.c56
-rw-r--r--x11-wm/pawm/files/patch-src_cfgpool.h30
-rw-r--r--x11-wm/pawm/files/patch-src_chain.c24
-rw-r--r--x11-wm/pawm/files/patch-src_paclock.c12
-rw-r--r--x11-wm/pawm/files/patch-src_pashut.c12
-rw-r--r--x11-wm/pawm/files/patch-src_timux.c15
-rw-r--r--x11-wm/pawm/files/patch-src_timux.h22
-rw-r--r--x11-wm/pawm/files/patch-src_wm.c17
-rw-r--r--x11-wm/pawm/pkg-plist38
14 files changed, 152 insertions, 223 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index d3198ce61009..302a1d206194 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -6,52 +6,69 @@
#
PORTNAME= pawm
-PORTVERSION= 1.9.7
+PORTVERSION= 2.2.0
CATEGORIES= x11-wm
MASTER_SITES= http://www.pleyades.net/pawm/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= The Puto Amo Window Manager
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
-
-DOCS= AUTHORS Changelog GPL INSTALL README THANKS
-PLIST= ${WRKDIR}/pkg-plist
USE_BZIP2= yes
-USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+MAKEFILE= Makefile.in
+MAKE_ARGS= GCC="${CC}" MAKE.binary="${CC} ${LDFLAGS} -o"
-do-configure:
- cd ${WRKSRC} && \
- bash ./0 --prefix=${PREFIX} --datadir=${PREFIX}/share/pawm
-
-pre-install:
- ${ECHO_CMD} bin/pawm > ${PLIST}
- ${ECHO_CMD} etc/pawm.conf >> ${PLIST}
- for ii in `${LS} ${WRKSRC}/data/icons`; do \
- ${ECHO_CMD} share/pawm/icons/$$ii >> ${PLIST}; \
- done
- ${ECHO_CMD} @dirrm share/pawm/icons >> ${PLIST}
- ${ECHO_CMD} @dirrm share/pawm >> ${PLIST}
-.if !defined(NOPORTDOCS)
-.for ii in ${DOCS}
- ${ECHO_CMD} share/doc/pawm/${ii} >> ${PLIST}
-.endfor
- ${ECHO_CMD} @dirrm share/doc/pawm >> ${PLIST}
+CFLAGS+= -I. -I${X11BASE}/include -DNDEBUG
+LDFLAGS= -lm -L${X11BASE}/lib -lXpm -lXrandr
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -Dintmax_t=u_int32_t -Duintmax_t=u_int32_t \
+ -Dstrtoimax=strtoll -Dstrtoumax=strtoull \
+ -DSIZE_MAX=UINT_MAX
.endif
+.if ${X_WINDOW_SYSTEM} == xfree86-3 || defined(WITHOUT_XFT)
+CFLAGS+= -DDISABLE_XFT
+.else
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CFLAGS+= `pkg-config --cflags xft`
+LDFLAGS+= `pkg-config --libs xft`
+.endif
+
+.if defined(WITH_SN)
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+CFLAGS+= -DENABLE_STARTUP -DSN_API_NOT_YET_FROZEN \
+ `pkg-config --cflags libstartup-notification-1.0`
+LDFLAGS+= `pkg-config --libs libstartup-notification-1.0`
+.endif
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<inttypes.h>|g'
+.endif
+
+do-configure:
+ @${ECHO_CMD} -n > ${WRKSRC}/config.h
+ @${ECHO_CMD} '#define PROJECT "${PORTNAME}"' >> ${WRKSRC}/config.h
+ @${ECHO_CMD} '#define VERSION "${PORTVERSION}"' >> ${WRKSRC}/config.h
+ @${ECHO_CMD} '#define CONFDIR "${PREFIX}/etc"' >> ${WRKSRC}/config.h
+ @${ECHO_CMD} '#define DATADIR "${DATADIR}"' >> ${WRKSRC}/config.h
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pawm ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/conf/pawm.conf ${PREFIX}/etc/
- ${MKDIR} ${PREFIX}/share/pawm/icons
- for ii in `${LS} ${WRKSRC}/data/icons/*`; do \
- ${INSTALL_DATA} $$ii ${PREFIX}/share/pawm/icons ; \
- done
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/pawm ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/conf/pawm.conf ${PREFIX}/etc
+ @${MKDIR} ${DATADIR}/icons
+ ${INSTALL_DATA} ${WRKSRC}/data/icons/*.xpm ${DATADIR}/icons
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for ii in ${DOCS}
+ @${MKDIR} ${DOCSDIR}
+.for ii in AUTHORS Changelog GPL INSTALL README
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/pawm/distinfo b/x11-wm/pawm/distinfo
index f7bc6d455119..3e9fc030a7ae 100644
--- a/x11-wm/pawm/distinfo
+++ b/x11-wm/pawm/distinfo
@@ -1,3 +1,3 @@
-MD5 (pawm-1.9.7.tar.bz2) = 9ba4bb81166995cbefd5ee2660217d9c
-SHA256 (pawm-1.9.7.tar.bz2) = b9a5e3b4895328c8f26bfbab894ef93d6c0215925e344f488b9a48019994d880
-SIZE (pawm-1.9.7.tar.bz2) = 100424
+MD5 (pawm-2.2.0.tar.bz2) = ed810bff65c8ccc97d8963adf6f4304a
+SHA256 (pawm-2.2.0.tar.bz2) = 976db753a275f9d49d2752dba64754f7889d6af190103ea196fd72a7f7c4c5a8
+SIZE (pawm-2.2.0.tar.bz2) = 123542
diff --git a/x11-wm/pawm/files/patch-src__pashut.c b/x11-wm/pawm/files/patch-src__pashut.c
new file mode 100644
index 000000000000..c6aaf7651bae
--- /dev/null
+++ b/x11-wm/pawm/files/patch-src__pashut.c
@@ -0,0 +1,10 @@
+--- src/pashut.c.orig Sat Feb 25 00:55:09 2006
++++ src/pashut.c Sun Feb 26 03:15:23 2006
+@@ -24,6 +24,7 @@
+ #include "pabar.h"
+ #include "pafont.h"
+ #include "pashut.h"
++#include "signals.h"
+
+
+ static void shut_all(void *);
diff --git a/x11-wm/pawm/files/patch-src__pawindow.cc b/x11-wm/pawm/files/patch-src__pawindow.cc
new file mode 100644
index 000000000000..cb43bb09cc06
--- /dev/null
+++ b/x11-wm/pawm/files/patch-src__pawindow.cc
@@ -0,0 +1,32 @@
+--- src/pawindow.c.orig Sun Mar 5 10:14:06 2006
++++ src/pawindow.c Wed Mar 8 13:29:48 2006
+@@ -787,10 +787,12 @@
+
+ static void canvas_KeyPress(XKeyPressedEvent *event, PAWindow pawindow)
+ {
++ XEvent *e;
++
+ ASSERT(event);
+ ASSERT(pawindow);
+
+- XEvent *e = (XEvent *) event;
++ e = (XEvent *) event;
+
+ /* Replay the event if it isn't a pawm keybinding */
+ if (!keyboard_binding_key(event)) {
+@@ -1633,6 +1635,7 @@
+ int num_rows=1;
+ int firsticonx, lasticonx, iconx, icony;
+ bool forward= (strcmp((char *)data, "forward")==0 ? 1 : 0);
++ KeySym testkeysym; KeyCode testkeycode;
+
+
+ /* TODO: Support both rotate method: w/wout popup window*/
+@@ -1665,7 +1668,6 @@
+ None, CurrentTime);
+ current_pw=tab_window_draw_all(num_windows, num_rows);
+
+- KeySym testkeysym; KeyCode testkeycode;
+ testkeysym=XStringToKeysym("Tab");
+ testkeycode=XKeysymToKeycode(display, testkeysym);
+ XGrabKey(display, testkeycode, Mod1Mask, ROOT, False, GrabModeAsync, GrabModeAsync);
diff --git a/x11-wm/pawm/files/patch-src__wm.c b/x11-wm/pawm/files/patch-src__wm.c
new file mode 100644
index 000000000000..a46b43ffe321
--- /dev/null
+++ b/x11-wm/pawm/files/patch-src__wm.c
@@ -0,0 +1,20 @@
+--- src/wm.c.orig Fri Feb 24 05:12:18 2006
++++ src/wm.c Sun Feb 26 03:10:37 2006
+@@ -355,6 +355,9 @@
+ CARD32 tmpdata[20];
+ unsigned long length;
+ int (*olderrorhandler) (Display *, XErrorEvent *);
++#ifndef DISABLE_XRANDR
++ int major, minor,errbase;
++#endif
+
+ SAY ("Initializing window manager...");
+
+@@ -373,7 +376,6 @@
+
+ #ifndef DISABLE_XRANDR
+ /* Check for XRandr extension */
+- int major, minor,errbase;
+ XRRQueryVersion(display, &major, &minor);
+ XRRQueryExtension(display, &(class.randr_base), &errbase);
+ SAY("Using XRandr %d.%d extension. Event base: %d Error base %d", major, minor, class.randr_base, errbase);
diff --git a/x11-wm/pawm/files/patch-src_cfgpool.c b/x11-wm/pawm/files/patch-src_cfgpool.c
deleted file mode 100644
index b18c298f3264..000000000000
--- a/x11-wm/pawm/files/patch-src_cfgpool.c
+++ /dev/null
@@ -1,56 +0,0 @@
-$FreeBSD$
-
-FreeBSD 4 is not C99-compliant.
-
---- src/cfgpool.c.orig Wed Aug 6 14:27:17 2003
-+++ src/cfgpool.c Sat Oct 18 17:18:40 2003
-@@ -309,13 +309,13 @@ legal value*. So, for proper error check
- EINVAL: Couldn't parse a well-formed natural number.
- ERANGE: Overflow while parsing the number.
- */
--uintmax_t
-+u_int32_t
- cfgpool_getnatural (CfgPool pool, const char *key, unsigned int base) {
-
- char *value=NULL;
- char *tailptr=NULL;
- int tmperrno=errno;
-- uintmax_t natural=0;
-+ u_int32_t natural=0;
-
- ASSERT(pool);
- ASSERT(key);
-@@ -329,7 +329,7 @@ cfgpool_getnatural (CfgPool pool, const
-
- /* Well, it seems we have a value... Translate to correct type */
- errno=0;
-- natural=strtoumax(value, &tailptr, base);
-+ natural=strtoull(value, &tailptr, base);
-
- if (errno) natural=0,tmperrno=ERANGE;
- if ((!natural) && (tailptr==value)) tmperrno=EINVAL;
-@@ -359,13 +359,13 @@ legal value*. So, for proper error check
- ERANGE: Overflow while parsing the number.
- */
-
--intmax_t
-+u_int32_t
- cfgpool_getinteger (CfgPool pool, const char *key, unsigned int base) {
-
- char *value=NULL;
- char *tailptr=NULL;
- int tmperrno=errno;
-- intmax_t integer=0;
-+ u_int32_t integer=0;
-
- ASSERT(pool);
- ASSERT(key);
-@@ -379,7 +379,7 @@ cfgpool_getinteger (CfgPool pool, const
-
- /* Well, it seems we have a value... Translate to correct type */
- errno=0;
-- integer=strtoimax(value, &tailptr, base);
-+ integer=strtoll(value, &tailptr, base);
-
- if (errno) integer=0,tmperrno=ERANGE;
- if ((!integer) && (tailptr==value)) tmperrno=EINVAL;
diff --git a/x11-wm/pawm/files/patch-src_cfgpool.h b/x11-wm/pawm/files/patch-src_cfgpool.h
deleted file mode 100644
index e340f836d7ba..000000000000
--- a/x11-wm/pawm/files/patch-src_cfgpool.h
+++ /dev/null
@@ -1,30 +0,0 @@
-$FreeBSD$
-
-FreeBSD 4 is not C99-compliant.
-
---- src/cfgpool.h.orig Wed Jul 10 07:33:57 2002
-+++ src/cfgpool.h Sat Oct 18 16:14:11 2003
-@@ -25,21 +25,16 @@
- #ifndef __X_CFGPOOL_X__
- #define __X_CFGPOOL_X__
-
--#include <stdint.h>
- #include <limits.h>
- #include <inttypes.h>
-
--#if SSIZE_MAX > SIZE_MAX
--#error Cannot build, since SSIZE_MAX appears to be greater than SIZE_MAX!!!
--#endif
--
- typedef struct CfgPool *CfgPool;
-
- CfgPool cfgpool_create (const char *);
- CfgPool cfgpool_delete (CfgPool);
-
- char * cfgpool_getstring (CfgPool, const char *);
--uintmax_t cfgpool_getnatural (CfgPool, const char *, unsigned int);
--intmax_t cfgpool_getinteger (CfgPool, const char *, unsigned int);
-+u_int32_t cfgpool_getnatural (CfgPool, const char *, unsigned int);
-+u_int32_t cfgpool_getinteger (CfgPool, const char *, unsigned int);
-
- #endif
diff --git a/x11-wm/pawm/files/patch-src_chain.c b/x11-wm/pawm/files/patch-src_chain.c
deleted file mode 100644
index 592e81a1308b..000000000000
--- a/x11-wm/pawm/files/patch-src_chain.c
+++ /dev/null
@@ -1,24 +0,0 @@
-$FreeBSD$
-
-FreeBSD 4 is not C99-compliant.
-
---- src/chain.c.orig Wed Aug 6 14:27:17 2003
-+++ src/chain.c Sat Oct 18 16:30:50 2003
-@@ -22,7 +22,7 @@ Copyright (C) 2002,03 Raúl Núñez de Aren
- #include <stddef.h>
- #include <errno.h>
- #include <limits.h>
--#include <stdint.h>
-+#include <sys/types.h>
- #include "chain.h"
- #include "mobs.h"
-
-@@ -199,7 +199,7 @@ void *chain_put (Chain chain, void *item
- ASSERT(chain);
- ASSERT(item);
-
-- if (chain->size==SIZE_MAX) {
-+ if (chain->size==UINT_MAX) {
- errno=EFBIG;
- return NULL;
- }
diff --git a/x11-wm/pawm/files/patch-src_paclock.c b/x11-wm/pawm/files/patch-src_paclock.c
deleted file mode 100644
index 01d3c42f2414..000000000000
--- a/x11-wm/pawm/files/patch-src_paclock.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- src/paclock.c.orig Fri Jan 16 13:22:09 2004
-+++ src/paclock.c Thu Mar 11 18:00:10 2004
-@@ -20,6 +20,7 @@
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include <signal.h>
- #include "pabar.h"
- #include "paclock.h"
- #include "timux.h"
diff --git a/x11-wm/pawm/files/patch-src_pashut.c b/x11-wm/pawm/files/patch-src_pashut.c
deleted file mode 100644
index 99856625fca9..000000000000
--- a/x11-wm/pawm/files/patch-src_pashut.c
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- src/pashut.c.orig Thu Sep 4 22:29:02 2003
-+++ src/pashut.c Thu Mar 11 18:08:38 2004
-@@ -20,6 +20,7 @@
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
-+#include <signal.h>
- #include "pashut.h"
- #include "pawindow.h"
- #include "pabar.h"
diff --git a/x11-wm/pawm/files/patch-src_timux.c b/x11-wm/pawm/files/patch-src_timux.c
deleted file mode 100644
index 170d4d61f851..000000000000
--- a/x11-wm/pawm/files/patch-src_timux.c
+++ /dev/null
@@ -1,15 +0,0 @@
-$FreeBSD$
-
-FreeBSD 4 is not C99-compliant.
-
---- src/timux.c.orig Wed Aug 6 14:27:19 2003
-+++ src/timux.c Sat Oct 18 17:14:40 2003
-@@ -45,7 +45,7 @@ struct TiMux {
- TiMuxEvent target;
- };
-
--static volatile uintmax_t timux_count=0;
-+static volatile uint32_t timux_count=0;
- static TiMux theTiMux=NULL;
-
- static void TheHandlerTM (int);
diff --git a/x11-wm/pawm/files/patch-src_timux.h b/x11-wm/pawm/files/patch-src_timux.h
deleted file mode 100644
index eab3422b1f75..000000000000
--- a/x11-wm/pawm/files/patch-src_timux.h
+++ /dev/null
@@ -1,22 +0,0 @@
-$FreeBSD$
-
-FreeBSD 4 is not C99-compliant.
-
---- src/timux.h.orig Wed Apr 24 11:07:32 2002
-+++ src/timux.h Sat Oct 18 17:15:40 2003
-@@ -25,13 +25,11 @@
- #ifndef __X_TIMUX_X__
- #define __X_TIMUX_X__
-
--#include <stdint.h>
--
- /* NOTE: timestamps, and so resolutions, are expressed in milliseconds */
-
- typedef struct TiMux *TiMux;
--typedef uint_fast32_t tempus;
--typedef uint_fast64_t jobid;
-+typedef uint32_t tempus;
-+typedef uint64_t jobid;
- typedef void (*duty) (void *);
-
- TiMux timux_create (void);
diff --git a/x11-wm/pawm/files/patch-src_wm.c b/x11-wm/pawm/files/patch-src_wm.c
deleted file mode 100644
index 7e06a1888977..000000000000
--- a/x11-wm/pawm/files/patch-src_wm.c
+++ /dev/null
@@ -1,17 +0,0 @@
-$FreeBSD$
-
-Make ANSI C89/C90-compliant to compile with GCC 2.X.
-author: Volker Stolz
-
---- src/wm.c.orig Wed Apr 14 16:32:24 2004
-+++ src/wm.c Wed Apr 14 16:32:44 2004
-@@ -311,8 +311,8 @@
-
- char *tmpvalue;
-
-- SAY ("Initializing window manager...");
- int (*olderrorhandler) (Display *, XErrorEvent *);
-+ SAY ("Initializing window manager...");
-
- if (reference_count++) return !0;
-
diff --git a/x11-wm/pawm/pkg-plist b/x11-wm/pawm/pkg-plist
new file mode 100644
index 000000000000..471a67bf4b9d
--- /dev/null
+++ b/x11-wm/pawm/pkg-plist
@@ -0,0 +1,38 @@
+bin/pawm
+etc/pawm.conf
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/GPL
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/icons/close_d.xpm
+%%DATADIR%%/icons/close_d_256.xpm
+%%DATADIR%%/icons/close_h.xpm
+%%DATADIR%%/icons/close_h_256.xpm
+%%DATADIR%%/icons/close_o.xpm
+%%DATADIR%%/icons/close_o_256.xpm
+%%DATADIR%%/icons/max_d.xpm
+%%DATADIR%%/icons/max_d_256.xpm
+%%DATADIR%%/icons/max_h.xpm
+%%DATADIR%%/icons/max_h_256.xpm
+%%DATADIR%%/icons/max_o.xpm
+%%DATADIR%%/icons/max_o_256.xpm
+%%DATADIR%%/icons/min_d.xpm
+%%DATADIR%%/icons/min_d_256.xpm
+%%DATADIR%%/icons/min_h.xpm
+%%DATADIR%%/icons/min_h_256.xpm
+%%DATADIR%%/icons/min_o.xpm
+%%DATADIR%%/icons/min_o_256.xpm
+%%DATADIR%%/icons/penguin-gentoo.xpm
+%%DATADIR%%/icons/penguin-gentoo_256.xpm
+%%DATADIR%%/icons/penguin.xpm
+%%DATADIR%%/icons/penguin_256.xpm
+%%DATADIR%%/icons/powerbutton_active.xpm
+%%DATADIR%%/icons/powerbutton_active_256.xpm
+%%DATADIR%%/icons/powerbutton_normal.xpm
+%%DATADIR%%/icons/powerbutton_normal_256.xpm
+%%DATADIR%%/icons/powerbutton_pressed.xpm
+%%DATADIR%%/icons/powerbutton_pressed_256.xpm
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%