aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/plasma5-kwin/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-10-16 15:18:49 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-10-16 15:18:49 +0000
commita20e88733fbdfd9177cec3f95cd4afc46d13a5e1 (patch)
treeb2406c6911d2056617fd4377a284bc8b49adada6 /x11-wm/plasma5-kwin/Makefile
parent5731dfc5e71a4c8eadb6fc0226d50e670f458ecf (diff)
downloadports-a20e88733fbdfd9177cec3f95cd4afc46d13a5e1.tar.gz
ports-a20e88733fbdfd9177cec3f95cd4afc46d13a5e1.zip
Make dependencies explicit
- Cleanup dependency handling by explicitly depending on new transitive dependencies. Reported by: rhurlin, poudriere
Notes
Notes: svn path=/head/; revision=552514
Diffstat (limited to 'x11-wm/plasma5-kwin/Makefile')
-rw-r--r--x11-wm/plasma5-kwin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index 8cfc8f5cf0b7..9b1a043392e9 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kwin
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -12,6 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libXcursor.so:x11/libXcursor \
libdrm.so:graphics/libdrm \
libepoxy.so:graphics/libepoxy \
+ libepoll-shim.so:devel/libepoll-shim \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libinput.so:x11/libinput \
@@ -26,9 +28,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
Xwayland:x11-servers/xwayland
RUN_DEPENDS= Xwayland:x11-servers/xwayland
-USES= cmake compiler:c++11-lib cpe gettext gl kde:5 pkgconfig python:3.5+,run \
+USES= cmake compiler:c++11-lib cpe gettext gl gnome kde:5 pkgconfig python:3.5+,run \
qt:5 shebangfix tar:xz xorg
USE_GL= egl
+USE_GNOME= glib20
USE_KDE= activities activities attica auth breeze codecs \
completion config configwidgets coreaddons crash decoration \
doctools doctools globalaccel i18n iconthemes idletime init \