aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/skippy-xd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-10-17 09:09:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-10-17 09:09:08 +0000
commitd597c53d4cbf0df855a673412d89540a48e96a6b (patch)
tree79ebe83ab78d2f01666b795ea95889e4385cab89 /x11-wm/skippy-xd
parent817b851128efd190cd59e50f27dd2595cb0b954a (diff)
downloadports-d597c53d4cbf0df855a673412d89540a48e96a6b.tar.gz
ports-d597c53d4cbf0df855a673412d89540a48e96a6b.zip
Resurrect `x11-wm/skippy-xd', a full-screen Expose-style standalone task
switcher for X11. It is now being hosted on GitHub as a fork from the original 0.5.0 release (2004), initially maintained by Nick Watts (2011) and now by Richard Grenville (2013). Assume maintainership.
Notes
Notes: svn path=/head/; revision=482283
Diffstat (limited to 'x11-wm/skippy-xd')
-rw-r--r--x11-wm/skippy-xd/Makefile36
-rw-r--r--x11-wm/skippy-xd/distinfo3
-rw-r--r--x11-wm/skippy-xd/files/patch-src_config.c22
-rw-r--r--x11-wm/skippy-xd/pkg-descr12
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-wm/skippy-xd/Makefile b/x11-wm/skippy-xd/Makefile
new file mode 100644
index 000000000000..5c84eb574f07
--- /dev/null
+++ b/x11-wm/skippy-xd/Makefile
@@ -0,0 +1,36 @@
+# Created by: Michael Johnson <ahze@ahze.net>
+# $FreeBSD$
+
+PORTNAME= skippy-xd
+PORTVERSION= 0.5.0
+PORTREVISION= 2
+CATEGORIES= x11-wm
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Full-screen Expose-style standalone task switcher for X11
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgif.so:graphics/giflib \
+ libpng.so:graphics/png
+
+USES= gmake jpeg pkgconfig
+USE_XORG= x11 xcomposite xdamage xext xfixes xft xinerama xrender
+
+USE_GITHUB= yes
+GH_ACCOUNT= richardgv
+GH_TAGNAME= 397216c
+
+MAKE_ARGS= SKIPPYXD_VERSION=${PORTVERSION}-git-${GH_TAGNAME}-2015-02-24
+
+PLIST_FILES= bin/skippy-xd \
+ @sample\ etc/xdg/skippy-xd.rc.sample
+PORTDOCS= CHANGELOG
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/skippy-xd/distinfo b/x11-wm/skippy-xd/distinfo
new file mode 100644
index 000000000000..e6fba9eaaf05
--- /dev/null
+++ b/x11-wm/skippy-xd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1424784900
+SHA256 (richardgv-skippy-xd-0.5.0-397216c_GH0.tar.gz) = 172ab8c0fcbd61df3de27d08b87851c17a31a2e06f99dd42894436921a92e1d9
+SIZE (richardgv-skippy-xd-0.5.0-397216c_GH0.tar.gz) = 57168
diff --git a/x11-wm/skippy-xd/files/patch-src_config.c b/x11-wm/skippy-xd/files/patch-src_config.c
new file mode 100644
index 000000000000..c5af18ff6f02
--- /dev/null
+++ b/x11-wm/skippy-xd/files/patch-src_config.c
@@ -0,0 +1,22 @@
+--- src/config.c.orig 2015-02-24 13:35:00 UTC
++++ src/config.c
+@@ -73,9 +73,9 @@ config_parse(const char *config) {
+ int ix = 0, l_ix = 0;
+ dlist *new_config = 0;
+
+- regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*?)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
+ regcomp(&re_empty, "^[[:space:]]*#|^[[:space:]]*$", REG_EXTENDED);
+- regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*?)[[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*)[[:space:]]*$", REG_EXTENDED);
+
+ while(1)
+ {
+@@ -150,6 +150,7 @@ config_load(const char *path)
+ fclose(fin);
+ return 0;
+ }
++ data[flen] = '\0';
+
+ fclose(fin);
+
diff --git a/x11-wm/skippy-xd/pkg-descr b/x11-wm/skippy-xd/pkg-descr
new file mode 100644
index 000000000000..716c4c72eabf
--- /dev/null
+++ b/x11-wm/skippy-xd/pkg-descr
@@ -0,0 +1,12 @@
+Skippy-XD is a version of Skippy that uses Xserver's XDamage, XComposite and
+XFixes extensions to provide you with 'live' versions of the windows.
+
+Skippy-XD is best described as a full-screen task-switcher for X11. It tries to
+provide an alternative when taskbars or regular task-switchers aren't the most
+efficient way of switching tasks (like when you have a lot of applications open)
+When activated (currently only through a hotkey), it will arrange and scale
+snapshots of all windows on the current desktop and it'll let you pick a
+window using a mouse or a keyboard. Yes, this is also what expocity and Apple's
+Expose.
+
+WWW: https://github.com/richardgv/skippy-xd