aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2004-10-26 08:49:49 +0000
committerDoug Barton <dougb@FreeBSD.org>2004-10-26 08:49:49 +0000
commit197d0d347b01272276f493ffa10983ba92beabd7 (patch)
tree55557e2735a9d3f6b0ed9bf052b3bd8a2e6978cc /x11-wm/windowmaker
parent4803d397f0d6949162cf9ed8bb38e04688846378 (diff)
downloadports-197d0d347b01272276f493ffa10983ba92beabd7.tar.gz
ports-197d0d347b01272276f493ffa10983ba92beabd7.zip
Update to 0.91.0, the latest version from the window maker team.
It contains several bug fixes, especially for the new alt-tab code. 1. Adopt this port, at least for the time being. I use it every day, and follow the wm-user list so I'm probably qualified. 2. Update the descriptions of the OPTIONS. 3. Restore the knob for KDE, and add knobs for XINERAMA and the additional LINGUAS files. These, and the XKB_STATUS knobs are all off by default, but on for the PACKAGE_BUILDING case. I borrowed this concept from the fluxbox port. 4. Add a knob for the experimental virtual desktop code, off by default. The window maker folks warn that this is still experimental, so users shouldn't wander into it by mistake. 5. Instead of bumping the SHLIB version number to 5, set it back to 4. The window maker folks use N.N.N for their libwraster version string, and their version for the 0.80.2 version of window maker was 2.3.0. Thus, our previous version number of 4 was already bogus, so keep it bogus even though they've bumped their version to 3.N.N. The new lib is forward compatible for apps compiled with old library (I've tested many of them), and this "fixes" all the ports that depend on libwraster. 6. Make the locale files hidden under the LINGUAS knob conditional in the plist.
Notes
Notes: svn path=/head/; revision=120205
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/Makefile40
-rw-r--r--x11-wm/windowmaker/distinfo4
-rw-r--r--x11-wm/windowmaker/pkg-plist112
3 files changed, 88 insertions, 68 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 4622ad81c5e9..211311cab9ad 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= windowmaker
-PORTVERSION= 0.90.0
-PORTREVISION= 1
+PORTVERSION= 0.91.0
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= source/release
DISTNAME= WindowMaker-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= DougB@FreeBSD.org
COMMENT= GNUStep-compliant NeXTStep window manager clone
LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
@@ -31,15 +30,12 @@ USE_GETTEXT= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LINGUAS="${LINGUAS}"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
--with-libs-from="-L${LOCALBASE}/lib" \
--with-incs-from="-I${LOCALBASE}/include" \
--with-appspath="${PREFIX}/GNUstep/Apps" \
- --enable-vdesktop \
- --enable-xinerama \
--disable-debug
INSTALLS_SHLIB= yes
@@ -47,21 +43,43 @@ MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x
-OPTIONS= XKB_STATUS "XKB STATUS" off
+OPTIONS= KDE "Add hooks for kde support" off \
+ XINERAMA "Enable xinerama support" off \
+ XKB_STATUS "XKB keyboard language status support" off \
+ WM_LINGUAS "Enable support for additional locales" off \
+ WM_VDESKTOP "Experts only!" off
.include <bsd.port.pre.mk>
-LINGUAS!= ${CAT} ${FILESDIR}/LINGUAS
+.if defined(WITH_KDE) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-kde
+.endif
-.if defined(WITH_XKB_STATUS)
+.if defined(WITH_XINERAMA) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-xinerama
+.endif
+
+.if defined(WITH_XKB_STATUS) || defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --enable-modelock
.endif
+.if defined(WITH_WM_LINGUAS) || defined(PACKAGE_BUILDING)
+LINGUAS!= ${CAT} ${FILESDIR}/LINGUAS
+CONFIGURE_ENV+= LINGUAS="${LINGUAS}"
+PLIST_SUB= WM_LINGUAS=""
+.else
+PLIST_SUB= WM_LINGUAS="@comment "
+.endif
+
+.if defined(WITH_WM_VDESKTOP)
+CONFIGURE_ARGS+= --enable-vdesktop
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|TW\.Big5|TW|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c
@${REINPLACE_CMD} -e "s|%%PERL%%|${PERL}|g" ${WRKSRC}/util/wm-oldmenu2new
- @${REINPLACE_CMD} -e "s|-version-info 3:|-version-info 5:|g" ${WRKSRC}/wrlib/Makefile.in
+ @${REINPLACE_CMD} -e "s|-version-info 3:|-version-info 4:|g" ${WRKSRC}/wrlib/Makefile.in
@${REINPLACE_CMD} -e "s|Trebuchet MS,Luxi Sans|sans|g" ${WRKSRC}/WindowMaker/Defaults/WMGLOBAL
@${REINPLACE_CMD} -e "s|/usr/local/GNUstep|${PREFIX}/GNUstep|g" \
${WRKSRC}/WindowMaker/*menu*
diff --git a/x11-wm/windowmaker/distinfo b/x11-wm/windowmaker/distinfo
index 029a1bca4308..7a7b2623a205 100644
--- a/x11-wm/windowmaker/distinfo
+++ b/x11-wm/windowmaker/distinfo
@@ -1,2 +1,2 @@
-MD5 (WindowMaker-0.90.0.tar.bz2) = 1665bdd857cf39a0a080f51d489a52ee
-SIZE (WindowMaker-0.90.0.tar.bz2) = 2196715
+MD5 (WindowMaker-0.91.0.tar.bz2) = 9d5e583e6cce5b4d16bb686b0c26c5dc
+SIZE (WindowMaker-0.91.0.tar.bz2) = 2198266
diff --git a/x11-wm/windowmaker/pkg-plist b/x11-wm/windowmaker/pkg-plist
index 0c571525bad6..4aaeab7fe624 100644
--- a/x11-wm/windowmaker/pkg-plist
+++ b/x11-wm/windowmaker/pkg-plist
@@ -103,7 +103,7 @@ lib/libWMaker.a
lib/libWUtil.a
lib/libwraster.a
lib/libwraster.so
-lib/libwraster.so.5
+lib/libwraster.so.4
libdata/pkgconfig/WINGs.pc
libdata/pkgconfig/wmlib.pc
libdata/pkgconfig/wrlib.pc
@@ -178,6 +178,8 @@ share/WindowMaker/Icons/xdvi.tiff
share/WindowMaker/Icons/xdvi.xpm
share/WindowMaker/Icons/xv.tiff
share/WindowMaker/Icons/xv.xpm
+share/WindowMaker/Pixmaps/swback.png
+share/WindowMaker/Pixmaps/swback2.png
share/WindowMaker/Pixmaps/swtile.png
share/WindowMaker/Pixmaps/tile.tiff
share/WindowMaker/Pixmaps/tile.xpm
@@ -271,60 +273,60 @@ share/WindowMaker/plmenu.zh_CN
share/WindowMaker/plmenu.zh_TW
share/WindowMaker/wmmacros
share/WindowMaker/xtree.dat
-share/locale/be/LC_MESSAGES/WindowMaker.mo
-share/locale/bg/LC_MESSAGES/WINGs.mo
-share/locale/bg/LC_MESSAGES/WPrefs.mo
-share/locale/bg/LC_MESSAGES/WindowMaker.mo
-share/locale/bs/LC_MESSAGES/WindowMaker.mo
-share/locale/ca/LC_MESSAGES/WINGs.mo
-share/locale/ca/LC_MESSAGES/WPrefs.mo
-share/locale/ca/LC_MESSAGES/WindowMaker.mo
-share/locale/cs/LC_MESSAGES/WINGs.mo
-share/locale/cs/LC_MESSAGES/WPrefs.mo
-share/locale/cs/LC_MESSAGES/WindowMaker.mo
-share/locale/da/LC_MESSAGES/WindowMaker.mo
-share/locale/de/LC_MESSAGES/WINGs.mo
-share/locale/de/LC_MESSAGES/WPrefs.mo
-share/locale/de/LC_MESSAGES/WindowMaker.mo
-share/locale/el/LC_MESSAGES/WindowMaker.mo
-share/locale/es/LC_MESSAGES/WPrefs.mo
-share/locale/es/LC_MESSAGES/WindowMaker.mo
-share/locale/et/LC_MESSAGES/WPrefs.mo
-share/locale/et/LC_MESSAGES/WindowMaker.mo
-share/locale/fi/LC_MESSAGES/WPrefs.mo
-share/locale/fi/LC_MESSAGES/WindowMaker.mo
-share/locale/fr/LC_MESSAGES/WINGs.mo
-share/locale/fr/LC_MESSAGES/WPrefs.mo
-share/locale/fr/LC_MESSAGES/WindowMaker.mo
-share/locale/gl/LC_MESSAGES/WindowMaker.mo
-share/locale/hr/LC_MESSAGES/WPrefs.mo
-share/locale/hr/LC_MESSAGES/WindowMaker.mo
-share/locale/hu/LC_MESSAGES/WPrefs.mo
-share/locale/hu/LC_MESSAGES/WindowMaker.mo
-share/locale/it/LC_MESSAGES/WPrefs.mo
-share/locale/it/LC_MESSAGES/WindowMaker.mo
-share/locale/ja/LC_MESSAGES/WPrefs.mo
-share/locale/ja/LC_MESSAGES/WindowMaker.mo
-share/locale/ko/LC_MESSAGES/WPrefs.mo
-share/locale/ko/LC_MESSAGES/WindowMaker.mo
-share/locale/ms/LC_MESSAGES/WindowMaker.mo
-share/locale/nl/LC_MESSAGES/WindowMaker.mo
-share/locale/no/LC_MESSAGES/WindowMaker.mo
-share/locale/pl/LC_MESSAGES/WindowMaker.mo
-share/locale/pt/LC_MESSAGES/WPrefs.mo
-share/locale/pt/LC_MESSAGES/WindowMaker.mo
-share/locale/ro/LC_MESSAGES/WindowMaker.mo
-share/locale/ru/LC_MESSAGES/WPrefs.mo
-share/locale/ru/LC_MESSAGES/WindowMaker.mo
-share/locale/sk/LC_MESSAGES/WINGs.mo
-share/locale/sk/LC_MESSAGES/WPrefs.mo
-share/locale/sk/LC_MESSAGES/WindowMaker.mo
-share/locale/sv/LC_MESSAGES/WindowMaker.mo
-share/locale/tr/LC_MESSAGES/WindowMaker.mo
-share/locale/zh_CN/LC_MESSAGES/WPrefs.mo
-share/locale/zh_CN/LC_MESSAGES/WindowMaker.mo
-share/locale/zh_TW/LC_MESSAGES/WPrefs.mo
-share/locale/zh_TW/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/be/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/bg/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/bg/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/bg/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/bs/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ca/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/ca/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/ca/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/cs/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/cs/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/cs/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/da/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/de/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/de/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/de/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/el/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/es/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/es/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/et/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/et/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/fi/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/fi/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/fr/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/fr/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/fr/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/gl/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/hr/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/hr/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/hu/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/hu/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/it/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/it/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ja/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/ja/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ko/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/ko/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ms/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/nl/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/no/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/pl/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/pt/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/pt/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ro/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/ru/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/ru/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/sk/LC_MESSAGES/WINGs.mo
+%%WM_LINGUAS%%share/locale/sk/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/sk/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/sv/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/tr/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/zh_CN/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/zh_CN/LC_MESSAGES/WindowMaker.mo
+%%WM_LINGUAS%%share/locale/zh_TW/LC_MESSAGES/WPrefs.mo
+%%WM_LINGUAS%%share/locale/zh_TW/LC_MESSAGES/WindowMaker.mo
@exec mkdir -p %D/GNUstep/Apps/WPrefs.app/xpm
@exec mkdir -p %D/share/WindowMaker/Sounds
@dirrm share/WindowMaker/Styles