aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2000-12-11 22:46:06 +0000
committerClive Lin <clive@FreeBSD.org>2000-12-11 22:46:06 +0000
commit3bc498db0e867932ffe2b360ee88af3cc833c47b (patch)
treea216c7a1582f7d7d0b407310316b8a8d6822871b /x11-wm
parentf512875b99de6466a39e1ee7b1b238ec19f4a2a2 (diff)
downloadports-3bc498db0e867932ffe2b360ee88af3cc833c47b.tar.gz
ports-3bc498db0e867932ffe2b360ee88af3cc833c47b.zip
This port contains e16utils provided on enlightenment ftp.
It contains e16menuedit and e16keyedit. PR: 22110 22113 Submitted by: Jeremy Norris <ishmael27@home.com> Merged by: clive Reviewed by: Jeremy Norris <ishmael27@home.com>
Notes
Notes: svn path=/head/; revision=35907
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e16utils/Makefile40
-rw-r--r--x11-wm/e16utils/distinfo2
-rw-r--r--x11-wm/e16utils/files/patch-e16keyedit-0.242
-rw-r--r--x11-wm/e16utils/files/patch-e16menuedit-0.142
-rw-r--r--x11-wm/e16utils/pkg-comment1
-rw-r--r--x11-wm/e16utils/pkg-descr1
-rw-r--r--x11-wm/e16utils/pkg-plist2
8 files changed, 131 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 0fe17d3f8e7c..1bc4687fc93e 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -12,6 +12,7 @@
SUBDIR += bbpager
SUBDIR += blackbox
SUBDIR += ctwm
+ SUBDIR += e16utils
SUBDIR += enlightenment
SUBDIR += epplets
SUBDIR += evilwm
diff --git a/x11-wm/e16utils/Makefile b/x11-wm/e16utils/Makefile
new file mode 100644
index 000000000000..915be91ed275
--- /dev/null
+++ b/x11-wm/e16utils/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: e16utils
+# Date Created: 17 Oct 2000
+# Whom: Jeremy Norris <ishmael27@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e16utils
+PORTVERSION= 0.16
+CATEGORIES= x11-wm
+MASTER_SITES= ftp://ftp.enlightenment.org/pub/enlightenment/e16utils/
+DISTFILES= e16menuedit-0.1.tar.gz e16keyedit-0.2.tar.gz
+
+MAINTAINER= ports@FreeBSD.ORG
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+
+SUB_STUBS= e16menuedit-0.1 e16keyedit-0.2
+
+do-patch:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; ${PATCH} -s < ${PATCHDIR}/patch-${i}
+.endfor
+
+do-build:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; ${SETENV} GTK_CONFIG=${GTK_CONFIG} make all
+.endfor
+
+do-install:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; \
+ ${INSTALL_PROGRAM} `${ECHO} '${i}' | ${SED} -e 's,-\(.*\),,'` \
+ ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e16utils/distinfo b/x11-wm/e16utils/distinfo
new file mode 100644
index 000000000000..73fa1ab6798a
--- /dev/null
+++ b/x11-wm/e16utils/distinfo
@@ -0,0 +1,2 @@
+MD5 (e16menuedit-0.1.tar.gz) = 094fc3b84b19b3afb6f1e2bf5e1f26bc
+MD5 (e16keyedit-0.2.tar.gz) = 0ebff2c6fb749113081b2212c777e19b
diff --git a/x11-wm/e16utils/files/patch-e16keyedit-0.2 b/x11-wm/e16utils/files/patch-e16keyedit-0.2
new file mode 100644
index 000000000000..0f9ebf32df4e
--- /dev/null
+++ b/x11-wm/e16utils/files/patch-e16keyedit-0.2
@@ -0,0 +1,42 @@
+--- Makefile.orig Thu Mar 23 13:04:16 2000
++++ Makefile Tue Oct 17 17:17:01 2000
+@@ -10,23 +10,23 @@
+ BUILD = \
+
+ LIB_DIRS = \
+- -L/usr/local/lib -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/dt/lib
++ -L${LOCALBASE}/lib -L${X11BASE}/lib
+ LIBS = \
+- `gtk-config --libs` -lgdbm -lgdk_imlib
+-CFLAGS = \
+- -O -g -D_GNU_SOURCE $(DEVFLAGS)
++ `${GTK_CONFIG} --libs` -lgdbm -lgdk_imlib
++CFLAGS += \
++ -D_GNU_SOURCE $(DEVFLAGS)
+ #CFLAGS = \
+ # -O -g -W -Wall -Wno-unused -pedantic -pedantic-errors -ansi -D_GNU_SOURCE
+ OPTFLAGS = \
+ -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
+ INCLUDES = \
+- `gtk-config --cflags` -I..
++ `${GTK_CONFIG} --cflags` -I..
+
+ BIN = e16keyedit
+
+ # configurable stuff
+-BINARY_DESTINATION = /usr/local/enlightenment/bin
+-DATA_DESTINATION = /usr/local/enlightenment/share
++BINARY_DESTINATION = ${PREFIX}/bin
++DATA_DESTINATION = ${PREFIX}/share
+
+ # commands to do things
+ INSTALL = install
+@@ -39,7 +39,7 @@
+ MAKE = make
+ STRIP = strip
+ SED = sed
+-MAKEDEP = gcc -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
++MAKEDEP = ${CC} -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
+ #MAKEDEP = makedepend -f- -s'\# CUT' -- -Y $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES) --
+
+ # piece together variables
diff --git a/x11-wm/e16utils/files/patch-e16menuedit-0.1 b/x11-wm/e16utils/files/patch-e16menuedit-0.1
new file mode 100644
index 000000000000..4104871845e1
--- /dev/null
+++ b/x11-wm/e16utils/files/patch-e16menuedit-0.1
@@ -0,0 +1,42 @@
+--- Makefile.orig Sun Apr 16 15:40:03 2000
++++ Makefile Tue Oct 17 18:06:00 2000
+@@ -10,23 +10,23 @@
+ BUILD = \
+
+ LIB_DIRS = \
+- -L/usr/local/lib -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/dt/lib
++ -L${LOCALBASE}/lib -L${X11BASE}/lib
+ LIBS = \
+- `gtk-config --libs` -lgdbm -lgdk_imlib
+-CFLAGS = \
+- -O -g -D_GNU_SOURCE $(DEVFLAGS)
++ `${GTK_CONFIG} --libs` -lgdbm -lgdk_imlib
++CFLAGS += \
++ -D_GNU_SOURCE $(DEVFLAGS)
+ #CFLAGS = \
+ # -O -g -W -Wall -Wno-unused -pedantic -pedantic-errors -ansi -D_GNU_SOURCE
+ OPTFLAGS = \
+ -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
+ INCLUDES = \
+- `gtk-config --cflags` -I..
++ `${GTK_CONFIG} --cflags` -I..
+
+ BIN = e16menuedit
+
+ # configurable stuff
+-BINARY_DESTINATION = /usr/local/enlightenment/bin
+-DATA_DESTINATION = /usr/local/enlightenment/share
++BINARY_DESTINATION = ${PREFIX}/bin
++DATA_DESTINATION = ${PREFIX}/share
+
+ # commands to do things
+ INSTALL = install
+@@ -39,7 +39,7 @@
+ MAKE = make
+ STRIP = strip
+ SED = sed
+-MAKEDEP = gcc -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
++MAKEDEP = ${CC} -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
+ #MAKEDEP = makedepend -f- -s'\# CUT' -- -Y $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES) --
+
+ # piece together variables
diff --git a/x11-wm/e16utils/pkg-comment b/x11-wm/e16utils/pkg-comment
new file mode 100644
index 000000000000..b0673815fd4a
--- /dev/null
+++ b/x11-wm/e16utils/pkg-comment
@@ -0,0 +1 @@
+Standalone menu and keybinding editors for enlightment 0.16
diff --git a/x11-wm/e16utils/pkg-descr b/x11-wm/e16utils/pkg-descr
new file mode 100644
index 000000000000..5918d33b2bef
--- /dev/null
+++ b/x11-wm/e16utils/pkg-descr
@@ -0,0 +1 @@
+Standalone menu and keybinding editors for enlightment 0.16.
diff --git a/x11-wm/e16utils/pkg-plist b/x11-wm/e16utils/pkg-plist
new file mode 100644
index 000000000000..585bfd696d87
--- /dev/null
+++ b/x11-wm/e16utils/pkg-plist
@@ -0,0 +1,2 @@
+bin/e16menuedit
+bin/e16keyedit