aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /x11-wm
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/chamfer/Makefile2
-rw-r--r--x11-wm/fvwm2/Makefile2
-rw-r--r--x11-wm/fvwm3/Makefile2
-rw-r--r--x11-wm/herbstluftwm/Makefile2
-rw-r--r--x11-wm/nscde/Makefile2
-rw-r--r--x11-wm/plasma5-kwin/Makefile2
-rw-r--r--x11-wm/qtile/Makefile2
-rw-r--r--x11-wm/xfce4-panel-profiles/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/x11-wm/chamfer/Makefile b/x11-wm/chamfer/Makefile
index a29986b1ea03..8d725664f58a 100644
--- a/x11-wm/chamfer/Makefile
+++ b/x11-wm/chamfer/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR}
-USES= compiler:c++17-lang meson localbase pkgconfig python:3.3+ xorg
+USES= compiler:c++17-lang meson localbase pkgconfig python xorg
USE_GITHUB= yes
USE_XORG= xcb
GH_ACCOUNT= jaelpark
diff --git a/x11-wm/fvwm2/Makefile b/x11-wm/fvwm2/Makefile
index 71eb232d9572..08401edc3815 100644
--- a/x11-wm/fvwm2/Makefile
+++ b/x11-wm/fvwm2/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mandoc --without-gnome --disable-gtk \
--without-rplay-library \
ac_cv_path_PYTHON=${PYTHON_CMD}
-USES= cpe gmake gnome perl5 pkgconfig python:3.4+ gettext readline xorg
+USES= cpe gmake gnome perl5 pkgconfig python gettext readline xorg
USE_XORG= xcursor xft xinerama xpm xrender x11 ice xext
USE_GNOME= cairo
CFLAGS= -Wno-int-conversion
diff --git a/x11-wm/fvwm3/Makefile b/x11-wm/fvwm3/Makefile
index bf63784fb64d..b1525d7eb148 100644
--- a/x11-wm/fvwm3/Makefile
+++ b/x11-wm/fvwm3/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libevent.so:devel/libevent \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= autoreconf compiler:c11 cpe pkgconfig python:3.7+ readline xorg
+USES= autoreconf compiler:c11 cpe pkgconfig python readline xorg
USE_XORG= ice sm x11 xext xft xrandr xrender xt
CONFLICTS_INSTALL= fvwm
diff --git a/x11-wm/herbstluftwm/Makefile b/x11-wm/herbstluftwm/Makefile
index 719fcbf4755c..c4b1aa2d9d8b 100644
--- a/x11-wm/herbstluftwm/Makefile
+++ b/x11-wm/herbstluftwm/Makefile
@@ -23,7 +23,7 @@ SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_SUB= yes
-DOCS_USES+= python:3.5+,build
+DOCS_USES+= python:build
DOCS_CMAKE_BOOL+= WITH_DOCUMENTATION
DOCS_VARS= binary_alias=python3=${PYTHON_CMD}
diff --git a/x11-wm/nscde/Makefile b/x11-wm/nscde/Makefile
index 87f558769ecf..907fb241dbb1 100644
--- a/x11-wm/nscde/Makefile
+++ b/x11-wm/nscde/Makefile
@@ -52,7 +52,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=5.7.0:sysutils/py-psutil@${PY_FLAVOR
xterm:x11/xterm
USES= desktop-file-utils gettext magick pkgconfig:build pyqt:5 \
- python:3.7+ shebangfix xorg
+ python shebangfix xorg
USE_PYQT= pyqt5
USE_XORG= x11 xext xpm
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index 75131d42f0c5..f50ba58cb9ac 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -34,7 +34,7 @@ RUN_DEPENDS= xwayland-devel>0:x11-servers/xwayland-devel \
CONFLICTS_INSTALL= kwinft # bin/kwin_wayland
USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig \
- python:3.7+,run qt:5 shebangfix tar:xz xorg
+ python:run qt:5 shebangfix tar:xz xorg
USE_GL= egl gbm
USE_GNOME= glib20
USE_KDE= activities attica auth breeze codecs completion config \
diff --git a/x11-wm/qtile/Makefile b/x11-wm/qtile/Makefile
index adc7b45da1bb..d4894f8c5e15 100644
--- a/x11-wm/qtile/Makefile
+++ b/x11-wm/qtile/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xcffib>=0.5.0:x11/py-xcffib@${PY_FLAVOR} \
USE_GNOME= pygobject3
-USES= gnome python:3.7+ localbase
+USES= gnome python localbase
USE_PYTHON= distutils autoplist noflavors
NO_ARCH= yes
diff --git a/x11-wm/xfce4-panel-profiles/Makefile b/x11-wm/xfce4-panel-profiles/Makefile
index 9b95f73ff845..fa56b49926e7 100644
--- a/x11-wm/xfce4-panel-profiles/Makefile
+++ b/x11-wm/xfce4-panel-profiles/Makefile
@@ -10,7 +10,7 @@ WWW= https://git.xfce.org/apps/xfce4-panel-profiles/about/
LICENSE= GPLv3
-USES= gettext-tools gmake gnome python:3.3+ shebangfix tar:bz2 xfce
+USES= gettext-tools gmake gnome python shebangfix tar:bz2 xfce
USE_GNOME= gtk30 intltool
USE_XFCE= panel