aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 21:39:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 21:53:05 +0000
commita79ba32c2ce95911b11dbb6e8143f74dd355444f (patch)
tree6647eafd9f11dfd1d596023422a3e2b18f506dc7 /x11-wm
parent6d558714dfde336df111103f873cef02d65c64c4 (diff)
downloadports-a79ba32c2ce95911b11dbb6e8143f74dd355444f.tar.gz
ports-a79ba32c2ce95911b11dbb6e8143f74dd355444f.zip
x11-wm/subtle: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/subtle/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-wm/subtle/Makefile b/x11-wm/subtle/Makefile
index 8b3515300900..3b0689645b29 100644
--- a/x11-wm/subtle/Makefile
+++ b/x11-wm/subtle/Makefile
@@ -19,14 +19,21 @@ MAKE_CMD= rake -v
MAKEFILE= Rakefile
ALL_TARGET= build
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 1d ${WRKSRC}/data/subtler/runner.rb
@${REINPLACE_CMD} -e 's,File\.exists\?,File.exist?,' \
${WRKSRC}/data/sur/server.rb
@${REINPLACE_CMD} -e 's,/etc/xdg,${LOCALBASE}&,' \
${WRKSRC}/src/subtle/ruby.c
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+ @${REINPLACE_CMD} -e '/cflags/s/-Wall/-Wall -Wno-error=incompatible-function-pointer-types /g' \
+ ${WRKSRC}/Rakefile
+.endif
+
do-configure:
@cd ${WRKSRC} && ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} config
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>