aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2024-02-08 06:03:42 +0000
committerHiroki Sato <hrs@FreeBSD.org>2024-02-08 06:05:12 +0000
commitbee4c95d61d1194bfd89cefbfdd114280eb19013 (patch)
tree3e6edb6c1495ab00e427a8f8d5f306bf3c5c5778 /x11-wm
parentf8dddde0575695643c5c1614cb333182b544c8e6 (diff)
downloadports-bee4c95d61d1194bfd89cefbfdd114280eb19013.tar.gz
ports-bee4c95d61d1194bfd89cefbfdd114280eb19013.zip
x11-wm/windowmaker: Enable XRandR support
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 35af53caa43e..cc6a5bd98555 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -1,5 +1,6 @@
PORTNAME= windowmaker
PORTVERSION= 0.96.0
+PORTREVISION= 1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= https://www.windowmaker.org/pub/source/release/ \
https://github.com/window-maker/wmaker/releases/download/wmaker-${PORTVERSION}/ LOCAL/danfe
@@ -22,12 +23,12 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libexif.so:graphics/libexif
RUN_DEPENDS= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:graphics/wmicons
-USES= cpe gmake gnome jpeg libtool pathfix perl5 pkgconfig \
- shebangfix xorg
+USES= cpe desktop-file-utils gmake gnome jpeg libtool localbase \
+ pathfix perl5 pkgconfig shebangfix xorg
USE_CSTD= c99
USE_GNOME= pango
USE_LDCONFIG= yes
-USE_XORG= x11 xext xft xinerama xmu xpm
+USE_XORG= x11 xext xft xinerama xmu xpm xrandr xres
SHEBANG_FILES= util/wkdemenu.pl
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no \
@@ -42,9 +43,8 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-xinerama \
--enable-usermenu \
--enable-wmreplace \
+ --enable-xrandr \
--with-x
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS BUGFORM BUGS ChangeLog FAQ INSTALL \
@@ -67,7 +67,7 @@ NLS_CONFIGURE_ENABLE= locale
post-patch-IMAGEMAGICK-on:
.if ${IMAGEMAGICK_DEFAULT} == 6
@${REINPLACE_CMD} -e '/MagickWand\.h/s,MagickWand/,wand/,' \
- ${WRKSRC}/configure ${WRKSRC}/wrlib/load_magick.c
+ ${WRKSRC}/configure ${WRKSRC}/wrlib/load_magick.c
.endif
post-install:
@@ -75,8 +75,10 @@ post-install:
${STAGEDIR}${PREFIX}/GNUstep/Applications/WPrefs.app/xpm \
${STAGEDIR}${PREFIX}/share/WindowMaker/Sounds
-post-install-DOCS-on:
+pre-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOCS-on:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>