aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-05-08 15:28:05 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-05-08 15:28:05 +0000
commitc5e7b808d5353a592c1ee9efed8494276124e711 (patch)
tree5ad6eae7c3dc292c3eb3182f37b0b1338cc4233d /x11-wm
parentd67bba5a5a8333a178499aed318122bb9e8cf598 (diff)
downloadports-c5e7b808d5353a592c1ee9efed8494276124e711.tar.gz
ports-c5e7b808d5353a592c1ee9efed8494276124e711.zip
- Update to 4.10.1
- Add new option, NLS - Trim Makefile header - Finish to convert USES - Remove desktopfileutils, because MimeType entry is not present in desktop file
Notes
Notes: svn path=/head/; revision=317676
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-wm/Makefile33
-rw-r--r--x11-wm/xfce4-wm/distinfo4
-rw-r--r--x11-wm/xfce4-wm/files/patch-configure11
-rw-r--r--x11-wm/xfce4-wm/pkg-plist171
4 files changed, 116 insertions, 103 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index e53c30ade3e7..a5dcd47a03e7 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -1,23 +1,20 @@
-# New ports collection makefile for: xfwm4
-# Date created: August 14, 2002
-# Whom: James Earl <jdearl@telus.net>
-#
+# Created by: James Earl <jdearl@telus.net>
# $FreeBSD$
#
PORTNAME= xfce4-wm
-PORTVERSION= 4.10.0
-PORTREVISION= 1
+PORTVERSION= 4.10.1
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/xfce/xfwm4/${PORTVERSION:R}
DISTNAME= xfwm4-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce's window manager
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ wnck-1:${PORTSDIR}/x11-toolkits/libwnck
CONFIGURE_ARGS= --enable-xsync \
--enable-render \
@@ -26,15 +23,15 @@ CONFIGURE_ARGS= --enable-xsync \
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USES= gettext
+USES= pathfix pkgconfig
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig desktopfileutils
+USE_GNOME= gtk20 intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv libmenu libutil xfconf
USE_XORG= x11 sm xext xrandr xrender
DATADIR= ${PREFIX}/share/xfwm4
-OPTIONS_DEFINE= COMPOSITE NOTIFY REVMOUSE
+OPTIONS_DEFINE= COMPOSITE NLS NOTIFY REVMOUSE
OPTIONS_DEFAULT= COMPOSITE NOTIFY
REVMOUSE_DESC= Reverse mouse workspace changing direction
@@ -46,8 +43,17 @@ CONFIGURE_ARGS+=--enable-compositor
CONFIGURE_ARGS+=--disable-compositor
.endif
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
@@ -57,7 +63,4 @@ CONFIGURE_ARGS+=--disable-startup-notification
EXTRA_PATCHES= ${FILESDIR}/extrapatch-src__events.c
.endif
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-wm/distinfo b/x11-wm/xfce4-wm/distinfo
index 1b5742a816f3..20ec30cec004 100644
--- a/x11-wm/xfce4-wm/distinfo
+++ b/x11-wm/xfce4-wm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfwm4-4.10.0.tar.bz2) = 492357bf48121ebffabf2bf0d3b84213d19bf81087321175d687c8a68efe1f9c
-SIZE (xfce4/xfwm4-4.10.0.tar.bz2) = 1100067
+SHA256 (xfce4/xfwm4-4.10.1.tar.bz2) = 380c44fba6eb779e34be0fe94f3726cfa131803014d6073c45aec8a1257fa740
+SIZE (xfce4/xfwm4-4.10.1.tar.bz2) = 1093825
diff --git a/x11-wm/xfce4-wm/files/patch-configure b/x11-wm/xfce4-wm/files/patch-configure
new file mode 100644
index 000000000000..59050f778b4d
--- /dev/null
+++ b/x11-wm/xfce4-wm/files/patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig 2013-05-05 15:58:46.000000000 +0000
++++ ./configure 2013-05-06 18:59:33.000000000 +0000
+@@ -13408,7 +13408,7 @@
+
+ fi
+ fi
+- USE_NLS=yes
++# USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/x11-wm/xfce4-wm/pkg-plist b/x11-wm/xfce4-wm/pkg-plist
index e9e291428292..43caa820e428 100644
--- a/x11-wm/xfce4-wm/pkg-plist
+++ b/x11-wm/xfce4-wm/pkg-plist
@@ -30,70 +30,71 @@ share/icons/hicolor/scalable/actions/xfce-wm-unstick.svg
share/icons/hicolor/scalable/apps/xfce4-workspaces.svg
share/icons/hicolor/scalable/apps/wmtweaks.svg
share/icons/hicolor/scalable/apps/xfwm4.svg
-share/locale/am/LC_MESSAGES/xfwm4.mo
-share/locale/ar/LC_MESSAGES/xfwm4.mo
-share/locale/ast/LC_MESSAGES/xfwm4.mo
-share/locale/az/LC_MESSAGES/xfwm4.mo
-share/locale/be/LC_MESSAGES/xfwm4.mo
-share/locale/bg/LC_MESSAGES/xfwm4.mo
-share/locale/bn/LC_MESSAGES/xfwm4.mo
-share/locale/bn_IN/LC_MESSAGES/xfwm4.mo
-share/locale/ca/LC_MESSAGES/xfwm4.mo
-share/locale/cs/LC_MESSAGES/xfwm4.mo
-share/locale/da/LC_MESSAGES/xfwm4.mo
-share/locale/de/LC_MESSAGES/xfwm4.mo
-share/locale/dz/LC_MESSAGES/xfwm4.mo
-share/locale/el/LC_MESSAGES/xfwm4.mo
-share/locale/en_GB/LC_MESSAGES/xfwm4.mo
-share/locale/eo/LC_MESSAGES/xfwm4.mo
-share/locale/es/LC_MESSAGES/xfwm4.mo
-share/locale/es_MX/LC_MESSAGES/xfwm4.mo
-share/locale/et/LC_MESSAGES/xfwm4.mo
-share/locale/eu/LC_MESSAGES/xfwm4.mo
-share/locale/fa/LC_MESSAGES/xfwm4.mo
-share/locale/fi/LC_MESSAGES/xfwm4.mo
-share/locale/fr/LC_MESSAGES/xfwm4.mo
-share/locale/gl/LC_MESSAGES/xfwm4.mo
-share/locale/gu/LC_MESSAGES/xfwm4.mo
-share/locale/he/LC_MESSAGES/xfwm4.mo
-share/locale/hi/LC_MESSAGES/xfwm4.mo
-share/locale/hr/LC_MESSAGES/xfwm4.mo
-share/locale/hu/LC_MESSAGES/xfwm4.mo
-share/locale/id/LC_MESSAGES/xfwm4.mo
-share/locale/is/LC_MESSAGES/xfwm4.mo
-share/locale/it/LC_MESSAGES/xfwm4.mo
-share/locale/ja/LC_MESSAGES/xfwm4.mo
-share/locale/ka/LC_MESSAGES/xfwm4.mo
-share/locale/kk/LC_MESSAGES/xfwm4.mo
-share/locale/ko/LC_MESSAGES/xfwm4.mo
-share/locale/lt/LC_MESSAGES/xfwm4.mo
-share/locale/lv/LC_MESSAGES/xfwm4.mo
-share/locale/mk/LC_MESSAGES/xfwm4.mo
-share/locale/mr/LC_MESSAGES/xfwm4.mo
-share/locale/ms/LC_MESSAGES/xfwm4.mo
-share/locale/nb/LC_MESSAGES/xfwm4.mo
-share/locale/nl/LC_MESSAGES/xfwm4.mo
-share/locale/nn/LC_MESSAGES/xfwm4.mo
-share/locale/pa/LC_MESSAGES/xfwm4.mo
-share/locale/pl/LC_MESSAGES/xfwm4.mo
-share/locale/pt/LC_MESSAGES/xfwm4.mo
-share/locale/pt_BR/LC_MESSAGES/xfwm4.mo
-share/locale/ro/LC_MESSAGES/xfwm4.mo
-share/locale/ru/LC_MESSAGES/xfwm4.mo
-share/locale/si/LC_MESSAGES/xfwm4.mo
-share/locale/sk/LC_MESSAGES/xfwm4.mo
-share/locale/sq/LC_MESSAGES/xfwm4.mo
-share/locale/sv/LC_MESSAGES/xfwm4.mo
-share/locale/ta/LC_MESSAGES/xfwm4.mo
-share/locale/te/LC_MESSAGES/xfwm4.mo
-share/locale/tr/LC_MESSAGES/xfwm4.mo
-share/locale/ug/LC_MESSAGES/xfwm4.mo
-share/locale/uk/LC_MESSAGES/xfwm4.mo
-share/locale/ur/LC_MESSAGES/xfwm4.mo
-share/locale/ur_PK/LC_MESSAGES/xfwm4.mo
-share/locale/vi/LC_MESSAGES/xfwm4.mo
-share/locale/zh_CN/LC_MESSAGES/xfwm4.mo
-share/locale/zh_TW/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/am/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/az/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/be/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/dz/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/es_MX/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/et/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/is/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/mk/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/si/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/te/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfwm4.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfwm4.mo
share/themes/Daloa/xfwm4/README
share/themes/Daloa/xfwm4/bottom-active.png
share/themes/Daloa/xfwm4/bottom-active.xpm
@@ -575,27 +576,25 @@ share/themes/Moheli/xfwm4/top-right-inactive.xpm
@dirrm share/themes/Daloa/xfwm4
@dirrm share/themes/Daloa
@dirrmtry share/themes
-@dirrmtry share/locale/ur_PK/LC_MESSAGES
-@dirrmtry share/locale/ur_PK
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/te/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/te
+%%NLS%%@dirrmtry share/locale/si/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/si
+%%NLS%%@dirrmtry share/locale/mr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/mr
+%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/kk
+%%NLS%%@dirrmtry share/locale/dz/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/dz
+%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/bn_IN
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
@dirrm lib/xfce4/xfwm4
@dirrmtry lib/xfce4
-@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true