aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-11 22:31:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-11 22:31:22 +0000
commitcb29de57bb5211e526958256b7f8ec883425e4c4 (patch)
treeca046cba03dab6d65bef60274b0923d5e7bc6bd5 /x11-wm
parent84a66afc908a45f044ec1a877f18622e84fc4119 (diff)
downloadports-cb29de57bb5211e526958256b7f8ec883425e4c4.tar.gz
ports-cb29de57bb5211e526958256b7f8ec883425e4c4.zip
x11-wm/enlightenment: fix packaging on powerpc
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-wm/enlightenment/Makefile b/x11-wm/enlightenment/Makefile
index e65183e1c12a..3f101530befb 100644
--- a/x11-wm/enlightenment/Makefile
+++ b/x11-wm/enlightenment/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libefl.so:devel/efl \
libpulse.so:audio/pulseaudio
USES= compiler:c11 desktop-file-utils gettext-tools gnome \
- meson ninja iconv libtool pathfix pkgconfig tar:xz xorg
+ localbase:ldflags meson ninja iconv libtool pathfix pkgconfig \
+ tar:xz xorg
USE_XORG= xcb
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -25,8 +26,6 @@ MESON_ARGS= -Dsystemd=false -Ddevice-udev=false \
-Dmount-udisks=false -Dmount-eeze=false -Dbluez5=false \
-Dconnman=false --sysconfdir=/usr/local/etc
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALLS_ICONS= yes
OPTIONS_DEFINE= NLS
@@ -46,10 +45,14 @@ ENLIGHTENMENT_ARCH= ${OPSYS:tl}-x86
.if ${CURRENT_ARCH:Mpowerpc64*}
ENLIGHTENMENT_ARCH= ${OPSYS:tl}-ppc64
.else
+.if ${CURRENT_ARCH} == powerpc
+ENLIGHTENMENT_ARCH= ${OPSYS:tl}-ppc
+.else
ENLIGHTENMENT_ARCH= ${OPSYS:tl}-${CURRENT_ARCH}
.endif
.endif
.endif
+.endif
ENLIGHTENMENT_VERSION= 0.24.2
PLIST_SUB= ENLIGHTENMENT_ARCH=${ENLIGHTENMENT_ARCH}-${ENLIGHTENMENT_VERSION}