aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-30 01:48:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-30 01:48:49 +0000
commite834875a4bec53c34d59f29b7040285731c602ba (patch)
tree8e574e63a7d216b96059588b4192d8eb67b844ae /x11-wm
parent06ff5efaf17833291aee2ba75a01b12930aa5466 (diff)
downloadports-e834875a4bec53c34d59f29b7040285731c602ba.tar.gz
ports-e834875a4bec53c34d59f29b7040285731c602ba.zip
Kickshaw is a menu editor for the Openbox window manager (but not only).
Notes
Notes: svn path=/head/; revision=524618
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/kickshaw/Makefile40
-rw-r--r--x11-wm/kickshaw/distinfo3
-rw-r--r--x11-wm/kickshaw/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index fa019bd375cd..e4814afb4e4a 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -65,6 +65,7 @@
SUBDIR += ion
SUBDIR += jewel
SUBDIR += jwm
+ SUBDIR += kickshaw
SUBDIR += larswm
SUBDIR += libcompizconfig
SUBDIR += libdockapp
diff --git a/x11-wm/kickshaw/Makefile b/x11-wm/kickshaw/Makefile
new file mode 100644
index 000000000000..0c856d69c96a
--- /dev/null
+++ b/x11-wm/kickshaw/Makefile
@@ -0,0 +1,40 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kickshaw
+PORTVERSION= 0.5.26
+CATEGORIES= x11-wm
+MASTER_SITES= SAVANNAH/obladi
+DISTNAME= ${PORTNAME}_${PORTVERSION}_source_only
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Menu editor for the Openbox window manager
+
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= gnome pkgconfig tar:bzip2
+USE_GNOME= cairo gdkpixbuf2
+MAKE_ARGS= CC="${CC}"
+
+OPTIONS_DEFINE= GTK2 GTK3
+OPTIONS_DEFAULT= GTK2 GTK3
+
+do-build do-install:
+ @${DO_NADA}
+
+.for v in 2 3
+GTK${v}_USE= GNOME=gtk${v}0
+GTK${v}_PLIST_FILES= bin/${PORTNAME}-gtk${v}
+
+do-build-GTK${v}-on:
+ ${DO_MAKE_BUILD} -C ${BUILD_WRKSRC}/GTK${v}/source
+
+do-install-GTK${v}-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/GTK${v}/source/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-gtk${v}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-wm/kickshaw/distinfo b/x11-wm/kickshaw/distinfo
new file mode 100644
index 000000000000..50fa14b2b507
--- /dev/null
+++ b/x11-wm/kickshaw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523785329
+SHA256 (kickshaw_0.5.26_source_only.tar.bz2) = bc767c45fdebf15492db5251d67c0b508ec14252f1505689652de3a9ca4807fe
+SIZE (kickshaw_0.5.26_source_only.tar.bz2) = 168701
diff --git a/x11-wm/kickshaw/pkg-descr b/x11-wm/kickshaw/pkg-descr
new file mode 100644
index 000000000000..eb292851109f
--- /dev/null
+++ b/x11-wm/kickshaw/pkg-descr
@@ -0,0 +1,5 @@
+Kickshaw is not dependent on Openbox; it can be used inside all window
+managers/desktop environments that support GTK applications to create
+and edit menu files.
+
+WWW: http://savannah.nongnu.org/projects/obladi