aboutsummaryrefslogtreecommitdiff
path: root/x11/9box
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-23 19:45:43 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-23 19:45:43 +0000
commit47c6c49d3076e0e7be7369004e0abeee22ae41d8 (patch)
tree0c10a71173cc990797e5ecc4a6d78a990f524af2 /x11/9box
parent73dd8639068ae7493e9026c2411e13ff30ed6720 (diff)
downloadports-47c6c49d3076e0e7be7369004e0abeee22ae41d8.tar.gz
ports-47c6c49d3076e0e7be7369004e0abeee22ae41d8.zip
Add 9box 0.2.1, 9box can "pack" windows inside itself.
PR: 50172 Submitted by: Serge Gagnon <gagnon__s@videotron.ca>
Notes
Notes: svn path=/head/; revision=85481
Diffstat (limited to 'x11/9box')
-rw-r--r--x11/9box/Makefile31
-rw-r--r--x11/9box/distinfo1
-rw-r--r--x11/9box/files/patch-src::Makefile19
-rw-r--r--x11/9box/pkg-descr9
-rw-r--r--x11/9box/pkg-plist1
5 files changed, 61 insertions, 0 deletions
diff --git a/x11/9box/Makefile b/x11/9box/Makefile
new file mode 100644
index 000000000000..0efe3ce6310e
--- /dev/null
+++ b/x11/9box/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: 9box
+# Date created: Fri Mar 21 10:10:48 EST 2003
+# Whom: Serge Gagnon <gagnon__s@videotron.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 9box
+PORTVERSION= 0.2.1
+CATEGORIES= x11
+MASTER_SITES= http://freesoftware.fsf.org/download/9box/ \
+ http://savannah.nongnu.org/download/9box/
+
+MAINTAINER= gagnon__s@videotron.ca
+COMMENT= 9box can "pack" windows inside itself
+
+USE_REINPLACE= yes
+USE_XLIB= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/src/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/9box ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/9box/distinfo b/x11/9box/distinfo
new file mode 100644
index 000000000000..643cecaf5612
--- /dev/null
+++ b/x11/9box/distinfo
@@ -0,0 +1 @@
+MD5 (9box-0.2.1.tar.gz) = b762aee591335a6cb4a3b75700ff1abe
diff --git a/x11/9box/files/patch-src::Makefile b/x11/9box/files/patch-src::Makefile
new file mode 100644
index 000000000000..6391a9423197
--- /dev/null
+++ b/x11/9box/files/patch-src::Makefile
@@ -0,0 +1,19 @@
+--- src/Makefile.orig Tue Oct 29 17:20:46 2002
++++ src/Makefile Wed Jul 23 21:35:39 2003
+@@ -1,10 +1,14 @@
++CC?= cc
++CFLAGS+= -g -I. -I%%X11BASE%%/include
++LIBS+= -L%%X11BASE%%/lib -lX11
++
+ all: 9box
+
+ 9box: grab.o 9box.o manage.o menu.o buttons.o utils.o wm.o
+- gcc -g -L/usr/X11R6/lib -lX11 -o $@ $^
++ $(CC) $(CFLAGS) $(LIBS) -o $@ $^
+
+ %.o: %.c
+- gcc -g -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm -f *.o 9box *~
diff --git a/x11/9box/pkg-descr b/x11/9box/pkg-descr
new file mode 100644
index 000000000000..d062f37b6e0f
--- /dev/null
+++ b/x11/9box/pkg-descr
@@ -0,0 +1,9 @@
+9box aims to develop an application which can "pack" windows inside
+itself.
+
+This will allow to use applications as if they were put in tabs.
+This behaviour is similar in spirit with konsole, but 9box will
+allow to pack windows from different applications as well as
+multiple instances from the same application.
+
+WWW: http://www.nongnu.org/9box/
diff --git a/x11/9box/pkg-plist b/x11/9box/pkg-plist
new file mode 100644
index 000000000000..9db05c2be4c2
--- /dev/null
+++ b/x11/9box/pkg-plist
@@ -0,0 +1 @@
+bin/9box