aboutsummaryrefslogtreecommitdiff
path: root/x11/babl/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-08 21:13:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-08 21:13:31 +0000
commit0f017c5d71b6752a59db4d4c5f14d4e3f4bf7efd (patch)
tree7090cac594f0f5a58d2817710fd2f966ef9911d2 /x11/babl/Makefile
parent903cef665ee204719f58255b4f452a3e2dc31d4e (diff)
downloadports-0f017c5d71b6752a59db4d4c5f14d4e3f4bf7efd.tar.gz
ports-0f017c5d71b6752a59db4d4c5f14d4e3f4bf7efd.zip
Correct the logic of the SIMD option so that packages are not built with
unwanted optimizations. PR: 137114 Submitted by: Anonymous <swell.k@gmail.com>
Notes
Notes: svn path=/head/; revision=239181
Diffstat (limited to 'x11/babl/Makefile')
-rw-r--r--x11/babl/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
index 6615e3af3379..e7b0a1b86fd2 100644
--- a/x11/babl/Makefile
+++ b/x11/babl/Makefile
@@ -31,10 +31,10 @@ OPTIONS= SIMD "Use cpu-specific optimizations if available" off
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SIMD)
-CONFIGURE_ARGS+=--enable-mmx \
- --enable-sse \
- --enable-altivec
+.if defined(WITHOUT_SIMD)
+CONFIGURE_ARGS+=--disable-mmx \
+ --disable-sse \
+ --disable-altivec
.endif
.include <bsd.port.post.mk>