aboutsummaryrefslogtreecommitdiff
path: root/x11/babl/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-02 21:35:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-02 21:35:01 +0000
commit13cf3b21c8098e10a5ce8299f4d2a159f88305ed (patch)
treeb9e9761d55fb640818e70c26b2ed286da0f353f5 /x11/babl/Makefile
parent77f617c8f77c315d350ecc80311b681c6ebe7e71 (diff)
downloadports-13cf3b21c8098e10a5ce8299f4d2a159f88305ed.tar.gz
ports-13cf3b21c8098e10a5ce8299f4d2a159f88305ed.zip
* Add support for SIMDoptimizations (off by default).
* Fix the invocation of mktemp to prevent a spurious error. PR: 137114 Submitted by: Anonymous <swell.k@gmail.com>
Notes
Notes: svn path=/head/; revision=238792
Diffstat (limited to 'x11/babl/Makefile')
-rw-r--r--x11/babl/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
index e731eff6185a..6615e3af3379 100644
--- a/x11/babl/Makefile
+++ b/x11/babl/Makefile
@@ -27,4 +27,14 @@ USE_AUTOTOOLS= libtool:22
USE_GNOME= pkgconfig gnomehack ltverhack
USE_GMAKE= yes
-.include <bsd.port.mk>
+OPTIONS= SIMD "Use cpu-specific optimizations if available" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SIMD)
+CONFIGURE_ARGS+=--enable-mmx \
+ --enable-sse \
+ --enable-altivec
+.endif
+
+.include <bsd.port.post.mk>