aboutsummaryrefslogtreecommitdiff
path: root/x11/cde-devel
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2024-02-17 00:54:59 +0000
committerCy Schubert <cy@FreeBSD.org>2024-02-17 05:45:39 +0000
commit9b9fcabd04c70c0d6a3798321551ec016467b0de (patch)
treee9368874ebb5cebc1fb3dc8bdc94e94036d4ac6a /x11/cde-devel
parent66c11db6b2f41f0e10419a280142672cf2fa5a0d (diff)
downloadports-9b9fcabd04c70c0d6a3798321551ec016467b0de.tar.gz
ports-9b9fcabd04c70c0d6a3798321551ec016467b0de.zip
x11/cde*: Work around a SIGBUS in dtcreate
dtcreate has been experiencing SIGBUS since llvm 17 import. Fall back to llvm 16 until this problem can be more thoroughly investigated.
Diffstat (limited to 'x11/cde-devel')
-rw-r--r--x11/cde-devel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11/cde-devel/Makefile b/x11/cde-devel/Makefile
index a95907c75f48..8ecf7d41e810 100644
--- a/x11/cde-devel/Makefile
+++ b/x11/cde-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cde
PORTVERSION= ${COMMIT_DATE}
+PORTREVISION= 1
CATEGORIES= x11
.if !defined(MASTERDIR)
PKGNAMESUFFIX= -devel
@@ -47,7 +48,7 @@ RUN_DEPENDS= ksh93:shells/ksh \
sessreg:x11/sessreg
USES= autoreconf:build iconv:wchar_t gmake jpeg libtool motif perl5 \
- shebangfix tcl:86 xorg
+ shebangfix tcl:86 xorg llvm:16
SHEBANG_LANG= pl
SHEBANG_FILES= programs/dtinfo/tools/bin/ccdate \
programs/dtdocbook/tcl/docbook.tcl
@@ -66,7 +67,8 @@ MAKE_ARGS+= PERL=${PERL} "LOCAL_LDFLAGS=${LDFLAGS}"
MAKE_JOBS_UNSAFE=yes
MAKE_ENV= MALLOC_CONF=junk:false
SUB_FILES= pkg-message
-CFLAGS+= -Wno-register -Wno-incompatible-function-pointer-types
+CFLAGS+= -Wno-register -Wno-incompatible-function-pointer-types \
+ -Wno-implicit-function-declaration
LDFLAGS+= -z muldefs #--allow-multiple-definition
pre-configure: