aboutsummaryrefslogtreecommitdiff
path: root/x11/cde/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2019-04-24 19:34:04 +0000
committerChris Rees <crees@FreeBSD.org>2019-04-24 19:34:04 +0000
commit88a9eed5e9f168418cb8bc8bf4c7478449f477c1 (patch)
treeeeeb91f36e18b1efb941045602543d7b1f33ad3c /x11/cde/Makefile
parent32daaae72c4bea6711020b6b7a68acbaf0af386e (diff)
downloadports-88a9eed5e9f168418cb8bc8bf4c7478449f477c1.tar.gz
ports-88a9eed5e9f168418cb8bc8bf4c7478449f477c1.zip
x11/cde: Fix building on FreeBSD 12
Add some missing dependencies and a couple more shebang fixes PR: ports/237518 Submitted by: Thomas Merkel MFH: 2019Q2 (build fix)
Notes
Notes: svn path=/head/; revision=499898
Diffstat (limited to 'x11/cde/Makefile')
-rw-r--r--x11/cde/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11/cde/Makefile b/x11/cde/Makefile
index 46b95c03655b..c237555c563f 100644
--- a/x11/cde/Makefile
+++ b/x11/cde/Makefile
@@ -26,12 +26,15 @@ RUN_DEPENDS= ${LOCALBASE}/bin/fc-cache:x11-fonts/fontconfig \
xrdb:x11/xrdb \
xset:x11/xset
-USES= iconv motif perl5 shebangfix tcl:85
+USES= iconv:wchar_t motif perl5 shebangfix tcl:85
+SHEBANG_LANG= pl ksh tcl
SHEBANG_FILES= programs/dtdocbook/sgmls/sgmls.pl \
- programs/dtinfo/tools/bin/ccdate
+ programs/dtinfo/tools/bin/ccdate \
+ programs/dtdocbook/doc2sdl/docbook.tcl \
+ programs/dtdocbook/doc2sdl/dtdocbook
USE_LDCONFIG= ${PREFIX}/dt/lib
USE_RC_SUBR= dtcms dtspc
-USE_XORG= xinerama xp xt xscrnsaver
+USE_XORG= ice sm x11 xau xdmcp xext xinerama xmu xp xscrnsaver xt
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
ALL_TARGET= World
@@ -39,12 +42,6 @@ MAKE_ARGS+= PERL=${PERL}
MAKE_JOBS_UNSAFE=yes
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} > 1200000
-BROKEN= Does not build on head
-.endif
-
post-patch:
@if [ -f /usr/include/iconv.h ]; then \
${REINPLACE_CMD} -e 's!^[[:space:]]*const char .ip = (const char .) .bp!char *ip = *bp!' \