aboutsummaryrefslogtreecommitdiff
path: root/x11/clipcat/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-26 22:19:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-26 22:47:22 +0000
commit7f99f1041c0fe82b0cde1012f0ea67ccfc27144c (patch)
tree925486dc94e3e7a902d077f273c55276ed01c1de /x11/clipcat/Makefile
parentdb2a9c1a32cd14aab3fdb8f427af9a9e2f0c052b (diff)
downloadports-7f99f1041c0fe82b0cde1012f0ea67ccfc27144c.tar.gz
ports-7f99f1041c0fe82b0cde1012f0ea67ccfc27144c.zip
x11/clipcat: update 0.5.0 → 0.6.0
Reported by: portscout
Diffstat (limited to 'x11/clipcat/Makefile')
-rw-r--r--x11/clipcat/Makefile516
1 files changed, 306 insertions, 210 deletions
diff --git a/x11/clipcat/Makefile b/x11/clipcat/Makefile
index 907d065fe120..134ccc3baf8f 100644
--- a/x11/clipcat/Makefile
+++ b/x11/clipcat/Makefile
@@ -1,7 +1,6 @@
PORTNAME= clipcat
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
-PORTREVISION= 9
+DISTVERSION= 0.6.0
CATEGORIES= x11
MAINTAINER= yuri@FreeBSD.org
@@ -21,221 +20,314 @@ GH_ACCOUNT= xrelkd
MAKE_ENV= LLVM_CONFIG_PATH=${LLVM_CONFIG}
-CARGO_CRATES= aho-corasick-0.7.15 \
- ansi_term-0.11.0 \
- ansi_term-0.12.1 \
- anyhow-1.0.38 \
- app_dirs-1.2.1 \
- arrayref-0.3.6 \
- arrayvec-0.5.2 \
- async-stream-0.3.0 \
- async-stream-impl-0.3.0 \
- async-trait-0.1.42 \
+CARGO_CRATES= addr2line-0.21.0 \
+ adler-1.0.2 \
+ aho-corasick-1.1.2 \
+ android-tzdata-0.1.1 \
+ android_system_properties-0.1.5 \
+ anstream-0.6.4 \
+ anstyle-1.0.4 \
+ anstyle-parse-0.2.2 \
+ anstyle-query-1.0.0 \
+ anstyle-wincon-3.0.1 \
+ anyhow-1.0.75 \
+ arboard-3.3.0 \
+ arrayvec-0.7.4 \
+ async-stream-0.3.5 \
+ async-stream-impl-0.3.5 \
+ async-trait-0.1.74 \
atty-0.2.14 \
- autocfg-1.0.1 \
- base64-0.13.0 \
- beef-0.4.4 \
- bincode-1.3.1 \
- bindgen-0.54.0 \
- bitflags-1.2.1 \
- blake2b_simd-0.5.11 \
- boxfnonce-0.1.1 \
- byteorder-1.4.2 \
- bytes-1.0.1 \
- cc-1.0.66 \
- cexpr-0.4.0 \
- cfg-if-0.1.10 \
+ autocfg-1.1.0 \
+ axum-0.6.20 \
+ axum-core-0.3.4 \
+ backtrace-0.3.69 \
+ base64-0.21.5 \
+ beef-0.5.2 \
+ bincode-1.3.3 \
+ bit_field-0.10.2 \
+ bitflags-1.3.2 \
+ bitflags-2.4.1 \
+ block-0.1.6 \
+ bumpalo-3.14.0 \
+ bytecount-0.6.7 \
+ bytemuck-1.14.0 \
+ byteorder-1.5.0 \
+ bytes-1.5.0 \
+ cc-1.0.83 \
cfg-if-1.0.0 \
- chrono-0.4.19 \
- clang-sys-0.29.3 \
- clap-2.33.3 \
- const_fn-0.4.5 \
- constant_time_eq-0.1.5 \
- crossbeam-0.7.3 \
- crossbeam-channel-0.4.4 \
- crossbeam-channel-0.5.0 \
- crossbeam-deque-0.7.3 \
- crossbeam-deque-0.8.0 \
- crossbeam-epoch-0.8.2 \
- crossbeam-epoch-0.9.1 \
- crossbeam-queue-0.2.3 \
- crossbeam-utils-0.7.2 \
- crossbeam-utils-0.8.1 \
- daemonize-0.4.1 \
- darling-0.10.2 \
- darling_core-0.10.2 \
- darling_macro-0.10.2 \
- defer-drop-1.0.1 \
- derive_builder-0.9.0 \
- derive_builder_core-0.9.0 \
- dirs-2.0.2 \
- dirs-sys-0.3.5 \
+ chrono-0.4.31 \
+ clap-3.2.25 \
+ clap-4.4.8 \
+ clap_builder-4.4.8 \
+ clap_complete-4.4.4 \
+ clap_derive-4.4.7 \
+ clap_lex-0.2.4 \
+ clap_lex-0.6.0 \
+ clipboard-win-4.5.0 \
+ color_quant-1.1.0 \
+ colorchoice-1.0.0 \
+ core-foundation-0.9.3 \
+ core-foundation-sys-0.8.4 \
+ core-graphics-0.22.3 \
+ core-graphics-types-0.1.2 \
+ crc32fast-1.3.2 \
+ crossbeam-0.8.2 \
+ crossbeam-channel-0.5.8 \
+ crossbeam-deque-0.8.3 \
+ crossbeam-epoch-0.9.15 \
+ crossbeam-queue-0.3.8 \
+ crossbeam-utils-0.8.16 \
+ crunchy-0.2.2 \
+ daemonize-0.5.0 \
+ darling-0.14.4 \
+ darling-0.20.3 \
+ darling_core-0.14.4 \
+ darling_core-0.20.3 \
+ darling_macro-0.14.4 \
+ darling_macro-0.20.3 \
+ defer-drop-1.3.0 \
+ deranged-0.3.9 \
+ derive-new-0.5.9 \
+ derive_builder-0.11.2 \
+ derive_builder_core-0.11.2 \
+ derive_builder_macro-0.11.2 \
+ directories-5.0.1 \
+ dirs-next-2.0.0 \
+ dirs-sys-0.4.1 \
+ dirs-sys-next-0.1.2 \
+ dlib-0.5.2 \
doc-comment-0.3.3 \
- either-1.6.1 \
- env_logger-0.6.2 \
- env_logger-0.7.1 \
- fixedbitset-0.2.0 \
+ downcast-rs-1.2.0 \
+ either-1.9.0 \
+ env_logger-0.9.3 \
+ equivalent-1.0.1 \
+ errno-0.3.7 \
+ error-code-2.3.1 \
+ exitcode-1.1.2 \
+ exr-1.71.0 \
+ fastrand-2.0.1 \
+ fdeflate-0.3.1 \
+ fixedbitset-0.4.2 \
+ flate2-1.0.28 \
+ flume-0.11.0 \
fnv-1.0.7 \
- futures-0.3.12 \
- futures-channel-0.3.12 \
- futures-core-0.3.12 \
- futures-executor-0.3.12 \
- futures-io-0.3.12 \
- futures-macro-0.3.12 \
- futures-sink-0.3.12 \
- futures-task-0.3.12 \
- futures-util-0.3.12 \
+ foreign-types-0.3.2 \
+ foreign-types-shared-0.1.1 \
+ futures-0.3.29 \
+ futures-channel-0.3.29 \
+ futures-core-0.3.29 \
+ futures-executor-0.3.29 \
+ futures-io-0.3.29 \
+ futures-macro-0.3.29 \
+ futures-sink-0.3.29 \
+ futures-task-0.3.29 \
+ futures-util-0.3.29 \
fuzzy-matcher-0.3.7 \
- getrandom-0.1.16 \
- getrandom-0.2.2 \
- glob-0.3.0 \
- h2-0.3.0 \
- hashbrown-0.9.1 \
- heck-0.3.2 \
- hermit-abi-0.1.18 \
- http-0.2.3 \
- http-body-0.4.0 \
- httparse-1.3.5 \
- httpdate-0.3.2 \
- humantime-1.3.0 \
- hyper-0.14.4 \
+ gethostname-0.3.0 \
+ getrandom-0.2.11 \
+ gif-0.12.0 \
+ gimli-0.28.0 \
+ h2-0.3.22 \
+ half-2.2.1 \
+ hashbrown-0.12.3 \
+ hashbrown-0.14.2 \
+ heck-0.4.1 \
+ hermit-abi-0.1.19 \
+ hermit-abi-0.3.3 \
+ hex-0.4.3 \
+ home-0.5.5 \
+ http-0.2.11 \
+ http-1.0.0 \
+ http-body-0.4.5 \
+ httparse-1.8.0 \
+ httpdate-1.0.3 \
+ humantime-2.1.0 \
+ hyper-0.14.27 \
+ hyper-timeout-0.4.1 \
+ iana-time-zone-0.1.58 \
+ iana-time-zone-haiku-0.1.2 \
ident_case-1.0.1 \
- indexmap-1.6.1 \
- itertools-0.9.0 \
- itoa-0.4.7 \
- jobserver-0.1.21 \
+ image-0.24.7 \
+ indexmap-1.9.3 \
+ indexmap-2.1.0 \
+ itertools-0.11.0 \
+ itoa-1.0.9 \
+ jpeg-decoder-0.3.0 \
+ js-sys-0.3.65 \
lazy_static-1.4.0 \
- lazycell-1.3.0 \
- libc-0.2.85 \
- libloading-0.5.2 \
- librocksdb-sys-6.11.4 \
- log-0.4.14 \
- matchers-0.0.1 \
- maybe-uninit-2.0.0 \
- memchr-2.3.4 \
- memoffset-0.5.6 \
- memoffset-0.6.1 \
- mio-0.7.7 \
- miow-0.3.6 \
- multimap-0.8.2 \
- nix-0.14.1 \
- nom-5.1.2 \
- ntapi-0.3.6 \
- num-integer-0.1.44 \
- num-traits-0.2.14 \
- num_cpus-1.13.0 \
- ole32-sys-0.2.0 \
- once_cell-1.5.2 \
- peeking_take_while-0.1.2 \
- percent-encoding-2.1.0 \
- petgraph-0.5.1 \
- pin-project-0.4.27 \
- pin-project-1.0.5 \
- pin-project-internal-0.4.27 \
- pin-project-internal-1.0.5 \
- pin-project-lite-0.2.4 \
+ lebe-0.5.2 \
+ libc-0.2.150 \
+ libloading-0.8.1 \
+ libredox-0.0.1 \
+ linux-raw-sys-0.4.11 \
+ lock_api-0.4.11 \
+ log-0.4.20 \
+ malloc_buf-0.0.6 \
+ matchit-0.7.3 \
+ memchr-2.6.4 \
+ memoffset-0.6.5 \
+ memoffset-0.7.1 \
+ memoffset-0.9.0 \
+ mime-0.3.17 \
+ minimal-lexical-0.2.1 \
+ miniz_oxide-0.7.1 \
+ mio-0.8.9 \
+ multimap-0.8.3 \
+ nix-0.24.3 \
+ nix-0.25.1 \
+ nix-0.26.4 \
+ nom-7.1.3 \
+ nu-ansi-term-0.46.0 \
+ num-integer-0.1.45 \
+ num-rational-0.4.1 \
+ num-traits-0.2.17 \
+ num_cpus-1.16.0 \
+ num_threads-0.1.6 \
+ objc-0.2.7 \
+ objc-foundation-0.1.1 \
+ objc_id-0.1.1 \
+ object-0.32.1 \
+ once_cell-1.18.0 \
+ option-ext-0.2.0 \
+ os_pipe-1.1.4 \
+ os_str_bytes-6.6.1 \
+ overload-0.1.1 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.9.9 \
+ percent-encoding-2.3.0 \
+ petgraph-0.6.4 \
+ pin-project-1.1.3 \
+ pin-project-internal-1.1.3 \
+ pin-project-lite-0.2.13 \
pin-utils-0.1.0 \
- ppv-lite86-0.2.10 \
- proc-macro-error-1.0.4 \
- proc-macro-error-attr-1.0.4 \
- proc-macro-hack-0.5.19 \
- proc-macro-nested-0.1.7 \
- proc-macro2-1.0.24 \
- prost-0.7.0 \
- prost-build-0.7.0 \
- prost-derive-0.7.0 \
- prost-types-0.7.0 \
- quick-error-1.2.3 \
- quote-1.0.8 \
- rand-0.8.3 \
- rand_chacha-0.3.0 \
- rand_core-0.6.1 \
- rand_hc-0.3.0 \
- rayon-1.5.0 \
- rayon-core-1.9.0 \
- redox_syscall-0.1.57 \
- redox_syscall-0.2.4 \
- redox_users-0.3.5 \
- regex-1.4.3 \
- regex-automata-0.1.9 \
- regex-syntax-0.6.22 \
- remove_dir_all-0.5.3 \
- rocksdb-0.15.0 \
- rust-argon2-0.8.3 \
- rustc-hash-1.1.0 \
- ryu-1.0.5 \
- scopeguard-1.1.0 \
- serde-1.0.123 \
- serde_derive-1.0.123 \
- serde_json-1.0.62 \
- serde_with-1.6.2 \
- serde_with_macros-1.3.0 \
- sharded-slab-0.1.1 \
- shell32-sys-0.1.2 \
- shlex-0.1.1 \
- signal-hook-registry-1.3.0 \
- skim-0.9.3 \
- slab-0.4.2 \
- smallvec-1.6.1 \
- snafu-0.6.10 \
- snafu-derive-0.6.10 \
- socket2-0.3.19 \
- strsim-0.8.0 \
- strsim-0.9.3 \
- structopt-0.3.21 \
- structopt-derive-0.4.14 \
- syn-1.0.60 \
- tempfile-3.2.0 \
- term-0.6.1 \
- termcolor-1.1.2 \
- textwrap-0.11.0 \
- thiserror-1.0.23 \
- thiserror-impl-1.0.23 \
- thread_local-1.1.3 \
- time-0.1.43 \
+ pkg-config-0.3.27 \
+ png-0.17.10 \
+ powerfmt-0.2.0 \
+ ppv-lite86-0.2.17 \
+ prettyplease-0.2.15 \
+ proc-macro2-1.0.69 \
+ prost-0.12.3 \
+ prost-build-0.12.3 \
+ prost-derive-0.12.3 \
+ prost-types-0.12.3 \
+ qoi-0.4.1 \
+ quick-xml-0.30.0 \
+ quote-1.0.33 \
+ rand-0.8.5 \
+ rand_chacha-0.3.1 \
+ rand_core-0.6.4 \
+ rayon-1.8.0 \
+ rayon-core-1.12.0 \
+ redox_syscall-0.4.1 \
+ redox_users-0.4.4 \
+ regex-1.10.2 \
+ regex-automata-0.4.3 \
+ regex-syntax-0.8.2 \
+ rustc-demangle-0.1.23 \
+ rustix-0.38.25 \
+ rustversion-1.0.14 \
+ ryu-1.0.15 \
+ scoped-tls-1.0.1 \
+ scopeguard-1.2.0 \
+ serde-1.0.193 \
+ serde_derive-1.0.193 \
+ serde_json-1.0.108 \
+ serde_spanned-0.6.4 \
+ serde_with-3.4.0 \
+ serde_with_macros-3.4.0 \
+ sharded-slab-0.1.7 \
+ shlex-1.2.0 \
+ sigfinn-0.1.1 \
+ signal-hook-registry-1.4.1 \
+ simd-adler32-0.3.7 \
+ skim-0.10.4 \
+ slab-0.4.9 \
+ smallvec-1.11.2 \
+ snafu-0.7.5 \
+ snafu-derive-0.7.5 \
+ socket2-0.4.10 \
+ socket2-0.5.5 \
+ spin-0.9.8 \
+ str-buf-1.0.6 \
+ strsim-0.10.0 \
+ syn-1.0.109 \
+ syn-2.0.39 \
+ sync_wrapper-0.1.2 \
+ tempfile-3.8.1 \
+ term-0.7.0 \
+ termcolor-1.4.0 \
+ textwrap-0.16.0 \
+ thiserror-1.0.50 \
+ thiserror-impl-1.0.50 \
+ thread_local-1.1.7 \
+ tiff-0.9.0 \
+ time-0.3.30 \
+ time-core-0.1.2 \
+ time-macros-0.2.15 \
timer-0.2.0 \
- tokio-1.2.0 \
- tokio-macros-1.1.0 \
- tokio-stream-0.1.3 \
- tokio-util-0.6.3 \
- toml-0.5.8 \
- tonic-0.4.0 \
- tonic-build-0.4.0 \
- tower-0.4.4 \
- tower-layer-0.3.1 \
- tower-service-0.3.1 \
- tracing-0.1.23 \
- tracing-attributes-0.1.12 \
- tracing-core-0.1.17 \
- tracing-futures-0.2.4 \
- tracing-journald-0.1.0 \
- tracing-log-0.1.1 \
- tracing-serde-0.1.2 \
- tracing-subscriber-0.2.15 \
- try-lock-0.2.3 \
- tuikit-0.4.3 \
- unicode-segmentation-1.7.1 \
- unicode-width-0.1.8 \
- unicode-xid-0.2.1 \
- utf8parse-0.1.1 \
- vec_map-0.8.2 \
- version_check-0.9.2 \
- void-1.0.2 \
- vte-0.3.3 \
- want-0.3.0 \
- wasi-0.9.0+wasi-snapshot-preview1 \
- wasi-0.10.2+wasi-snapshot-preview1 \
- which-3.1.1 \
- which-4.0.2 \
- winapi-0.2.8 \
+ tokio-1.34.0 \
+ tokio-io-timeout-1.2.0 \
+ tokio-macros-2.2.0 \
+ tokio-stream-0.1.14 \
+ tokio-util-0.7.10 \
+ toml-0.8.8 \
+ toml_datetime-0.6.5 \
+ toml_edit-0.21.0 \
+ tonic-0.10.2 \
+ tonic-build-0.10.2 \
+ tower-0.4.13 \
+ tower-layer-0.3.2 \
+ tower-service-0.3.2 \
+ tracing-0.1.40 \
+ tracing-attributes-0.1.27 \
+ tracing-core-0.1.32 \
+ tracing-journald-0.3.0 \
+ tracing-log-0.2.0 \
+ tracing-subscriber-0.3.18 \
+ tree_magic_mini-3.0.3 \
+ try-lock-0.2.4 \
+ tuikit-0.5.0 \
+ unicode-ident-1.0.12 \
+ unicode-width-0.1.11 \
+ utf8parse-0.2.1 \
+ valuable-0.1.0 \
+ vte-0.11.1 \
+ vte_generate_state_changes-0.1.1 \
+ want-0.3.1 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.88 \
+ wasm-bindgen-backend-0.2.88 \
+ wasm-bindgen-macro-0.2.88 \
+ wasm-bindgen-macro-support-0.2.88 \
+ wasm-bindgen-shared-0.2.88 \
+ wayland-backend-0.3.2 \
+ wayland-client-0.31.1 \
+ wayland-protocols-0.31.0 \
+ wayland-protocols-wlr-0.2.0 \
+ wayland-scanner-0.31.0 \
+ wayland-sys-0.31.1 \
+ weezl-0.1.7 \
+ which-4.4.2 \
winapi-0.3.9 \
- winapi-build-0.1.1 \
winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
+ winapi-util-0.1.6 \
+ winapi-wsapoll-0.1.1 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- xcb-0.9.0 \
- xdg-2.2.0 \
- x11-clipboard@git+https://github.com/xrelkd/x11-clipboard?tag=v0.6.0\#de648ede312e6b236e3b92119a014cac064b9e38
+ windows-core-0.51.1 \
+ windows-sys-0.48.0 \
+ windows-targets-0.48.5 \
+ windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_msvc-0.48.5 \
+ windows_i686_gnu-0.48.5 \
+ windows_i686_msvc-0.48.5 \
+ windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_msvc-0.48.5 \
+ winnow-0.5.19 \
+ wl-clipboard-rs-0.8.0 \
+ x11rb-0.12.0 \
+ x11rb-protocol-0.12.0 \
+ zune-inflate-0.2.54
PLIST_FILES= bin/clipcat-menu \
bin/clipcatctl \
@@ -243,12 +335,16 @@ PLIST_FILES= bin/clipcat-menu \
BINARY_ALIAS= python3=${PYTHON_CMD}
+PROGRAMS= clipcat-menu clipcatctl clipcatd
+
# rebuilds rocksdb - maybe it can link with external rocksdb?
-post-install:
- @${STRIP_CMD} \
- ${STAGEDIR}${PREFIX}/bin/clipcat-menu \
- ${STAGEDIR}${PREFIX}/bin/clipcatctl \
- ${STAGEDIR}${PREFIX}/bin/clipcatd
+do-install:
+.for p in ${PROGRAMS}
+ # workaround for error: found a virtual manifest at `xx` instead of a package manifest
+ ${INSTALL_PROGRAM} \
+ ${WRKDIR}/target/*/release/${p} \
+ ${STAGEDIR}${PREFIX}/bin/${p}
+.endfor
.include <bsd.port.mk>