aboutsummaryrefslogtreecommitdiff
path: root/x11/dzen2/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-23 11:20:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-23 11:20:08 +0000
commitacc2f58dc3ef0019b19b706724d9ddef3fde5a40 (patch)
treeb2039d7b0784cb5c52f161053048953520bb960d /x11/dzen2/Makefile
parent8bf0e8e651d6c07e7955f7c74e3015f7a2c4e762 (diff)
downloadports-acc2f58dc3ef0019b19b706724d9ddef3fde5a40.tar.gz
ports-acc2f58dc3ef0019b19b706724d9ddef3fde5a40.zip
- Add support for XINERAMA and XPM options
PR: 128279 Submitted by: Ashish Shukla <wahjava at gmail dot com> Approved by: Morten Slot Kristensen <msk at nullpointer dot dk> (maintainer)
Notes
Notes: svn path=/head/; revision=221924
Diffstat (limited to 'x11/dzen2/Makefile')
-rw-r--r--x11/dzen2/Makefile26
1 files changed, 25 insertions, 1 deletions
diff --git a/x11/dzen2/Makefile b/x11/dzen2/Makefile
index ebac74836431..eb85450c24ad 100644
--- a/x11/dzen2/Makefile
+++ b/x11/dzen2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dzen2
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://gotmor.googlepages.com/
@@ -17,8 +18,31 @@ USE_XORG= x11
PLIST_FILES= bin/${PORTNAME}
+OPTIONS= XPM "Enable XPM support" On \
+ XINERAMA "Enable Xinerama support" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XPM)
+USE_XORG+= xpm
+.endif
+
+.if !defined(WITHOUT_XINERAMA)
+USE_XORG+= xinerama
+.endif
+
post-patch:
+.if !defined(WITHOUT_XPM)
+ ${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXpm/g' \
+ -e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XPM/g' \
+ ${WRKSRC}/config.mk
+.endif
+.if !defined(WITHOUT_XINERAMA)
+ ${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXinerama/g' \
+ -e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XINERAMA/g' \
+ ${WRKSRC}/config.mk
+.endif
${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKSRC}/config.mk
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>