aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-uptime/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:49:20 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 12:49:20 +0000
commit7790cb7367ff44c3706b3a1ed33006610fb98c2e (patch)
tree11429e2b85ec6d8960d2f5e205550a8c8193f52e /x11/e17-module-uptime/Makefile
parentcefb4c693ba3a287f3e51c08fd8e71f471fbc670 (diff)
downloadports-7790cb7367ff44c3706b3a1ed33006610fb98c2e.tar.gz
ports-7790cb7367ff44c3706b3a1ed33006610fb98c2e.zip
An e17 module indicating the system's current uptime, load averages and number
of active users in a configurable interval. Author: Matthew Mullins WWW: http://www.enlightenment.org PR: ports/99368 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=167348
Diffstat (limited to 'x11/e17-module-uptime/Makefile')
-rw-r--r--x11/e17-module-uptime/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11/e17-module-uptime/Makefile b/x11/e17-module-uptime/Makefile
new file mode 100644
index 000000000000..36d5f8af1395
--- /dev/null
+++ b/x11/e17-module-uptime/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-uptime
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uptime
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 uptime and load average indicator module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>