aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-10-28 23:43:04 +0000
committerWill Andrews <will@FreeBSD.org>2000-10-28 23:43:04 +0000
commitafb8e1a19d15fd4a17227330b97b960e6056df56 (patch)
treee166ccf780e1e858379ffb79c88e861bd892b646 /x11/kdelibs4
parent93d5d50b4c438f7af2712f9359c11b2e8d45b4a3 (diff)
downloadports-afb8e1a19d15fd4a17227330b97b960e6056df56.tar.gz
ports-afb8e1a19d15fd4a17227330b97b960e6056df56.zip
Take a shot at mentioning what kind of OpenSSL support we have, since KDE2
does not support OpenSSL <= 0.9.4. Also add USE_OPENSSL, to keep people who don't have it installed from using the port. Perhaps that should be a knob, in case people have some legitimate reason not to have OpenSSL.
Notes
Notes: svn path=/head/; revision=34377
Diffstat (limited to 'x11/kdelibs4')
-rw-r--r--x11/kdelibs4/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 2b81e2b1d186..aa9c5b109fe6 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
mimelib.3:${PORTSDIR}/converters/kdesupport2
+USE_OPENSSL= yes
USE_QT2= yes
MOC?= ${X11BASE}/bin/moc2
SOMAJOR= 4
@@ -38,6 +39,18 @@ USE_GMAKE= yes
MAKE_ENV= SOMAJOR="${SOMAJOR}" SOMINOR="${SOMINOR}"
PLIST_SUB+= LIBVER="${SOMAJOR}"
+pre-fetch:
+.if ${OSVERSION} <= 410002
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "Your OpenSSL installation could be out of date. This is"
+ @${ECHO} "just a warning, but if your system's world was built on"
+ @${ECHO} "sources earlier than August 20 along RELENG_4 or older,"
+ @${ECHO} "then KDE2 will not build with SSL support."
+ @${ECHO}
+.endif
+
pre-configure:
.for NUM in 1 3
(find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \