aboutsummaryrefslogtreecommitdiff
path: root/x11/kf5-frameworkintegration
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:14:10 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:36:35 +0000
commitc0f139b89306c012b33bdd4d676b107305ba3e06 (patch)
tree02588523ca26bd83647873708e04d2c1bdd56495 /x11/kf5-frameworkintegration
parentba93bcdc15399175b77e3ae109a6ed37807b1364 (diff)
downloadports-c0f139b89306c012b33bdd4d676b107305ba3e06.tar.gz
ports-c0f139b89306c012b33bdd4d676b107305ba3e06.zip
*/kf5-*: (KDE Frameworks) lighten dependencies
- ECM (extra-cmake-modules) is only ever a build-dep and was missing in some places where it was previously pulled in implicitly - Qt testlib is only a build-dep While here - conventionally, the _build and _run items in USE_KDE and USE_QT are sorted to the end, and they start a new line in the Makefile - remove tcberner's created-line (confirmed on IRC) - use DISTVERSION everywhere - reduce inter-framework dependencies using the tooling proposed by tcberner in https://reviews.freebsd.org/D27304 Some PORTREVISION may have jumped by more than 1, since this commit is a squash of a long string of updates where I may have bumped a port once for ecm_build, and a second time for other lightening-up.
Diffstat (limited to 'x11/kf5-frameworkintegration')
-rw-r--r--x11/kf5-frameworkintegration/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11/kf5-frameworkintegration/Makefile b/x11/kf5-frameworkintegration/Makefile
index 7c97f3074701..16319860b4b4 100644
--- a/x11/kf5-frameworkintegration/Makefile
+++ b/x11/kf5-frameworkintegration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= frameworkintegration
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -7,10 +8,11 @@ COMMENT= KF5 workspace and cross-framework integration plugins
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig \
qt:5 tar:xz xorg
-USE_KDE= auth attica codecs config configwidgets coreaddons ecm i18n \
- iconthemes kio newstuff notifications package widgetsaddons
-USE_QT= buildtools_build core dbus gui network qmake_build widgets \
- x11extras xml
+USE_KDE= auth attica codecs config configwidgets coreaddons i18n \
+ iconthemes newstuff notifications widgetsaddons \
+ ecm_build
+USE_QT= core dbus gui network widgets xml \
+ buildtools_build qmake_build
USE_XORG= xcb xcursor
.include <bsd.port.mk>