aboutsummaryrefslogtreecommitdiff
path: root/x11/libICE/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-21 23:35:55 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-21 23:35:55 +0000
commit5496f2518e9e5c2eda27dc457f3aa3aa48e51528 (patch)
treec17cff45f92c313e7b26681afc5cd40c4376a63e /x11/libICE/Makefile
parent377f5c8f063be8c7864ed5f0c461a0e124b8e185 (diff)
downloadports-5496f2518e9e5c2eda27dc457f3aa3aa48e51528.tar.gz
ports-5496f2518e9e5c2eda27dc457f3aa3aa48e51528.zip
New port: Prerelease version of libICE from freedesktop.org:
Inter Client Exchange library for X11 Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Notes
Notes: svn path=/head/; revision=96366
Diffstat (limited to 'x11/libICE/Makefile')
-rw-r--r--x11/libICE/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/libICE/Makefile b/x11/libICE/Makefile
new file mode 100644
index 000000000000..ddfa336da5c7
--- /dev/null
+++ b/x11/libICE/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libICE
+# Date Created: 09 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libICE
+PORTVERSION= 6.3.1.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Inter Client Exchange library for X11
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xtrans.pc:${PORTSDIR}/x11/libXtrans \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.3.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>