aboutsummaryrefslogtreecommitdiff
path: root/x11/libSM/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-01 11:41:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-01 11:41:07 +0000
commitf4936121f95e76555bebbc39e5b73dc12b0ff91f (patch)
treefcac9880f7998d69245463508464761e7b89a20e /x11/libSM/files
parent693ef828a26aa5cb92848177be5fcb2afa9dd055 (diff)
downloadports-f4936121f95e76555bebbc39e5b73dc12b0ff91f.tar.gz
ports-f4936121f95e76555bebbc39e5b73dc12b0ff91f.zip
- Update to Xorg 7.5
The Intel drivers was patched to work with the new server. The drivers for Vesa, NV,NVIDIA and ATI have been tested thoroughfully and seem to work fine. A complete changelog of Xorg 7.5 can you read here: http://www.x.org/releases/X11R7.5/ A note to FreeBSD 6.X users: We strongly recommend you to update your system to 7.x or above. For updating try portupgrade -af \* or: portmaster -af Please report any problems and issus to x11 (at) FreeBSD.org. Thanks to beat@, rnoland@, fluffy@, stas@ and all testers for their help and Feeback. Tested by: Community and 2x exp-runs
Notes
Notes: svn path=/head/; revision=253503
Diffstat (limited to 'x11/libSM/files')
-rw-r--r--x11/libSM/files/patch-configure.ac18
-rw-r--r--x11/libSM/files/patch-src_Makefile.am13
-rw-r--r--x11/libSM/files/patch-src_sm_genid.c43
3 files changed, 0 insertions, 74 deletions
diff --git a/x11/libSM/files/patch-configure.ac b/x11/libSM/files/patch-configure.ac
deleted file mode 100644
index 2fe7d332d26a..000000000000
--- a/x11/libSM/files/patch-configure.ac
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.ac.orig 2008-07-02 21:58:05.000000000 +0400
-+++ configure.ac 2009-02-23 18:50:18.000000000 +0300
-@@ -35,10 +35,13 @@
- # Needed to check for TCP & IPv6 support and set flags appropriately
- XTRANS_CONNECTION_FLAGS
-
-+AC_ARG_WITH(stduuid, AC_HELP_STRING([--with-stduuid], [Build with DCE 1.1 uuid support for client IDs]))
-+AM_CONDITIONAL(WITH_STDUUID, test x"$with_stduuid" != "xno")
-+
- AC_ARG_WITH(libuuid, AC_HELP_STRING([--with-libuuid], [Build with libuuid support for client IDs]))
--AM_CONDITIONAL(WITH_LIBUUID, test x"$with_libuuid" != xno)
-+AM_CONDITIONAL(WITH_LIBUUID, test x"$with_libuuid" = "xyes" -a x"$with_stduuid" = "xno")
-
--if test x"$with_libuuid" != xno; then
-+if test x"$with_libuuid" = "xyes" -a x"$with_stduuid" = "xno"; then
- PKG_CHECK_MODULES(LIBUUID, uuid)
- fi
-
diff --git a/x11/libSM/files/patch-src_Makefile.am b/x11/libSM/files/patch-src_Makefile.am
deleted file mode 100644
index 7a855fab2e0d..000000000000
--- a/x11/libSM/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.am.orig 2008-06-24 21:09:29.000000000 +0400
-+++ src/Makefile.am 2009-02-23 18:48:20.000000000 +0300
-@@ -2,6 +2,10 @@
-
- AM_CFLAGS= -I${top_srcdir}/include $(SM_CFLAGS) $(XTRANS_CFLAGS)
-
-+if WITH_STDUUID
-+AM_CFLAGS += -DHAVE_STDUUID
-+endif
-+
- if WITH_LIBUUID
- AM_CFLAGS += $(LIBUUID_CFLAGS) -DHAVE_LIBUUID
- endif
diff --git a/x11/libSM/files/patch-src_sm_genid.c b/x11/libSM/files/patch-src_sm_genid.c
deleted file mode 100644
index 2d685115acdb..000000000000
--- a/x11/libSM/files/patch-src_sm_genid.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/sm_genid.c.orig 2008-06-24 21:11:27.000000000 +0400
-+++ src/sm_genid.c 2009-02-23 18:51:22.000000000 +0300
-@@ -76,7 +76,9 @@
- #define TCPCONN
- #endif
-
--#if defined(HAVE_LIBUUID)
-+#if defined(HAVE_STDUUID)
-+#include <uuid.h>
-+#elif defined(HAVE_LIBUUID)
- #include <uuid/uuid.h>
- #endif
-
-@@ -85,7 +87,28 @@
- SmsGenerateClientID (smsConn)
- SmsConn smsConn;
- {
--#if defined(HAVE_LIBUUID)
-+#if defined(HAVE_STDUUID)
-+ char *id;
-+ char *str;
-+ uuid_t uuid;
-+ uint32_t status;
-+
-+ uuid_create(&uuid, &status);
-+ if (status != uuid_s_ok)
-+ return NULL;
-+
-+ uuid_to_string(&uuid, &str, &status);
-+ if (status != uuid_s_ok)
-+ return NULL;
-+
-+ if ((id = malloc (strlen (str) + 2)) != NULL) {
-+ id[0] = '2';
-+ strcpy(&id[1], str);
-+ }
-+ free(str);
-+
-+ return id;
-+#elif defined(HAVE_LIBUUID)
- char *id;
- char temp[256];
- uuid_t uuid;