aboutsummaryrefslogtreecommitdiff
path: root/x11/libXcm
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-02-15 10:53:01 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-02-15 10:53:01 +0000
commit3a5930bc05a0db28594aa22781323835ce758b59 (patch)
tree0c95376fbb1a2b37f5b6b28b6ded0f55b2b078be /x11/libXcm
parentb1f31853449e0b163b1f8b06525527b254f023d6 (diff)
downloadports-3a5930bc05a0db28594aa22781323835ce758b59.tar.gz
ports-3a5930bc05a0db28594aa22781323835ce758b59.zip
The libXcm library is colour management helper for Xorg. It contains
a reference implementation of the X Color Management specification. It allows to attach colour regions to X windows to communicate with colour servers.
Notes
Notes: svn path=/head/; revision=312284
Diffstat (limited to 'x11/libXcm')
-rw-r--r--x11/libXcm/Makefile24
-rw-r--r--x11/libXcm/distinfo2
-rw-r--r--x11/libXcm/pkg-descr4
-rw-r--r--x11/libXcm/pkg-plist13
4 files changed, 43 insertions, 0 deletions
diff --git a/x11/libXcm/Makefile b/x11/libXcm/Makefile
new file mode 100644
index 000000000000..782855fb48e9
--- /dev/null
+++ b/x11/libXcm/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= libXcm
+PORTVERSION= 0.5.2
+CATEGORIES= x11
+MASTER_SITES= SF/oyranos/${PORTNAME}/${PORTNAME}-${PORTVERSION:C|(.*)\.[0-9]*$|\1|}
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= X Colour Management Library
+
+LICENSE= MIT
+
+XORG_CAT= lib
+USE_PKGCONFIG= build
+USE_XORG= xfixes xmu
+
+MAN3= Xcm.3 XcmDDC.3 XcmEdidParse.3 XcmEvents.3 XcolorProfile.3 \
+ XcolorRegion.3 libXcm.3
+
+post-patch:
+ @${SED} -I.bak -e 's:{libdir}/pkgconfig:{prefix}/libdata/pkgconfig:g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11/libXcm/distinfo b/x11/libXcm/distinfo
new file mode 100644
index 000000000000..7fdb24c20b62
--- /dev/null
+++ b/x11/libXcm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xorg/lib/libXcm-0.5.2.tar.bz2) = 1ed2750e55dd3c8c9e1597de577bdc3a72d37e976979926d973ea9e3583afcd5
+SIZE (xorg/lib/libXcm-0.5.2.tar.bz2) = 301813
diff --git a/x11/libXcm/pkg-descr b/x11/libXcm/pkg-descr
new file mode 100644
index 000000000000..4a5026e83aac
--- /dev/null
+++ b/x11/libXcm/pkg-descr
@@ -0,0 +1,4 @@
+The libXcm library is colour management helper for Xorg. It contains
+a reference implementation of the X Color Management specification.
+It allows to attach colour regions to X windows to communicate with
+colour servers.
diff --git a/x11/libXcm/pkg-plist b/x11/libXcm/pkg-plist
new file mode 100644
index 000000000000..6ede719ea7b9
--- /dev/null
+++ b/x11/libXcm/pkg-plist
@@ -0,0 +1,13 @@
+include/X11/Xcm/Xcm.h
+include/X11/Xcm/XcmDDC.h
+include/X11/Xcm/XcmEdidParse.h
+include/X11/Xcm/XcmEvents.h
+include/X11/Xcm/XcmVersion.h
+lib/libXcm.la
+lib/libXcm.so
+lib/libXcm.so.0
+libdata/pkgconfig/xcm.pc
+share/cmake/Modules/FindXcm.cmake
+@dirrmtry share/cmake/Modules
+@dirrmtry share/cmake
+@dirrm include/X11/Xcm