aboutsummaryrefslogtreecommitdiff
path: root/x11/libXxf86dga
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /x11/libXxf86dga
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
downloadports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.tar.gz
ports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Notes
Notes: svn path=/head/; revision=319055
Diffstat (limited to 'x11/libXxf86dga')
-rw-r--r--x11/libXxf86dga/Makefile8
-rw-r--r--x11/libXxf86dga/distinfo4
-rw-r--r--x11/libXxf86dga/files/patch-src_XF86DGA2.c20
3 files changed, 24 insertions, 8 deletions
diff --git a/x11/libXxf86dga/Makefile b/x11/libXxf86dga/Makefile
index 6404f9752524..73e7dcf77411 100644
--- a/x11/libXxf86dga/Makefile
+++ b/x11/libXxf86dga/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: libXxf86dga
-# Date Created: 8 Feb 2006
-# Whom: Eric Anholt <anholt@FreeBSD.org>
-#
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libXxf86dga
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/libXxf86dga/distinfo b/x11/libXxf86dga/distinfo
index 643f927aeb1e..d0b4606f504c 100644
--- a/x11/libXxf86dga/distinfo
+++ b/x11/libXxf86dga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/lib/libXxf86dga-1.1.2.tar.bz2) = 1ba652f562ce3fb3fef092ce5485eb7ef15b521124c901977b56d6f324605a06
-SIZE (xorg/lib/libXxf86dga-1.1.2.tar.bz2) = 270013
+SHA256 (xorg/lib/libXxf86dga-1.1.3.tar.bz2) = 551fa374dbef0f977de1f35d005fa9ffe92b7a87e82dbe62d6a4640f5b0b4994
+SIZE (xorg/lib/libXxf86dga-1.1.3.tar.bz2) = 290347
diff --git a/x11/libXxf86dga/files/patch-src_XF86DGA2.c b/x11/libXxf86dga/files/patch-src_XF86DGA2.c
new file mode 100644
index 000000000000..69ede4ecd9da
--- /dev/null
+++ b/x11/libXxf86dga/files/patch-src_XF86DGA2.c
@@ -0,0 +1,20 @@
+--- src/XF86DGA2.c.orig 2013-03-25 20:23:42.796859881 +0100
++++ src/XF86DGA2.c 2013-03-25 20:23:17.997856725 +0100
+@@ -21,6 +21,8 @@
+ #include <X11/extensions/extutil.h>
+ #include <stdio.h>
+
++#include <stdint.h>
++
+
+ /* If you change this, change the Bases[] array below as well */
+ #define MAX_HEADS 16
+@@ -928,7 +930,7 @@
+ if ((pMap->fd = open(name, O_RDWR)) < 0)
+ return False;
+ pMap->virtual = mmap(NULL, size, PROT_READ | PROT_WRITE,
+- MAP_FILE | MAP_SHARED, pMap->fd, (off_t)base);
++ MAP_FILE | MAP_SHARED, pMap->fd, (off_t)(uintptr_t)base);
+ if (pMap->virtual == (void *)-1)
+ return False;
+ mprotect(pMap->virtual, size, PROT_READ | PROT_WRITE);