aboutsummaryrefslogtreecommitdiff
path: root/x11/libfm/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-12-11 17:53:52 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-12-11 17:53:52 +0000
commitbea6d782fcf22774203a15a593ee83174492d868 (patch)
tree371dc19d3fc880890430f7d3811e508568f1ac3c /x11/libfm/Makefile
parent19aff4855cb9eb3e61fccfcdc0704a831df99579 (diff)
downloadports-bea6d782fcf22774203a15a593ee83174492d868.tar.gz
ports-bea6d782fcf22774203a15a593ee83174492d868.zip
- Update to 1.2.5
- Adjust dependencies (reported by QA script) - Switch to USES= localbase - Remove DOCS option - Take maintainership
Notes
Notes: svn path=/head/; revision=428372
Diffstat (limited to 'x11/libfm/Makefile')
-rw-r--r--x11/libfm/Makefile42
1 files changed, 19 insertions, 23 deletions
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 3d872abedc29..6edb5c64c94d 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= libfm
-PORTVERSION= 1.2.4
+PORTVERSION= 1.2.5
CATEGORIES= x11
MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/LibFM/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= olivierd@FreeBSD.org
COMMENT?= Core library of PCManFM file manager
LICENSE= LGPL21
@@ -15,42 +15,42 @@ LICENSE= LGPL21
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
valac:lang/vala
LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
- libexif.so:graphics/libexif
+ libexif.so:graphics/libexif \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libfm-extra.so:x11/libfm-extra
.endif
SLAVEDIRS= ${CATEGORIES}/${PORTNAME}-extra
-USES= gettext-tools gmake libtool pathfix pkgconfig tar:xz
+USES= gettext-tools gmake libtool localbase pathfix pkgconfig tar:xz
USE_GNOME= glib20 intltool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --disable-static
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
.if ! defined(EXTRA_ONLY)
USES+= desktop-file-utils shared-mime-info
-USE_GNOME+= gtk20
+USE_GNOME+= gtk20 cairo gdkpixbuf2
CONFIGURE_ARGS+=--with-gtk=2
.else
USE_GNOME+= intltool intlhack
CONFIGURE_ARGS+=--with-extra-only
.endif
-MICRO_VERSION= 0.4
-ABI_VERSION= 4
-PLIST_SUB+= MICRO_VERSION=${MICRO_VERSION} \
- ABI_VERSION=${ABI_VERSION}
-
-PORTDOCS= AUTHORS NEWS README
-
-OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
+post-extract:
+.if !defined(EXTRA_ONLY)
+ ${MV} ${WRKSRC}/data/libfm.conf \
+ ${WRKSRC}/data/libfm.conf.sample
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|^[[:blank:]]\{5,\}USE_NLS=yes|#&|' \
${WRKSRC}/configure
@@ -59,7 +59,7 @@ post-patch:
/@LN_S@ @PACKAGE@-@FMLIBVER@/d' \
${WRKSRC}/src/Makefile.in
-.if ! defined(EXTRA_ONLY)
+.if !defined(EXTRA_ONLY)
${REINPLACE_CMD} -e 's|DATA = libfm-extra.pc|DATA =|' \
${WRKSRC}/Makefile.in
@@ -74,16 +74,12 @@ post-patch:
/^vfs_menu_la_LIBADD/s|$$(top.*|-lfm-extra|' \
${WRKSRC}/src/modules/Makefile.in
-post-install:
- ${MV} ${STAGEDIR}${PREFIX}/etc/xdg/${PORTNAME}/${PORTNAME}.conf \
- ${STAGEDIR}${PREFIX}/etc/xdg/${PORTNAME}/${PORTNAME}.conf.sample
+ ${REINPLACE_CMD} -e 's|libfm.conf|libfm.conf.sample|' \
+ ${WRKSRC}/data/Makefile.in
+post-install:
${INSTALL_DATA} ${WRKSRC}/src/actions/fm-actions.h \
${STAGEDIR}${PREFIX}/include/${PORTNAME}
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>