aboutsummaryrefslogtreecommitdiff
path: root/x11/lxrandr/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-09-21 22:24:49 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-09-21 22:24:49 +0000
commit3ea59fb409a784740372798eeb6eab6e9d030dfd (patch)
tree7bcf8cc3832f6572f6f292edd762d5ce7cf9e22c /x11/lxrandr/Makefile
parent3d89e681b652d3d9709a07f46580e48c4b07da3b (diff)
downloadports-3ea59fb409a784740372798eeb6eab6e9d030dfd.tar.gz
ports-3ea59fb409a784740372798eeb6eab6e9d030dfd.zip
Add new port x11/lxrandr:
LXDE screen manager. PR: ports/171652 Submitted by: Eric Turgeon <ericturgeon.bsd at gmail.com>
Notes
Notes: svn path=/head/; revision=304643
Diffstat (limited to 'x11/lxrandr/Makefile')
-rw-r--r--x11/lxrandr/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/lxrandr/Makefile b/x11/lxrandr/Makefile
new file mode 100644
index 000000000000..39c8cab42c26
--- /dev/null
+++ b/x11/lxrandr/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= lxrandr
+PORTVERSION= 0.1.2
+CATEGORIES= x11
+MASTER_SITES= SF/lxde/LXRandR%20%28monitor%20config%20tool%29/LXRandR%20${PORTVERSION}
+
+MAINTAINER= ericturgeon@ghostbsd.org
+COMMENT= LXDE screen manager
+
+USE_GNOME= gtk20
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+USE_XORG= xrandr
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+MAN1= lxrandr.1
+
+post-install:
+ @-${LOCALBASE}/bin/update-desktop-database > /dev/null
+
+.include <bsd.port.mk>