aboutsummaryrefslogtreecommitdiff
path: root/x11/pcdm/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-05 18:00:13 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-05 18:00:13 +0000
commit8311dd965638c3afb0b7619311b1e591667ddb36 (patch)
tree3d08b5ee09b99f551acde4929b9853172117a986 /x11/pcdm/Makefile
parent363377a9ed685d3caba1c7d92431649826d00d1b (diff)
downloadports-8311dd965638c3afb0b7619311b1e591667ddb36.tar.gz
ports-8311dd965638c3afb0b7619311b1e591667ddb36.zip
x11/pcdm: fix build with GCC-based architectures
This port needs USES=compiler:c++11-lang to build on GCC architectures. Additionally (by fernape): * Reorder USE in the Makefile * Add widgets as a USE_QT member * Add USE_GL and USE_XORG (suggested by the framework) * Fix wrong %%ETCDIR%% substitution in pkg-plist PR: 237117 Approved by: linimon (mentor)
Notes
Notes: svn path=/head/; revision=500868
Diffstat (limited to 'x11/pcdm/Makefile')
-rw-r--r--x11/pcdm/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11/pcdm/Makefile b/x11/pcdm/Makefile
index 5b0219e30adb..f5afa4ea3f06 100644
--- a/x11/pcdm/Makefile
+++ b/x11/pcdm/Makefile
@@ -15,16 +15,18 @@ RUN_DEPENDS= xorg-minimal>=0:x11/xorg-minimal \
setxkbmap:x11/setxkbmap \
${LOCALBASE}/bin/qsudo:sysutils/qsudo
+USES= compiler:c++11-lang gl qmake qt:5
+USE_QT= core gui network svg multimedia imageformats \
+ buildtools_build x11extras widgets concurrent linguisttools_build
+USE_GL= gl
+USE_XORG= x11
+USE_OPENRC_SUBR=pcdm
+
WRKSRC_SUBDIR= src-qt5
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
CONFLICTS= pcbsd-utils-qt*
-USES= qmake qt:5
-USE_QT= core gui network svg multimedia imageformats \
- buildtools_build x11extras concurrent linguisttools_build
-USE_OPENRC_SUBR=pcdm
-
USE_GITHUB= yes
GH_ACCOUNT= trueos
GH_PROJECT= pcdm