aboutsummaryrefslogtreecommitdiff
path: root/x11/py-qt5-opengl
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-10-05 15:50:03 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-10-05 15:50:03 +0000
commit2933bb22c330742a9a771b8a84abb127fc3e8cbc (patch)
tree4f76a634aa6b24065331c83abce53f1dfe75ebf9 /x11/py-qt5-opengl
parent4d98efd1ac4f23c42ac3616f40382cc7b48b2581 (diff)
downloadports-2933bb22c330742a9a771b8a84abb127fc3e8cbc.tar.gz
ports-2933bb22c330742a9a771b8a84abb127fc3e8cbc.zip
Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5
- Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5 - Use pypi for PYQT [1] - Add devel/py-qt5-sip (Don't use it for now. It will be used in future updates of PyQt with py-sip >= 5) - Add missing py-qt5 ports: comms/py-qt5-sensors, devel/py-qt5-location, devel/py-qt5-remoteobjects, net/py-qt5-networkauth - Strip libs - Refactor *_PATH and *_PORT parts [1] RiverBankComputing doesn't offer links to download latest version of some ports PR: 247369 Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D25749 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=551499
Diffstat (limited to 'x11/py-qt5-opengl')
-rw-r--r--x11/py-qt5-opengl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11/py-qt5-opengl/Makefile b/x11/py-qt5-opengl/Makefile
index 567444ece5b1..a83cb2fe2562 100644
--- a/x11/py-qt5-opengl/Makefile
+++ b/x11/py-qt5-opengl/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= opengl
-PORTREVISION= 1
CATEGORIES= x11 devel python
MAINTAINER= kde@FreeBSD.org
@@ -29,4 +28,7 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+port-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtOpenGl.so
+
.include <bsd.port.mk>