aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-inputmethods
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
commit74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8 (patch)
tree5a2cd52714027788ca840d18e6087ab373c335b4 /x11/qt4-inputmethods
parent9650cc958392c895ef613d1abea30ed3510adffd (diff)
downloadports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.tar.gz
ports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.zip
Add qt4, a multiplatform C++ application framework
Notes
Notes: svn path=/head/; revision=184304
Diffstat (limited to 'x11/qt4-inputmethods')
-rw-r--r--x11/qt4-inputmethods/Makefile66
-rw-r--r--x11/qt4-inputmethods/distinfo3
-rw-r--r--x11/qt4-inputmethods/pkg-descr12
-rw-r--r--x11/qt4-inputmethods/pkg-plist3
4 files changed, 84 insertions, 0 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
new file mode 100644
index 000000000000..6aebf51e26cf
--- /dev/null
+++ b/x11/qt4-inputmethods/Makefile
@@ -0,0 +1,66 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= inputmethods
+PORTVERSION= 4.2.2
+CATEGORIES?= x11
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt input method plugins
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
+ QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/network' --exclude '${DISTNAME}/src/xml' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/uic' \
+ --exclude '${DISTNAME}/src/tools/rcc' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../..
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/inputmethods|g' \
+ ${WRKSRC}/imsw-multi/imsw-multi.pro
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+
+.include <bsd.port.post.mk>
diff --git a/x11/qt4-inputmethods/distinfo b/x11/qt4-inputmethods/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/x11/qt4-inputmethods/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/x11/qt4-inputmethods/pkg-descr b/x11/qt4-inputmethods/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/x11/qt4-inputmethods/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/x11/qt4-inputmethods/pkg-plist b/x11/qt4-inputmethods/pkg-plist
new file mode 100644
index 000000000000..a74e769e120c
--- /dev/null
+++ b/x11/qt4-inputmethods/pkg-plist
@@ -0,0 +1,3 @@
+lib/plugins/inputmethods/libqimsw-multi.so
+lib/plugins/inputmethods/libqimsw-multi.so.debug
+@dirrm lib/plugins/inputmethods