aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-opengl
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 17:21:56 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 17:21:56 +0000
commitc2dd4d2e2d1073e25997d892bd76aac5e841d55b (patch)
tree66fbbfbf5bab18e735ad851a8c6925ac9e54cd31 /x11/qt4-opengl
parentdc0df90ca8b14adc6647caf42bd1d0b88fc9ca01 (diff)
downloadports-c2dd4d2e2d1073e25997d892bd76aac5e841d55b.tar.gz
ports-c2dd4d2e2d1073e25997d892bd76aac5e841d55b.zip
KDE/FreeBSD team presents Qt 4.8.4 and QtCreator 2.6.1 ports.
The area51 repository features commits by Alonso Schaich, avilla, fluffy, jhale, makc and rakuco. Common changes: - Trim Makefile header - Convert to new option framework - Add/improve desktop entries - Remove upstreamed patches Mk/bsd.qt.mk: - Set QMAKESPEC at late stage (to fix potential problem if USE_GCC is used) [1] devel/qmake: - Fix crash due to off-by one error [2] multimedia/qt4-phonon*: - Deprecate in favour of multimedia/phonon* www/qt4-webkit: - Make dependence on GStreamer optional [3] devel/qtcreator: - Enable qml-designer in devel/qtcreator (requires privite Qt headers) [4] Reported by: avg via irc [1] Submitted by: avg via maillist [2] PR: ports/175644 [3] Submitted by: danfe [3] PR: ports/169809 [4] Reported by: tcb <tcberner at gmail.com> [4]
Notes
Notes: svn path=/head/; revision=311473
Diffstat (limited to 'x11/qt4-opengl')
-rw-r--r--x11/qt4-opengl/Makefile7
-rw-r--r--x11/qt4-opengl/files/patch-src__corelib__tools__qiterator.h38
2 files changed, 1 insertions, 44 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 86b11ffa3c13..82deff6f0195 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -1,10 +1,5 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: qt40
-# Date created: Wed Jun 29 11:49:42 CEST 2005
-# Whom: lofi@freebsd.org
-#
+# Created by: lofi@freebsd.org
# $FreeBSD$
-#
PORTNAME= opengl
DISTVERSION= ${QT4_VERSION}
diff --git a/x11/qt4-opengl/files/patch-src__corelib__tools__qiterator.h b/x11/qt4-opengl/files/patch-src__corelib__tools__qiterator.h
deleted file mode 100644
index 9a2a2ca2daa7..000000000000
--- a/x11/qt4-opengl/files/patch-src__corelib__tools__qiterator.h
+++ /dev/null
@@ -1,38 +0,0 @@
-commit 5210d47aa66214e3cb16f394d0510a91f770c1b1
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Jul 16 23:39:07 2012 -0300
-
- Only forward-declare some std classes if QT_NO_STL is defined.
-
- If that is not done, building with clang, libc++ and C++11 support
- does not work: libc++ defines the iterator tag classes in an inline
- namespace inside the std namespace, and forward-declaring those
- classes inside the std namespace itself in qiterator.h causes an
- ambiguity that clang solves by choosing the incomplete-declared class
- declared in the enclosing std namespace.
-
- This is probably the "clang build problem" reported in commit
- 19e2b4d6eb733d9fd4eb69c0622b699fd08a3203 to qtbase, which cannot be
- directly cherry-picked without breaking other classes due to QT_NO_STL
- still being present in Qt 4.
-
- Change-Id: I26e33915347d3f94ef2e10b68fca6b2099ec9491
- Reviewed-by: Bradley T. Hughes <bradley.hughes@nokia.com>
-
-diff --git a/src/corelib/tools/qiterator.h b/src/corelib/tools/qiterator.h
-index 0747940..b9d8da6 100644
---- ./src/corelib/tools/qiterator.h
-+++ ./src/corelib/tools/qiterator.h
-@@ -46,10 +46,12 @@
-
- QT_BEGIN_HEADER
-
-+#ifdef QT_NO_STL
- namespace std {
- struct bidirectional_iterator_tag;
- struct random_access_iterator_tag;
- }
-+#endif
-
- QT_BEGIN_NAMESPACE
-