aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2012-06-08 15:43:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2012-06-08 15:43:57 +0000
commitf8d7624f0d72bda021b30e852ed764b82f53188e (patch)
tree63fd87914a38b65ded60347304c75ae2183132f1 /x11/rxvt
parent21367934447c86d8d9fa7ea1740172be629fa7c4 (diff)
downloadports-f8d7624f0d72bda021b30e852ed764b82f53188e.tar.gz
ports-f8d7624f0d72bda021b30e852ed764b82f53188e.zip
Convert to optionsng
Notes
Notes: svn path=/head/; revision=298766
Diffstat (limited to 'x11/rxvt')
-rw-r--r--x11/rxvt/Makefile54
1 files changed, 24 insertions, 30 deletions
diff --git a/x11/rxvt/Makefile b/x11/rxvt/Makefile
index 36997e2af45e..adc1ca97d08c 100644
--- a/x11/rxvt/Makefile
+++ b/x11/rxvt/Makefile
@@ -19,17 +19,19 @@ COMMENT= A low memory usage xterm replacement that supports color
USE_XORG= xpm
GNU_CONFIGURE= yes
-OPTIONS= BIG5 "Build with BIG5 support" off \
- GB "Build with GB support" off \
- GREEK "Build with greek keyboard support" off \
- HALF_SHADOW "Build with half shadows support" off \
- KANJI "Build with Kanji support" off \
- MENUBAR "Build with menubar support" off \
- NEXT "Build with NeXT scrollbar" off \
- TRANSPARENCY "Build with transparency support" off \
- XGETDEFAULT "Build with XGetDefault() support" off \
- XIM "Build with XIM support" off \
- XTERM "Build with Xterm scrollbar" off
+OPTIONS_DEFINE = BIG5 GB GREEK HALF_SHADOW KANJI MENUBAR NEXT \
+ TRANSPARENCY XGETDEFAULT XIM XTERM
+BIG5_DESC= Build with BIG5 support
+GB_DESC= Build with GB support
+GREEK_DESC= Build with greek keyboard support
+HALF_SHADOW_DESC= Build with half shadows support
+KANJI_DESC= Build with Kanji support
+MENUBAR_DESC= Build with menubar support
+NEXT_DESC= Build with NeXT scrollbar
+TRANSPARENCY_DESC= Build with transparency support
+XGETDEFAULT_DESC= Build with XGetDefault() support
+XIM_DESC= Build with XIM support
+XTERM_DESC= Build with Xterm scrollbar
CONFIGURE_ARGS= --enable-utmp --enable-wtmp --enable-ttygid \
--with-xpm --enable-xpm-background \
@@ -44,58 +46,50 @@ PLIST_FILES= bin/rxvt
BROKEN= fails to build with new utmpx
.endif
-# enable big5 support
-.if defined(WITH_BIG5)
+.if ${PORT_OPTIONS:MBIG5}
CONFIGURE_ARGS+= --enable-big5
.endif
-# enable gb support
-.if defined(WITH_GB)
+.if ${PORT_OPTIONS:MGB}
CONFIGURE_ARGS+= --enable-gb
.endif
-# enable greek keyboard support
-.if defined(WITH_GREEK)
+.if ${PORT_OPTIONS:MGREEK}
CONFIGURE_ARGS+= --enable-greek
.endif
# enable half width/height shadows scrollbar
-.if defined(WITH_HALF_SHADOW)
+.if ${PORT_OPTIONS:MHALF_SHADOW}
CONFIGURE_ARGS+= --enable-half-shadow
.endif
-# enable kanji support
-.if defined(WITH_KANJI)
+.if ${PORT_OPTIONS:MKANJI}
CONFIGURE_ARGS+= --enable-kanji
.endif
-# enable menubar
-.if defined(WITH_MENUBAR)
+.if ${PORT_OPTIONS:MMENUBAR}
CONFIGURE_ARGS+= --enable-menubar
.endif
-# enable NeXT style scrollbar
-.if defined(WITH_NEXT)
+.if ${PORT_OPTIONS:MNEXT}
CONFIGURE_ARGS+= --enable-next-scroll
.endif
-# enable transparency support
-.if defined(WITH_TRANSPARENCY)
+.if ${PORT_OPTIONS:MTRANSPARENCY}
CONFIGURE_ARGS+= --enable-transparency
.endif
# make resources checking via XGetDefault()
-.if defined(WITH_XGETDEFAULT)
+.if ${PORT_OPTIONS:MXGETDEFAULT}
CONFIGURE_ARGS+= --enable-xgetdefault
.endif
# XIM (X Input Method) protocol support
-.if defined(WITH_XIM)
+.if ${PORT_OPTIONS:MXIM}
CONFIGURE_ARGS+= --enable-xim
.endif
-# enable Xterm style scrollbar
-.if defined(WITH_XTERM)
+.if ${PORT_OPTIONS:MXTERM}
CONFIGURE_ARGS+= --enable-xterm-scroll
.endif