aboutsummaryrefslogtreecommitdiff
path: root/x11/swaybg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-05-03 17:42:38 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-05-03 17:42:38 +0000
commit5517cf54eb46749abc8b78f219ab9040e40bd122 (patch)
tree09e36090bdbb6680a3ab9cad61c729d91d2734a9 /x11/swaybg
parentf27d0a2c2ee40f425bbe007381e5ac7abe0f7d36 (diff)
downloadports-5517cf54eb46749abc8b78f219ab9040e40bd122.tar.gz
ports-5517cf54eb46749abc8b78f219ab9040e40bd122.zip
x11-wm/sway: update to 1.1.r1
Notes
Notes: svn path=/head/; revision=500747
Diffstat (limited to 'x11/swaybg')
-rw-r--r--x11/swaybg/Makefile38
-rw-r--r--x11/swaybg/distinfo3
-rw-r--r--x11/swaybg/pkg-descr8
3 files changed, 49 insertions, 0 deletions
diff --git a/x11/swaybg/Makefile b/x11/swaybg/Makefile
new file mode 100644
index 000000000000..4443e1ee0bc0
--- /dev/null
+++ b/x11/swaybg/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= swaybg
+DISTVERSION= 1.0
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wallpaper tool for Wayland compositors
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= swaywm
+USE_GNOME= cairo
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES PIXBUF
+OPTIONS_DEFAULT=MANPAGES PIXBUF
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+PIXBUF_USE= GNOME=gdkpixbuf2
+PIXBUF_MESON_ENABLED= gdk-pixbuf
+
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
+ -e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
+ ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11/swaybg/distinfo b/x11/swaybg/distinfo
new file mode 100644
index 000000000000..17a2582d169c
--- /dev/null
+++ b/x11/swaybg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556299636
+SHA256 (swaywm-swaybg-1.0_GH0.tar.gz) = a23f1cde07138b865630172eff83db916d2f0989b75fb318def85dcfc3120fbd
+SIZE (swaywm-swaybg-1.0_GH0.tar.gz) = 15851
diff --git a/x11/swaybg/pkg-descr b/x11/swaybg/pkg-descr
new file mode 100644
index 000000000000..59bebe7e4f33
--- /dev/null
+++ b/x11/swaybg/pkg-descr
@@ -0,0 +1,8 @@
+swaybg is a wallpaper utility for Wayland compositors. It is compatible with any
+Wayland compositor which implements the following Wayland protocols:
+
+- wlr-layer-shell
+- xdg-output
+- xdg-shell
+
+WWW: https://github.com/swaywm/swaybg