aboutsummaryrefslogtreecommitdiff
path: root/x11/swayidle
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-15 00:52:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-15 00:52:45 +0000
commiteb2e63135cdda78018bb4c7ce73c8d32e7f70861 (patch)
tree27175f62285d8c69e945559160c61184f69cdf3e /x11/swayidle
parent79cd352a718d48447eb09d4f08ba6d9ac91de55e (diff)
downloadports-eb2e63135cdda78018bb4c7ce73c8d32e7f70861.tar.gz
ports-eb2e63135cdda78018bb4c7ce73c8d32e7f70861.zip
x11-wm/sway: update to 1.0.b.2.189
The last beta is several months old, so use a snapshot to help users evaluate the current state. Changes: https://github.com/swaywm/sway/compare/1.0-beta.2...2573606b Changes: https://github.com/swaywm/wlroots/compare/0.2...10a2c4ed
Notes
Notes: svn path=/head/; revision=490329
Diffstat (limited to 'x11/swayidle')
-rw-r--r--x11/swayidle/Makefile33
-rw-r--r--x11/swayidle/distinfo3
-rw-r--r--x11/swayidle/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/x11/swayidle/Makefile b/x11/swayidle/Makefile
new file mode 100644
index 000000000000..6450db16d60c
--- /dev/null
+++ b/x11/swayidle/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= swayidle
+DISTVERSION= 1.1
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Sway's idle management daemon #'
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= swaywm
+PLIST_FILES= bin/${PORTNAME} \
+ share/bash-completion/completions/${PORTNAME} \
+ share/fish/completions/${PORTNAME}.fish \
+ share/zsh/site-functions/_${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} -i '' "s/'scdoc/&-disabled/" ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11/swayidle/distinfo b/x11/swayidle/distinfo
new file mode 100644
index 000000000000..50dcebe2fc3c
--- /dev/null
+++ b/x11/swayidle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547463557
+SHA256 (swaywm-swayidle-1.1_GH0.tar.gz) = f7b108404892029c736a0b37b43e9c94feede355aea3e4932dd5e36d56fab246
+SIZE (swaywm-swayidle-1.1_GH0.tar.gz) = 8866
diff --git a/x11/swayidle/pkg-descr b/x11/swayidle/pkg-descr
new file mode 100644
index 000000000000..66abb071b6df
--- /dev/null
+++ b/x11/swayidle/pkg-descr
@@ -0,0 +1,4 @@
+swayidle is an idle management daemon, compatible with any Wayland
+compositor which implements the KDE idle protocol.
+
+WWW: https://github.com/swaywm/swayidle