aboutsummaryrefslogtreecommitdiff
path: root/x11/terminator
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 16:22:17 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 16:22:17 +0000
commit1e34739b64d384b87ee2c57027df596b464c79ab (patch)
tree528f950c491cb30f26166e5e23d4b77ad233a5ee /x11/terminator
parent875909eef32afaae5809e1ed26797d44a2f7e2b1 (diff)
downloadports-1e34739b64d384b87ee2c57027df596b464c79ab.tar.gz
ports-1e34739b64d384b87ee2c57027df596b464c79ab.zip
Use setuptools for all Python ports.
Setuptools is the preferred method to manage Python distributions after many changes to the packaging ecosystem over the past couple of years. Only ports using USE_PYDISTUTILS= yes are affected by this commit, ports using USE_PYDISTUTILS= easy_install remains the same however this usage is now deprecated and should be converted to USE_PYDISTUTILS= yes. Some Python distributions do not work with setuptools out of the box because they extend the install command from distutils and not setuptools, and so they need to be patched accordingly. pip (which leverages setuptools) works around the issue by using eggs, however we want to get rid of those as well, as support for "flat" installation is unavailable or has other issues associated with it. This work allows us to unify how python packages are built, ensure that Python distributions are installed consistently, reduces complexity for Python port maintainers and paves the way for simplifying the Python ports framework in the future. With hat on: python Reviewed by: koobs, antoine Exp-run: bdrewery Approved by: bdrewery (portmgr)
Notes
Notes: svn path=/head/; revision=336553
Diffstat (limited to 'x11/terminator')
-rw-r--r--x11/terminator/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index 09b559df7abf..939832d901b1 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -21,7 +21,7 @@ OPTIONS_DEFINE= NLS GCONF
GCONF_DESC= Use GNOME Terminal settings
OPTIONS_DEFAULT= NLS GCONF
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Terminator
@@ -42,7 +42,7 @@ PYSETUP+= --without-gettext
.include <bsd.port.pre.mk>
-PYSETUP+= --without-icon-cache
+PYDISTUTILS_SETUP+= --without-icon-cache
.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= pygnome2