aboutsummaryrefslogtreecommitdiff
path: root/x11/wdm/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 22:06:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 22:06:18 +0000
commit2b6b72274cce097ffdf2519492a82eb3fcb1cc81 (patch)
tree2b821bec0c92e4539c4ef76b9521736e4253699f /x11/wdm/Makefile
parent51fb2f16a60807e52e5058ec670a976287d3db5d (diff)
downloadports-2b6b72274cce097ffdf2519492a82eb3fcb1cc81.tar.gz
ports-2b6b72274cce097ffdf2519492a82eb3fcb1cc81.zip
Support stage
Use options framework
Notes
Notes: svn path=/head/; revision=349073
Diffstat (limited to 'x11/wdm/Makefile')
-rw-r--r--x11/wdm/Makefile60
1 files changed, 13 insertions, 47 deletions
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index e76cc785d092..efce86645c25 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -18,12 +18,16 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= xride@FreeBSD.org
COMMENT= WINGs Display Manager; an xdm replacement
-LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker
+LIB_DEPENDS= libWINGs.so:${PORTSDIR}/x11-wm/windowmaker
NOT_FOR_ARCHS= sparc64
+OPTIONS_DEFINE= PAM
+OPTIONS_DEFAULT= PAM
+OPTIONS_SUB= yes
+
+USES= tar:bzip2
USE_XORG= x11 xmu
-USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= DEF_SERVER="${DEF_SERVER}" XRDB_PATH="${XRDB_PATH}"
CONFIGURE_ARGS= --with-logdir=/var/log \
@@ -38,8 +42,6 @@ CONFIGURE_ARGS= --with-logdir=/var/log \
--with-defsystempath=/bin:/usr/bin:/sbin:/usr/sbin:${LOCALBASE}/bin \
--with-wmlist=wmaker:afterstep:blackbox:ctwm:enlightenment:fvwm:fvwm2:fvwm95:olvwm:qvwm:tvtwm
-MAN1= wdm.1 wdmLogin.1
-
CPPFLAGS+= -I${LOCALBASE}/include -DCSRG_BASED -DHAS_SETUSERCONTEXT
LDFLAGS+= -L${LOCALBASE}/lib -lintl
@@ -48,28 +50,8 @@ XRDB_PATH?= ${LOCALBASE}/bin/xrdb
WDMDIR= ${PREFIX}/lib/X11/wdm
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_PAM)
-WITH_PAM= yes
-CONFIGURE_ARGS+= --with-pamdir=${LOCALBASE}/etc/pam.d/
-PLIST_SUB+= PAM=""
-.else
-PLIST_SUB+= PAM="@comment "
-.endif
-
-.if !defined(WITH_PAM)
-CONFIGURE_ARGS+= --disable-pam
-.endif
-
-pre-everything::
-.if !defined(WITH_PAM)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with PAM support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_PAM=yes\""
- @${ECHO_MSG}
-.endif
+PAM_CONFIGURE_OFF= --disable-pam
+PAM_CONFIGURE_ON= --with-pamdir=${LOCALBASE}/etc/pam.d/
post-patch:
@${REINPLACE_CMD} -e \
@@ -89,28 +71,12 @@ post-patch:
@${REINPLACE_CMD} -e \
's|/etc/X11/wdm|${WDMDIR}|g' ${WRKSRC}/doc/wdmLogin.man
-pre-install:
-.if exists(${WDMDIR}/wdm-config)
- ${MV} ${WDMDIR}/wdm-config ${WDMDIR}/wdm-config.preserve
-.endif
-.if exists(${WDMDIR}/Xsetup_0)
- ${MV} ${WDMDIR}/Xsetup_0 ${WDMDIR}/Xsetup_0.preserve
-.endif
-
post-install:
- @${CP} ${WDMDIR}/wdm-config ${WDMDIR}/wdm-config.dist
-.if exists(${WDMDIR}/wdm-config.preserve)
- ${MV} ${WDMDIR}/wdm-config.preserve ${WDMDIR}/wdm-config
-.endif
- @${CP} ${WDMDIR}/Xsetup_0 ${WDMDIR}/Xsetup_0.dist
-.if exists(${WDMDIR}/Xsetup_0.preserve)
- ${MV} ${WDMDIR}/Xsetup_0.preserve ${WDMDIR}/Xsetup_0
-.endif
+ @${MV} ${STAGEDIR}${WDMDIR}/wdm-config ${STAGEDIR}${WDMDIR}/wdm-config.dist
+ @${MV} ${STAGEDIR}${WDMDIR}/Xsetup_0 ${STAGEDIR}${WDMDIR}/Xsetup_0.dist
.for file in beastie.xpm daemon1-HQ-1280x960.jpg
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${WDMDIR}/pixmaps
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${STAGEDIR}${WDMDIR}/pixmaps
.endfor
-.if defined(WITH_PAM)
- ${INSTALL_DATA} ${FILESDIR}/wdm.pam ${LOCALBASE}/etc/pam.d/wdm
-.endif
+ ${INSTALL_DATA} ${FILESDIR}/wdm.pam ${STAGEDIR}${LOCALBASE}/etc/pam.d/wdm
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>