aboutsummaryrefslogtreecommitdiff
path: root/x11/wlogout
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-23 12:07:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-03-23 12:07:58 +0000
commit868989880bd8505df7d666313a8f29e7fd3e7dc6 (patch)
treeab1cda8a8520ae285c8259ec23837dfb4aa28361 /x11/wlogout
parent4271acd20bc0e1ecbc3b40330007bca45460c278 (diff)
downloadports-868989880bd8505df7d666313a8f29e7fd3e7dc6.tar.gz
ports-868989880bd8505df7d666313a8f29e7fd3e7dc6.zip
x11/wlogout: add new port
With help from: manu (files/patch-layout) wlogout is a logout menu for wayland environments. https://github.com/ArtsyMacaw/wlogout
Notes
Notes: svn path=/head/; revision=528969
Diffstat (limited to 'x11/wlogout')
-rw-r--r--x11/wlogout/Makefile27
-rw-r--r--x11/wlogout/distinfo3
-rw-r--r--x11/wlogout/files/patch-layout39
-rw-r--r--x11/wlogout/pkg-descr3
-rw-r--r--x11/wlogout/pkg-plist21
5 files changed, 93 insertions, 0 deletions
diff --git a/x11/wlogout/Makefile b/x11/wlogout/Makefile
new file mode 100644
index 000000000000..84a015f6a5fc
--- /dev/null
+++ b/x11/wlogout/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= wlogout
+PORTVERSION= 1.1.1
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland-based logout menu
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= gtk30
+GH_ACCOUNT= ArtsyMacaw
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+OPTIONS_SUB= yes
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+
+.include <bsd.port.mk>
diff --git a/x11/wlogout/distinfo b/x11/wlogout/distinfo
new file mode 100644
index 000000000000..7a4d39f93454
--- /dev/null
+++ b/x11/wlogout/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584164087
+SHA256 (ArtsyMacaw-wlogout-1.1.1_GH0.tar.gz) = cc79c9e2ff1bd225b051a34ccb352bcf8a1991b83414a7db623fce7c49566940
+SIZE (ArtsyMacaw-wlogout-1.1.1_GH0.tar.gz) = 540189
diff --git a/x11/wlogout/files/patch-layout b/x11/wlogout/files/patch-layout
new file mode 100644
index 000000000000..1a7a518f4b39
--- /dev/null
+++ b/x11/wlogout/files/patch-layout
@@ -0,0 +1,39 @@
+--- layout.orig 2020-03-14 05:34:47 UTC
++++ layout
+@@ -6,31 +6,31 @@
+ }
+ {
+ "label" : "hibernate",
+- "action" : "systemctl hibernate",
++ "action" : "acpiconf -s 4",
+ "text" : "Hibernate",
+ "keybind" : "h"
+ }
+ {
+ "label" : "logout",
+- "action" : "loginctl terminate-user $USER",
++ "action" : "kill -9 -1",
+ "text" : "Logout",
+ "keybind" : "e"
+ }
+ {
+ "label" : "shutdown",
+- "action" : "systemctl poweroff",
++ "action" : "shutdown -p now",
+ "text" : "Shutdown",
+ "keybind" : "s"
+ }
+ {
+ "label" : "suspend",
+- "action" : "systemctl suspend",
++ "action" : "zzz",
+ "text" : "Suspend",
+ "keybind" : "u"
+ }
+ {
+ "label" : "reboot",
+- "action" : "systemctl reboot",
++ "action" : "shutdown -r now",
+ "text" : "Reboot",
+ "keybind" : "r"
+ }
diff --git a/x11/wlogout/pkg-descr b/x11/wlogout/pkg-descr
new file mode 100644
index 000000000000..408008e1853c
--- /dev/null
+++ b/x11/wlogout/pkg-descr
@@ -0,0 +1,3 @@
+wlogout is a logout menu for wayland environments.
+
+WWW: https://github.com/ArtsyMacaw/wlogout
diff --git a/x11/wlogout/pkg-plist b/x11/wlogout/pkg-plist
new file mode 100644
index 000000000000..adce77e010e6
--- /dev/null
+++ b/x11/wlogout/pkg-plist
@@ -0,0 +1,21 @@
+bin/wlogout
+%%ETCDIR%%/layout
+%%ETCDIR%%/style.css
+%%MANPAGES%%man/man1/wlogout.1.gz
+%%MANPAGES%%man/man5/wlogout.5.gz
+share/bash-completion/completions/wlogout.bash
+share/fish/completions/wlogout.fish
+%%DATADIR%%/assets/CREDIT.md
+%%DATADIR%%/assets/hibernate.svg
+%%DATADIR%%/assets/lock.svg
+%%DATADIR%%/assets/logout.svg
+%%DATADIR%%/assets/reboot.svg
+%%DATADIR%%/assets/shutdown.svg
+%%DATADIR%%/assets/suspend.svg
+%%DATADIR%%/icons/hibernate.png
+%%DATADIR%%/icons/lock.png
+%%DATADIR%%/icons/logout.png
+%%DATADIR%%/icons/reboot.png
+%%DATADIR%%/icons/shutdown.png
+%%DATADIR%%/icons/suspend.png
+share/zsh/site-functions/_wlogout