aboutsummaryrefslogtreecommitdiff
path: root/x11/wmcliphist
diff options
context:
space:
mode:
authorUlrich Spörlein <uqs@FreeBSD.org>2010-11-25 18:58:20 +0000
committerUlrich Spörlein <uqs@FreeBSD.org>2010-11-25 18:58:20 +0000
commitde464d6a557ea900f37738573c307bd6b9417715 (patch)
tree4769e64a02d3fe5d9db2c912ae4663d2bb425d20 /x11/wmcliphist
parent26411aa5370da36122a9eea521b8251535a2f5cf (diff)
downloadports-de464d6a557ea900f37738573c307bd6b9417715.tar.gz
ports-de464d6a557ea900f37738573c307bd6b9417715.zip
Update wmcliphist to 1.0
- Fix usage of MASTER_SITE_LOCAL - Port now depends on gtk20
Notes
Notes: svn path=/head/; revision=265145
Diffstat (limited to 'x11/wmcliphist')
-rw-r--r--x11/wmcliphist/Makefile10
-rw-r--r--x11/wmcliphist/distinfo5
-rw-r--r--x11/wmcliphist/files/patch-Makefile31
-rw-r--r--x11/wmcliphist/files/patch-history.c24
-rw-r--r--x11/wmcliphist/pkg-descr2
-rw-r--r--x11/wmcliphist/pkg-message4
-rw-r--r--x11/wmcliphist/pkg-plist2
7 files changed, 33 insertions, 45 deletions
diff --git a/x11/wmcliphist/Makefile b/x11/wmcliphist/Makefile
index e6982c7e2fb1..432b8a19cd06 100644
--- a/x11/wmcliphist/Makefile
+++ b/x11/wmcliphist/Makefile
@@ -6,22 +6,22 @@
#
PORTNAME= wmcliphist
-PORTVERSION= 0.6
-PORTREVISION= 3
+PORTVERSION= 1.0
CATEGORIES= x11 windowmaker
MASTER_SITES= http://linux.nawebu.cz/wmcliphist/ \
- http://people.freebsd.org/~uqs/distfiles/
+ ${MASTER_SITE_LOCAL:S/%SUBDIR%/uqs/}
MAINTAINER= uqs@FreeBSD.org
COMMENT= Clipboard history management dockapp for Window Maker
+WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= xpm
-USE_GNOME= gtk12
+USE_GNOME= gtk20
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/.wmcliphistrc ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/wmcliphistrc ${EXAMPLESDIR}
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/x11/wmcliphist/distinfo b/x11/wmcliphist/distinfo
index bf30656704ef..86339749660c 100644
--- a/x11/wmcliphist/distinfo
+++ b/x11/wmcliphist/distinfo
@@ -1,3 +1,2 @@
-MD5 (wmcliphist-0.6.tar.gz) = 6cd9788321eb7c0c72bd00cb76f52789
-SHA256 (wmcliphist-0.6.tar.gz) = a775bea29c11ff06fb7eb43cc21aa2e3aff57a692b1edafbb6ba8ecf417f4148
-SIZE (wmcliphist-0.6.tar.gz) = 88733
+SHA256 (wmcliphist-1.0.tar.gz) = b33a4f2c1f5bf4b177fbc9bc5a4e4fdf31d78097ebd33ea76691025b43908028
+SIZE (wmcliphist-1.0.tar.gz) = 268821
diff --git a/x11/wmcliphist/files/patch-Makefile b/x11/wmcliphist/files/patch-Makefile
index 8120c751554c..3b297e3c13de 100644
--- a/x11/wmcliphist/files/patch-Makefile
+++ b/x11/wmcliphist/files/patch-Makefile
@@ -1,34 +1,21 @@
---- Makefile.orig Mon Jun 23 18:30:16 2003
-+++ Makefile Sat Aug 9 16:09:52 2003
-@@ -1,11 +1,7 @@
--CC = gcc
--
--INCLUDES = `gtk-config --cflags` -I. -Ifoodock -g
--
--DESTDIR = "/usr/local/bin"
-+INCLUDES = `${GTK_CONFIG} --cflags` -I. -Ifoodock
+--- Makefile.orig
++++ Makefile
+@@ -3,7 +3,7 @@
+ INCLUDES = `pkg-config --cflags gtk+-2.0` -I. -Ifoodock
# for normal use
--CFLAGS = -Wall -O2 -ansi -pedantic $(INCLUDES)
+-CFLAGS += -Wall -ansi -pedantic $(INCLUDES)
+CFLAGS += $(INCLUDES)
DEBUG =
# for debuggind purposes
-@@ -15,7 +11,7 @@
- #DEBUG = debug.o
-
-
--LFLAGS = `gtk-config --libs`
-+LFLAGS = `${GTK_CONFIG} --libs`
-
-
- OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o $(DEBUG)
-@@ -27,7 +23,7 @@
+@@ -22,8 +22,8 @@
+ lclint:
lclint $(INCLUDES) +posixlib *.c >lclint.log
wmcliphist: $(OBJECTS) foodock/foodock.o
-- $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock/foodock.o
-+ $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock.o
+- $(CC) $(LDFLAGS) $(OBJECTS) foodock/foodock.o $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJECTS) foodock.o $(LIBS) -o $@
wmcliphist.o: wmcliphist.c wmcliphist.h \
icon/ico_60x60_black.xpm icon/ico_60x60_gray.xpm \
diff --git a/x11/wmcliphist/files/patch-history.c b/x11/wmcliphist/files/patch-history.c
index 876a5a5668a9..158b05a0b265 100644
--- a/x11/wmcliphist/files/patch-history.c
+++ b/x11/wmcliphist/files/patch-history.c
@@ -1,13 +1,13 @@
---- history.c.orig Sun Aug 24 16:59:37 2003
-+++ history.c Mon Dec 20 12:33:42 2004
+--- history.c.orig
++++ history.c
@@ -1,3 +1,5 @@
+#include <sys/types.h>
+#include <sys/stat.h>
#include <wmcliphist.h>
-@@ -182,7 +184,7 @@
- history_load()
+@@ -180,7 +182,7 @@
+ history_load(gboolean dump_only)
{
gchar *buf;
- gint len;
@@ -15,21 +15,25 @@
gint ver;
FILE *f;
gchar *fname;
-@@ -214,7 +216,7 @@
-
+@@ -215,7 +217,7 @@
+ }
while (!feof(f)) {
- if (fread(&len, sizeof(gint), 1, f) != 1)
+ if (fread(&len, sizeof(size_t), 1, f) != 1)
break;
- if (num_items == num_items_to_keep) {
-@@ -299,7 +301,7 @@
+ if (num_items == num_items_to_keep && !dump_only) {
+@@ -306,10 +308,10 @@
+
list_node = g_list_last(history_items);
while (list_node) {
+- int length;
++ size_t length;
hist_item = (HISTORY_ITEM *)list_node->data;
-- if (fwrite(&hist_item->content_len, sizeof(gint), 1, f) != 1) {
-+ if (fwrite(&hist_item->content_len, sizeof(size_t), 1, f) != 1) {
+ length = strlen(hist_item->content);
+- if (fwrite(&length, sizeof(gint), 1, f) != 1) {
++ if (fwrite(&length, sizeof(size_t), 1, f) != 1) {
tmp_errno = E_WRITE;
break;
}
diff --git a/x11/wmcliphist/pkg-descr b/x11/wmcliphist/pkg-descr
index f2c652068c74..767b5427bedc 100644
--- a/x11/wmcliphist/pkg-descr
+++ b/x11/wmcliphist/pkg-descr
@@ -5,5 +5,3 @@ clipboard for pasting to other applications.
WWW: http://linux.nawebu.cz/wmcliphist/
Author: Michal Krause <michal@krause.cz>
-
-- Patrick Li <pat@FreeBSD.org>
diff --git a/x11/wmcliphist/pkg-message b/x11/wmcliphist/pkg-message
index f232b35138b8..6bdae0d079f8 100644
--- a/x11/wmcliphist/pkg-message
+++ b/x11/wmcliphist/pkg-message
@@ -1,7 +1,7 @@
---------------------------------------------------------------------
Before using this program, edit
-%%EXAMPLESDIR%%/.wmcliphistrc
+%%EXAMPLESDIR%%/wmcliphistrc
-and copy to your home directory.
+and copy it to ~/.wmcliphistrc
---------------------------------------------------------------------
diff --git a/x11/wmcliphist/pkg-plist b/x11/wmcliphist/pkg-plist
index 5c06747674ec..1bc416c26f1f 100644
--- a/x11/wmcliphist/pkg-plist
+++ b/x11/wmcliphist/pkg-plist
@@ -1,5 +1,5 @@
bin/wmcliphist
-share/examples/wmcliphist/.wmcliphistrc
+share/examples/wmcliphist/wmcliphistrc
%%PORTDOCS%%share/doc/wmcliphist/README
@dirrm share/examples/wmcliphist
%%PORTDOCS%%@dirrm share/doc/wmcliphist