aboutsummaryrefslogtreecommitdiff
path: root/x11/xcmd
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 08:57:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 08:57:54 +0000
commit505ecaca2e8149ebc6b38ad48a9ff3b5f97b9617 (patch)
tree499ea62e231f88310346457adc6afae37f6d874f /x11/xcmd
parent07ab3ccfac4d9799e05b162fab483bf1e4f0f25e (diff)
downloadports-505ecaca2e8149ebc6b38ad48a9ff3b5f97b9617.tar.gz
ports-505ecaca2e8149ebc6b38ad48a9ff3b5f97b9617.zip
add xcmd
Xcmd is a front-end for starting programs under X11 PR: 29326 Submitted by: Oliver Breuninger <ob@breuninger.org>
Notes
Notes: svn path=/head/; revision=46428
Diffstat (limited to 'x11/xcmd')
-rw-r--r--x11/xcmd/Makefile22
-rw-r--r--x11/xcmd/distinfo1
-rw-r--r--x11/xcmd/files/patch-a14
-rw-r--r--x11/xcmd/pkg-comment1
-rw-r--r--x11/xcmd/pkg-descr9
-rw-r--r--x11/xcmd/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/x11/xcmd/Makefile b/x11/xcmd/Makefile
new file mode 100644
index 000000000000..590afdb61396
--- /dev/null
+++ b/x11/xcmd/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: xcmd
+# Date created: 30 Jul 2001
+# Whom: Oliver Breuninger <ob@breuninger.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcmd
+PORTVERSION= 1.8
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://www.breuninger.org/files/distfiles/
+MASTER_SITE_SUBDIR= X11/xutils
+
+MAINTAINER= ob@breuninger.org
+
+USE_IMAKE= yes
+
+MANCOMPRESSED= yes
+MAN1= xcmd.1
+
+.include <bsd.port.mk>
diff --git a/x11/xcmd/distinfo b/x11/xcmd/distinfo
new file mode 100644
index 000000000000..cab52ab28a7f
--- /dev/null
+++ b/x11/xcmd/distinfo
@@ -0,0 +1 @@
+MD5 (xcmd-1.8.tar.gz) = f843b34b043bc6e62769b24a3af09a1a
diff --git a/x11/xcmd/files/patch-a b/x11/xcmd/files/patch-a
new file mode 100644
index 000000000000..8e22d97fe7dc
--- /dev/null
+++ b/x11/xcmd/files/patch-a
@@ -0,0 +1,14 @@
+--- Imakefile.orig Fri Mar 27 04:57:00 1998
++++ Imakefile Mon Jul 30 12:51:43 2001
+@@ -21,11 +21,5 @@
+ HDRS = $(PROGNAME).h dsimple.h
+ MANS = $(PROGNAME).man
+- SPEC = $(PROGNAME).spec
+- LSMS = $(PROGNAME).lsm
+
+- TARDIR = $(PROGNAME)-$(VERSION)
+- TARSFX = .tar.gz
+- TARBAL = $(TARDIR)$(TARSFX)
+-
+ ComplexProgramTarget($(PROGNAME))
+
diff --git a/x11/xcmd/pkg-comment b/x11/xcmd/pkg-comment
new file mode 100644
index 000000000000..62d4bbaafd95
--- /dev/null
+++ b/x11/xcmd/pkg-comment
@@ -0,0 +1 @@
+Xcmd is a front-end for starting programs under X11
diff --git a/x11/xcmd/pkg-descr b/x11/xcmd/pkg-descr
new file mode 100644
index 000000000000..f73163764c76
--- /dev/null
+++ b/x11/xcmd/pkg-descr
@@ -0,0 +1,9 @@
+Xcmd is a front-end for starting programs under X11.
+You can tell xcmd to look for a window with a specific
+class, resource name, or title string (using the
+`--find-<property>' options); if it finds one or more,
+xcmd will `raise' them, otherwise it will run the
+command you specify. You can tell xcmd to run commands
+that create their own windows (using `--xcmd'), or to
+run commands inside a terminal window (using `--cmd')
+with various options.
diff --git a/x11/xcmd/pkg-plist b/x11/xcmd/pkg-plist
new file mode 100644
index 000000000000..9101cd28bd26
--- /dev/null
+++ b/x11/xcmd/pkg-plist
@@ -0,0 +1 @@
+bin/xcmd