aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-conf/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11/xfce4-conf/Makefile
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
- Convert complete XFCE to new options framework
While here some extra work: - Remove 6.X gruft - Correct NOPORTDOCS - Pet portlint - Whitespaces fixes Reviewed by: beat, bapt (thx!)
Notes
Notes: svn path=/head/; revision=297800
Diffstat (limited to 'x11/xfce4-conf/Makefile')
-rw-r--r--x11/xfce4-conf/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 6c35952f44f4..12b48478788e 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -28,23 +28,21 @@ USE_XORG= x11
CONFIGURE_ARGS+=--disable-gtk-doc-html
-OPTIONS= APIDOCS "Install api documentation" off \
- PERL "Install Perl bindings" off \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= DOCS PERL NLS
MAN3PREFIX?= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
MAN3= Xfce4::Xfconf.3
BUILD_DEPENDS+= p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1.12:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
@@ -57,7 +55,7 @@ CONFIGURE_ARGS+=--disable-perl-bindings
PLIST_SUB+= PERLBIND="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -66,4 +64,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>