aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-conf/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-10-28 15:31:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-10-28 15:31:02 +0000
commit730a6e5fb9d9a33a7319d6253fca12f4971dda7f (patch)
tree8f2310866c4fbd8566ecad62f01f5f60deb1f247 /x11/xfce4-conf/Makefile
parentd4cb892dc9d8a5ef3de1a247bb2a460217fc80dc (diff)
downloadports-730a6e5fb9d9a33a7319d6253fca12f4971dda7f.tar.gz
ports-730a6e5fb9d9a33a7319d6253fca12f4971dda7f.zip
- Fix build
- Add new option - Bump PORTREVISION PR: 160796 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Notes
Notes: svn path=/head/; revision=284538
Diffstat (limited to 'x11/xfce4-conf/Makefile')
-rw-r--r--x11/xfce4-conf/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index bc1baa87d43a..34bdb4fef604 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-conf
PORTVERSION= 4.8.0
+PORTREVISION= 1
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= xfconf-${PORTVERSION}
@@ -26,10 +27,7 @@ USE_LDCONFIG= yes
USE_XFCE= configenv libutil
USE_XORG= x11
-CONFIGURE_ARGS= --enable-gtk-doc-html=no \
- --disable-debug
-
-OPTIONS= GTKDOC "install the library documentation" off \
+OPTIONS= APIDOCS "Install api documentation" off \
PERL "Install Perl bindings" off \
NLS "Enable Native Language Support" on
@@ -37,6 +35,14 @@ MAN3PREFIX?= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_APIDOCS)
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
+.else
+CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
+PLIST_SUB+= APIDOCS=""
+.endif
+
.if defined(WITH_PERL)
MAN3= Xfce4::Xfconf.3
BUILD_DEPENDS+= p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
@@ -50,13 +56,6 @@ CONFIGURE_ARGS+=--disable-perl-bindings
PLIST_SUB+= PERLBIND="@comment "
.endif
-.if defined(WITH_GTKDOC)
-BUILD_DEPENDS+= gtkdocize:${PORTSDIR}/textproc/gtk-doc
-CONFIGURE_ARGS+=--enable-gtk-doc
-.else
-CONFIGURE_ARGS+=--disable-gtk-doc
-.endif
-
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls