aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-terminal/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /x11/xfce4-terminal/Makefile
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
downloadports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.gz
ports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Notes
Notes: svn path=/head/; revision=490953
Diffstat (limited to 'x11/xfce4-terminal/Makefile')
-rw-r--r--x11/xfce4-terminal/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index ea46aad9ee17..34709614ce3f 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-terminal
PORTVERSION= 0.8.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R:R}
DIST_SUBDIR= xfce4
@@ -14,16 +14,25 @@ COMMENT= Terminal emulator for the X windowing system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
+LIB_DEPENDS= libpcre2-8.so:devel/pcre2 \
+ libgnutls.so:security/gnutls
-USES= gettext gmake pkgconfig tar:bzip2 xfce:gtk3
-GNU_CONFIGURE= yes
-USE_GNOME= gtk30 glib20 cairo gdkpixbuf2 intltool vte3 libxml2
+#libdbus-glib-1.so:devel/dbus-glib XXX check
+
+USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce:gtk3
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool libxml2 vte3
USE_XFCE= libmenu
-USE_XORG= x11
+USE_XORG= ice sm x11
+
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
-
CONFIGURE_ARGS= --without-gnome-default-appsdir
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+
.include <bsd.port.mk>